summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-01-21 17:26:07 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-01-21 17:26:07 +0000
commitecd65c9b297517b01dc26d5064a653aed35bf874 (patch)
treeb7a62b22b85edef6c9d1312f7c7f7698af405cfe /sys-devel/autoconf
parentRemoving all directfb support (diff)
downloadgentoo-2-ecd65c9b297517b01dc26d5064a653aed35bf874.tar.gz
gentoo-2-ecd65c9b297517b01dc26d5064a653aed35bf874.tar.bz2
gentoo-2-ecd65c9b297517b01dc26d5064a653aed35bf874.zip
new version
Diffstat (limited to 'sys-devel/autoconf')
-rw-r--r--sys-devel/autoconf/ChangeLog7
-rw-r--r--sys-devel/autoconf/autoconf-2.57.ebuild139
-rw-r--r--sys-devel/autoconf/files/ac-wrapper.pl4
-rw-r--r--sys-devel/autoconf/files/autoconf-2.57-infopage-namechange.patch107
-rw-r--r--sys-devel/autoconf/files/digest-autoconf-2.572
5 files changed, 256 insertions, 3 deletions
diff --git a/sys-devel/autoconf/ChangeLog b/sys-devel/autoconf/ChangeLog
index 9345cecc7a53..0b7444412109 100644
--- a/sys-devel/autoconf/ChangeLog
+++ b/sys-devel/autoconf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/autoconf
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.14 2003/01/17 11:35:12 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.15 2003/01/21 17:25:54 azarah Exp $
+
+autoconf-2.57 (21 Jan 2003)
+
+ 21 Jan 2003; Martin Schlemmer <azarah@gentoo.org> autoconf-2.57.ebuild :
+ New version.
17 Jan 2003; Martin Schlemmer <azarah@gentoo.org> autoconf-2.54.ebuild :
Depend on texinfo-4.3, else info pages breaks, bug #13041.
diff --git a/sys-devel/autoconf/autoconf-2.57.ebuild b/sys-devel/autoconf/autoconf-2.57.ebuild
new file mode 100644
index 000000000000..1a54ae1a3571
--- /dev/null
+++ b/sys-devel/autoconf/autoconf-2.57.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.57.ebuild,v 1.1 2003/01/21 17:25:54 azarah Exp $
+
+IUSE=""
+
+inherit eutils
+
+OLD_PV="2.13"
+OLD_P="${PN}-${OLD_PV}"
+S="${WORKDIR}/${P}"
+OLD_S="${WORKDIR}/${OLD_P}"
+DESCRIPTION="Used to create autoconfiguration files"
+SRC_URI="ftp://ftp.gnu.org/gnu/${PN}/${P}.tar.bz2
+ ftp://ftp.gnu.org/gnu/${PN}/${OLD_P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
+
+LICENSE="GPL-2"
+SLOT="2.5"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND=">=sys-apps/texinfo-4.3
+ >=sys-devel/m4-1.4p
+ sys-devel/perl"
+
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${OLD_S}
+ epatch ${FILESDIR}/${OLD_P}-configure-gentoo.diff
+ epatch ${FILESDIR}/${OLD_P}-configure.in-gentoo.diff
+
+ cd ${S}
+ # Enable both autoconf-2.1 and autoconf-2.5 info pages
+ epatch ${FILESDIR}/${PN}-2.57-infopage-namechange.patch
+ ln -snf ${S}/doc/autoconf.texi ${S}/doc/autoconf25.texi
+}
+
+src_compile() {
+
+ #
+ # ************ autoconf-2.5x ************
+ #
+ cd ${S}
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake || die
+
+ #
+ # ************ autoconf-2.13 ************
+ #
+ cd ${OLD_S}
+
+ perl -pi -e 's|\* Autoconf:|\* Autoconf v2.1:|' autoconf.texi
+ cp autoconf.texi autoconf.texi.orig
+ sed -e '/START-INFO-DIR-ENTRY/ i INFO-DIR-SECTION GNU programming tools' \
+ autoconf.texi.orig > autoconf.texi
+
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake || die
+}
+
+src_install() {
+
+ # install wrapper script for autodetecting the proper version
+ # to use.
+ exeinto /usr/lib/${PN}
+ doexe ${FILESDIR}/ac-wrapper.pl
+ dosed "s:2\.5x:${PV}:g" /usr/lib/${PN}/ac-wrapper.pl
+
+ #
+ # ************ autoconf-2.5x ************
+ #
+
+ # need to use 'DESTDIR' here, else perl stuff puke
+ cd ${S}
+ make DESTDIR=${D} \
+ install || die
+
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames autom4te
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${PV}
+ done
+ # new in 2.5x
+ dosym ../lib/${PN}/ac-wrapper.pl /usr/bin/autom4te
+
+# mv ${D}/usr/share/info/autoconf.info ${D}/usr/share/info/autoconf-2.5.info
+
+ docinto ${PV}
+ dodoc COPYING AUTHORS BUGS NEWS README TODO THANKS
+ dodoc ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
+
+ #
+ # ************ autoconf-2.13 ************
+ #
+
+ # need to use 'prefix' here, else we get sandbox problems
+ cd ${OLD_S}
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${OLD_PV}
+ dosym ../lib/${PN}/ac-wrapper.pl /usr/bin/${x}
+ done
+
+ docinto ${OLD_PV}
+ dodoc COPYING AUTHORS NEWS README TODO
+ dodoc ChangeLog ChangeLog.0 ChangeLog.1
+
+ # from binutils
+ rm -f ${D}/usr/share/info/standards.info*
+}
+
+pkg_preinst() {
+
+ # remove these to make sure symlinks install properly if old versions
+ # was binaries
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames autom4te
+ do
+ if [ -e /usr/bin/${x} ]
+ then
+ rm -f /usr/bin/${x}
+ fi
+ done
+}
+
diff --git a/sys-devel/autoconf/files/ac-wrapper.pl b/sys-devel/autoconf/files/ac-wrapper.pl
index 29005d259501..7b9bcb71bb0f 100644
--- a/sys-devel/autoconf/files/ac-wrapper.pl
+++ b/sys-devel/autoconf/files/ac-wrapper.pl
@@ -42,10 +42,10 @@ if (!$ENV{WANT_AUTOCONF_2_1}) {
if (-x $binary_new # user may have only 2.13
&& ($ENV{WANT_AUTOCONF_2_5}
|| -r 'configure.ac'
- || (cat_('configure.in') =~ /^\s*AC_PREREQ\(\[?([^\)]{3})[^\)]*\)/m ? $1 : '') gt '2.1'
+ || (cat_('configure.in') =~ /^\s*AC_PREREQ\(\[?([^\)]{3})[^\)]*\]?\)/m ? $1 : '') gt '2.1'
|| (cat_('configure') =~ /^# Generated by Autoconf (\S+)/m ? $1 : '') gt '2.1'
|| (cat_('Makefile.in') =~ /^# Makefile\.in generated by automake (\S+)/ ? $1 : '') ge '1.6'
- || (cat_('aclocal.m4') =~ /^\s*AC_PREREQ\(\[?([^\)]{3})[^\)]*\)/m ? $1 : '') gt '2.1')) {
+ || (cat_('aclocal.m4') =~ /^\s*AC_PREREQ\(\[?([^\)]{3})[^\)]*\]?\)/m ? $1 : '') gt '2.1')) {
$ENV{WANT_AUTOCONF_2_5} = 1; # to prevent further "cats" and to enhance consistency (possible cwd etc)
$binary = $binary_new;
} else {
diff --git a/sys-devel/autoconf/files/autoconf-2.57-infopage-namechange.patch b/sys-devel/autoconf/files/autoconf-2.57-infopage-namechange.patch
new file mode 100644
index 000000000000..f7f6cbc98042
--- /dev/null
+++ b/sys-devel/autoconf/files/autoconf-2.57-infopage-namechange.patch
@@ -0,0 +1,107 @@
+--- autoconf-2.57/doc/autoconf.texi.orig 2003-01-20 21:25:17.000000000 +0200
++++ autoconf-2.57/doc/autoconf.texi 2003-01-20 21:29:26.000000000 +0200
+@@ -1,9 +1,9 @@
+ \input texinfo @c -*-texinfo-*-
+ @comment ========================================================
+ @comment %**start of header
+-@setfilename autoconf.info
++@setfilename autoconf25.info
+ @include version.texi
+-@settitle Autoconf
++@settitle Autoconf v2.5
+ @setchapternewpage odd
+ @setcontentsaftertitlepage
+ @finalout
+@@ -97,35 +97,35 @@
+
+ @dircategory GNU programming tools
+ @direntry
+-* Autoconf: (autoconf). Create source code configuration scripts
++* Autoconf v2.5: (autoconf25). Create source code configuration scripts
+ @end direntry
+
+ @dircategory Individual utilities
+ @direntry
+-* autoscan: (autoconf)autoscan Invocation.
++* autoscan: (autoconf25)autoscan Invocation.
+ Semi-automatic @file{configure.ac} writing
+-* ifnames: (autoconf)ifnames Invocation.
++* ifnames: (autoconf25)ifnames Invocation.
+ Listing the conditionals in source code
+-* autoconf: (autoconf)autoconf Invocation.
++* autoconf: (autoconf25)autoconf Invocation.
+ How to create configuration scripts
+-* autoreconf: (autoconf)autoreconf Invocation.
++* autoreconf: (autoconf25)autoreconf Invocation.
+ Remaking multiple @command{configure} scripts
+-* autoheader: (autoconf)autoheader Invocation.
++* autoheader: (autoconf25)autoheader Invocation.
+ How to create configuration templates
+-* autom4te: (autoconf)autom4te Invocation.
++* autom4te: (autoconf25)autom4te Invocation.
+ The Autoconf executables backbone
+-* configure: (autoconf)configure Invocation.
++* configure: (autoconf25)configure Invocation.
+ Configuring a package
+-* autoupdate: (autoconf)autoupdate Invocation.
++* autoupdate: (autoconf25)autoupdate Invocation.
+ Automatic update of @file{configure.ac}
+-* config.status: (autoconf)config.status Invocation.
++* config.status: (autoconf25)config.status Invocation.
+ Recreating a configuration
+-* testsuite: (autoconf)testsuite Invocation.
++* testsuite: (autoconf25)testsuite Invocation.
+ Running an Autotest test suite
+ @end direntry
+
+ @titlepage
+-@title Autoconf
++@title Autoconf v2.5
+ @subtitle Creating Automatic Configuration Scripts
+ @subtitle for version @value{VERSION}, @value{UPDATED}
+ @author David MacKenzie
+--- autoconf-2.57/doc/Makefile.in.orig 2003-01-20 21:29:55.000000000 +0200
++++ autoconf-2.57/doc/Makefile.in 2003-01-20 21:31:12.000000000 +0200
+@@ -96,7 +96,7 @@
+ TEXI2HTML = texi2html
+ TEXI2HTML_FLAGS = -split_chapter
+
+-info_TEXINFOS = autoconf.texi standards.texi
++info_TEXINFOS = autoconf25.texi standards.texi
+ autoconf_TEXINFOS = fdl.texi install.texi
+ standards_TEXINFOS = make-stds.texi
+
+@@ -113,11 +113,11 @@
+ DIST_SOURCES =
+ TEXINFO_TEX = $(top_srcdir)/config/texinfo.tex
+ am__TEXINFO_TEX_DIR = $(top_srcdir)/config
+-INFO_DEPS = autoconf.info standards.info
++INFO_DEPS = autoconf25.info standards.info
+ DVIS = autoconf.dvi standards.dvi
+ PDFS = autoconf.pdf standards.pdf
+ PSS = autoconf.ps standards.ps
+-TEXINFOS = autoconf.texi standards.texi
++TEXINFOS = autoconf25.texi standards.texi
+ DIST_COMMON = $(autoconf_TEXINFOS) $(standards_TEXINFOS) Makefile.am \
+ Makefile.in stamp-vti version.texi
+ all: all-am
+@@ -144,13 +144,13 @@
+ TEXINPUTS="$(am__TEXINFO_TEX_DIR)$(PATH_SEPARATOR)$$TEXINPUTS" \
+ MAKEINFO='$(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir)' \
+ $(TEXI2PDF) `test -f '$<' || echo '$(srcdir)/'`$<
+-autoconf.info: autoconf.texi version.texi $(autoconf_TEXINFOS)
+-autoconf.dvi: autoconf.texi version.texi $(autoconf_TEXINFOS)
+-autoconf.pdf: autoconf.texi version.texi $(autoconf_TEXINFOS)
++autoconf25.info: autoconf25.texi version.texi $(autoconf_TEXINFOS)
++autoconf.dvi: autoconf25.texi version.texi $(autoconf_TEXINFOS)
++autoconf.pdf: autoconf25.texi version.texi $(autoconf_TEXINFOS)
+ version.texi: stamp-vti
+-stamp-vti: autoconf.texi $(top_srcdir)/configure
+- @(dir=.; test -f ./autoconf.texi || dir=$(srcdir); \
+- set `$(SHELL) $(top_srcdir)/config/mdate-sh $$dir/autoconf.texi`; \
++stamp-vti: autoconf25.texi $(top_srcdir)/configure
++ @(dir=.; test -f ./autoconf25.texi || dir=$(srcdir); \
++ set `$(SHELL) $(top_srcdir)/config/mdate-sh $$dir/autoconf25.texi`; \
+ echo "@set UPDATED $$1 $$2 $$3"; \
+ echo "@set UPDATED-MONTH $$2 $$3"; \
+ echo "@set EDITION $(VERSION)"; \
diff --git a/sys-devel/autoconf/files/digest-autoconf-2.57 b/sys-devel/autoconf/files/digest-autoconf-2.57
new file mode 100644
index 000000000000..8c1eeddbdd02
--- /dev/null
+++ b/sys-devel/autoconf/files/digest-autoconf-2.57
@@ -0,0 +1,2 @@
+MD5 407ea53787ce13f5ca427e9a51e05bc2 autoconf-2.57.tar.bz2 811439
+MD5 9de56d4a161a723228220b0f425dc711 autoconf-2.13.tar.gz 443844