summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-10-16 01:38:59 +0000
committerMike Frysinger <vapier@gentoo.org>2006-10-16 01:38:59 +0000
commit02d36877f9171243c27b16cede9b016d5c828ac7 (patch)
treee2ba43c2abc9a6f6444de3b604e6e10fda95ae80 /sys-devel/automake-wrapper
parentMarking amd64, sparc stable; cleaning out old ebuilds (diff)
downloadgentoo-2-02d36877f9171243c27b16cede9b016d5c828ac7.tar.gz
gentoo-2-02d36877f9171243c27b16cede9b016d5c828ac7.tar.bz2
gentoo-2-02d36877f9171243c27b16cede9b016d5c828ac7.zip
Include support for automake-1.10.
(Portage version: 2.1.2_pre2-r9)
Diffstat (limited to 'sys-devel/automake-wrapper')
-rw-r--r--sys-devel/automake-wrapper/ChangeLog13
-rw-r--r--sys-devel/automake-wrapper/automake-wrapper-2.ebuild29
-rwxr-xr-xsys-devel/automake-wrapper/files/am-wrapper-2.sh135
-rw-r--r--sys-devel/automake-wrapper/files/digest-automake-wrapper-21
4 files changed, 171 insertions, 7 deletions
diff --git a/sys-devel/automake-wrapper/ChangeLog b/sys-devel/automake-wrapper/ChangeLog
index 6c9c5382e878..9470bff49063 100644
--- a/sys-devel/automake-wrapper/ChangeLog
+++ b/sys-devel/automake-wrapper/ChangeLog
@@ -1,13 +1,12 @@
# ChangeLog for sys-devel/automake-wrapper
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake-wrapper/ChangeLog,v 1.11 2006/03/30 13:43:51 flameeyes Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake-wrapper/ChangeLog,v 1.12 2006/10/16 01:38:59 vapier Exp $
- 30 Mar 2006; Diego Pettenò <flameeyes@gentoo.org>
- automake-wrapper-1-r1.ebuild:
- Add ~x86-fbsd keyword.
+*automake-wrapper-2 (16 Oct 2006)
- 15 Feb 2005; Kito <kito@gentoo.org> automake-wrapper-1-r1.ebuild:
- ~ppc-macos keyword
+ 16 Oct 2006; Mike Frysinger <vapier@gentoo.org> +files/am-wrapper-2.sh,
+ +automake-wrapper-2.ebuild:
+ Include support for automake-1.10.
*automake-wrapper-1-r1 (08 Feb 2004)
diff --git a/sys-devel/automake-wrapper/automake-wrapper-2.ebuild b/sys-devel/automake-wrapper/automake-wrapper-2.ebuild
new file mode 100644
index 000000000000..0fa7e70d0e28
--- /dev/null
+++ b/sys-devel/automake-wrapper/automake-wrapper-2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake-wrapper/automake-wrapper-2.ebuild,v 1.1 2006/10/16 01:38:59 vapier Exp $
+
+inherit multilib
+
+DESCRIPTION="wrapper for automake to manage multiple automake versions"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+S=${WORKDIR}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/misc
+ newexe "${FILESDIR}"/am-wrapper-${PV}.sh am-wrapper.sh || die
+
+ keepdir /usr/share/aclocal
+
+ dodir /usr/bin
+ local x=
+ for x in aclocal automake ; do
+ dosym ../$(get_libdir)/misc/am-wrapper.sh /usr/bin/${x}
+ done
+}
diff --git a/sys-devel/automake-wrapper/files/am-wrapper-2.sh b/sys-devel/automake-wrapper/files/am-wrapper-2.sh
new file mode 100755
index 000000000000..e3d84a884283
--- /dev/null
+++ b/sys-devel/automake-wrapper/files/am-wrapper-2.sh
@@ -0,0 +1,135 @@
+#!/bin/bash
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake-wrapper/files/am-wrapper-2.sh,v 1.1 2006/10/16 01:38:59 vapier Exp $
+
+# Based on the am-wrapper.pl script provided by MandrakeSoft
+# Rewritten in bash by Gregorio Guidi
+#
+# Executes the correct automake version.
+#
+# - defaults to automake-1.10
+# - runs automake-1.9 if:
+# - envvar WANT_AUTOMAKE is set to `1.9'
+# -or-
+# - `Makefile.in' was generated by automake-1.9
+# -or-
+# - 'aclocal.m4' contain AM_AUTOMAKE_VERSION, specifying the use of 1.9
+# - runs automake-1.8 if:
+# - envvar WANT_AUTOMAKE is set to `1.8'
+# -or-
+# - `Makefile.in' was generated by automake-1.8
+# -or-
+# - 'aclocal.m4' contain AM_AUTOMAKE_VERSION, specifying the use of 1.8
+# - runs automake-1.7 if:
+# - envvar WANT_AUTOMAKE is set to `1.7'
+# -or-
+# - `Makefile.in' was generated by automake-1.7
+# -or-
+# - 'aclocal.m4' contain AM_AUTOMAKE_VERSION, specifying the use of 1.7
+# - runs automake-1.6 if:
+# - envvar WANT_AUTOMAKE is set to `1.6'
+# -or-
+# - `Makefile.in'
+# -or-
+# - 'aclocal.m4' contain AM_AUTOMAKE_VERSION, specifying the use of 1.6
+# - runs automake-1.5 if:
+# - envvar WANT_AUTOMAKE is set to `1.5'
+# -or-
+# - `Makefile.in' was generated by automake-1.5
+# -or-
+# - 'aclocal.m4' contain AM_AUTOMAKE_VERSION, specifying the use of 1.5
+# - runs automake-1.4 if:
+# - envvar WANT_AUTOMAKE is set to `1.4'
+# -or-
+# - `Makefile.in' was generated by automake-1.4
+# -or-
+# - 'aclocal.m4' contain AM_AUTOMAKE_VERSION, specifying the use of 1.4
+
+if [ "${0##*/}" = "am-wrapper.sh" ] ; then
+ echo "Don't call this script directly." >&2
+ exit 1
+fi
+
+vers="1.10 1.9 1.8 1.7 1.6 1.5 1.4"
+
+for v in ${vers} ; do
+ eval binary_${v/./_}="${0}-${v}"
+done
+binary="${binary_1_10}"
+
+#
+# Check the WANT_AUTOMAKE setting
+#
+for v in ${vers} x ; do
+ if [ "${v}" = "x" ] ; then
+ unset WANT_AUTOMAKE
+ break
+ fi
+
+ if [ "${WANT_AUTOMAKE}" = "${v}" ] ; then
+ binary="binary_${v/./_}"
+ binary="${!binary}"
+ break
+ fi
+done
+
+do_awk() {
+ local file=$1 ; shift
+ local arg=$1 ; shift
+ echo $(gawk "{ if (match(\$0, \"$*\", res)) { print res[${arg}]; exit } }" ${file})
+}
+
+#
+# autodetect routine
+#
+if [ -z "${WANT_AUTOMAKE}" ] ; then
+ if [ -r "Makefile.in" ] ; then
+ confversion_mf=$(do_awk Makefile.in 2 "^# Makefile.in generated (automatically )?by automake ([0-9].[0-9]+)")
+ fi
+ if [ -r "aclocal.m4" ] ; then
+ confversion_ac=$(do_awk aclocal.m4 1 'generated automatically by aclocal ([0-9].[0-9]+)')
+ confversion_am=$(do_awk aclocal.m4 1 '[[:space:]]*\\[?AM_AUTOMAKE_VERSION\\(\\[?([0-9].[0-9]+)[^)]*\\]?\\)')
+ fi
+
+ for v in ${vers} ; do
+ if [ "${confversion_mf}" = "${v}" ] \
+ || [ "${confversion_ac}" = "${v}" ] \
+ || [ "${confversion_am}" = "${v}" ] ; then
+ binary="binary_${v/./_}"
+ binary="${!binary}"
+ break
+ fi
+ done
+fi
+
+if [ "${WANT_AMWRAPPER_DEBUG}" ] ; then
+ if [ "${WANT_AUTOMAKE}" ] ; then
+ echo "am-wrapper: DEBUG: WANT_AUTOMAKE is set to ${WANT_AUTOMAKE}" >&2
+ fi
+ echo "am-wrapper: DEBUG: will execute <$binary>" >&2
+fi
+
+#
+# for further consistency
+#
+for v in ${vers} ; do
+ mybin="binary_${v/./_}"
+ if [ "${binary}" = "${!mybin}" ] ; then
+ export WANT_AUTOMAKE="${v}"
+ fi
+done
+
+#
+# Now try to run the binary
+#
+if [ ! -x "${binary}" ] ; then
+ echo "am-wrapper: $binary is missing or not executable." >&2
+ echo " Please try emerging the correct version of automake." >&2
+ exit 1
+fi
+
+exec "$binary" "$@"
+
+echo "am-wrapper: was unable to exec $binary !?" >&2
+exit 1
diff --git a/sys-devel/automake-wrapper/files/digest-automake-wrapper-2 b/sys-devel/automake-wrapper/files/digest-automake-wrapper-2
new file mode 100644
index 000000000000..8b137891791f
--- /dev/null
+++ b/sys-devel/automake-wrapper/files/digest-automake-wrapper-2
@@ -0,0 +1 @@
+