summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-08-26 21:09:13 +0000
committerMike Frysinger <vapier@gentoo.org>2007-08-26 21:09:13 +0000
commitcb7d2811202041187c226c26b6bfeee310b88564 (patch)
tree0cf99ba0ef133977542eff2de22f6f4e35474562 /sys-devel/automake/files
parentChange kernel-version parsing to be more robust, now using versionator.eclass... (diff)
downloadgentoo-2-cb7d2811202041187c226c26b6bfeee310b88564.tar.gz
gentoo-2-cb7d2811202041187c226c26b6bfeee310b88564.tar.bz2
gentoo-2-cb7d2811202041187c226c26b6bfeee310b88564.zip
Fix false positive in depcomp2 caused by newer autoconf versions #181484.
(Portage version: 2.1.3.7)
Diffstat (limited to 'sys-devel/automake/files')
-rw-r--r--sys-devel/automake/files/automake-1.5-test-fixes.patch29
1 files changed, 20 insertions, 9 deletions
diff --git a/sys-devel/automake/files/automake-1.5-test-fixes.patch b/sys-devel/automake/files/automake-1.5-test-fixes.patch
index 91d114d30d8a..8f34a793e450 100644
--- a/sys-devel/automake/files/automake-1.5-test-fixes.patch
+++ b/sys-devel/automake/files/automake-1.5-test-fixes.patch
@@ -4,26 +4,29 @@ http://bugs.gentoo.org/79505
insthook:
update the head/tail syntax since coreutils has deprecated the old style
+dirname:
+just disable the pos
+
ccnoco:
rip patches from fedora
-dirname:
-just disable the pos
+depcomp2: #181484
+fix false positive when using newer autoconf -- it throws a warning based
+on dataroot which causes a failure when there was none
---- automake-1.5/tests/insthook.test.orig 2005-01-30 09:02:48.622592064 -0500
-+++ automake-1.5/tests/insthook.test 2005-01-30 09:03:00.332811840 -0500
+--- automake-1.5/tests/insthook.test
++++ automake-1.5/tests/insthook.test
@@ -17 +17 @@
-test x$lnum != x && tail +$lnum Makefile.in | head -3 | grep install-exec-hook
+test x$lnum != x && tail -n +$lnum Makefile.in | head -n 3 | grep install-exec-hook
-diff -u automake-1.5/tests/dirname.test automake-1.6.3/tests/dirname.test
---- automake-1.5/tests/dirname.test 2003-04-25 15:44:56.000000000 +0900
-+++ automake-1.6.3/tests/dirname.test 2003-04-25 15:44:56.000000000 +0900
+--- automake-1.5/tests/dirname.test
++++ automake-1.5/tests/dirname.test
@@ -1,2 +1,3 @@
#! /bin/sh
+exit 0
---- automake-1.5/tests/ccnoco.test 2003-06-07 06:34:18.000000000 +0900
-+++ automake-1.6.3/tests/ccnoco.test 2003-06-07 06:34:18.000000000 +0900
+--- automake-1.5/tests/ccnoco.test
++++ automake-1.5/tests/ccnoco.test
@@ -39,7 +39,6 @@
}
END
@@ -52,3 +55,11 @@ diff -u automake-1.5/tests/dirname.test automake-1.6.3/tests/dirname.test
for conf in configure.1 configure.3; do
cp $conf configure.in
+--- automake-1.5/tests/depcomp2.test
++++ automake-1.5/tests/depcomp2.test
+@@ -17,4 +17,5 @@
+ cat > Makefile.am << 'END'
+ SUBDIRS = subdir
++datarootdir = @datarootdir@
+ END
+