summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-23 23:58:59 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-23 23:58:59 +0000
commit25dfb70bd6845a47efa518dd8d5c9e5cdfd6d873 (patch)
tree63bce010d9eba93ddcf0ea3629addc82c6496165 /sys-devel/automake
parentstabilize (diff)
downloadgentoo-2-25dfb70bd6845a47efa518dd8d5c9e5cdfd6d873.tar.gz
gentoo-2-25dfb70bd6845a47efa518dd8d5c9e5cdfd6d873.tar.bz2
gentoo-2-25dfb70bd6845a47efa518dd8d5c9e5cdfd6d873.zip
touchup syntax, quoting, etc...
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-devel/automake')
-rw-r--r--sys-devel/automake/automake-1.4_p6.ebuild15
-rw-r--r--sys-devel/automake/automake-1.5.ebuild19
-rw-r--r--sys-devel/automake/automake-1.6.3.ebuild7
-rw-r--r--sys-devel/automake/automake-1.7.9-r1.ebuild9
-rw-r--r--sys-devel/automake/automake-1.8.5-r3.ebuild9
-rw-r--r--sys-devel/automake/automake-1.9.5.ebuild9
6 files changed, 31 insertions, 37 deletions
diff --git a/sys-devel/automake/automake-1.4_p6.ebuild b/sys-devel/automake/automake-1.4_p6.ebuild
index 17138e801102..03aae43478e5 100644
--- a/sys-devel/automake/automake-1.4_p6.ebuild
+++ b/sys-devel/automake/automake-1.4_p6.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.4_p6.ebuild,v 1.18 2005/03/13 04:40:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.4_p6.ebuild,v 1.19 2005/08/23 23:58:59 vapier Exp $
-inherit eutils gnuconfig
+inherit eutils
MY_P="${P/_/-}"
DESCRIPTION="Used to generate Makefile.in from Makefile.am"
@@ -19,21 +19,20 @@ DEPEND="dev-lang/perl
>=sys-devel/autoconf-2.59-r6
sys-devel/gnuconfig"
-S="${WORKDIR}/${MY_P}"
+S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/automake-1.4-libtoolize.patch
- epatch ${FILESDIR}/automake-1.4-subdirs-89656.patch
- epatch ${FILESDIR}/automake-1.4-ansi2knr-stdlib.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/automake-1.4-libtoolize.patch
+ epatch "${FILESDIR}"/automake-1.4-subdirs-89656.patch
+ epatch "${FILESDIR}"/automake-1.4-ansi2knr-stdlib.patch
sed -i 's:error\.test::' tests/Makefile.in #79529
sed -i \
-e "/^@setfilename/s|automake|automake${SLOT}|" \
-e "s|automake: (automake)|automake v${SLOT}: (automake${SLOT})|" \
-e "s|aclocal: (automake)|aclocal v${SLOT}: (automake${SLOT})|" \
automake.texi || die "sed failed"
- gnuconfig_update
export WANT_AUTOCONF=2.5
}
diff --git a/sys-devel/automake/automake-1.5.ebuild b/sys-devel/automake/automake-1.5.ebuild
index aba09d153397..ab5b67acdb4a 100644
--- a/sys-devel/automake/automake-1.5.ebuild
+++ b/sys-devel/automake/automake-1.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.5.ebuild,v 1.23 2005/03/13 04:40:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.5.ebuild,v 1.24 2005/08/23 23:58:59 vapier Exp $
-inherit eutils gnuconfig
+inherit eutils
DESCRIPTION="Used to generate Makefile.in from Makefile.am"
HOMEPAGE="http://sources.redhat.com/automake/"
@@ -20,26 +20,25 @@ DEPEND="dev-lang/perl
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-target_hook.patch
- epatch ${FILESDIR}/${P}-slot.patch
- epatch ${FILESDIR}/${P}-test-fixes.patch #79505
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-target_hook.patch
+ epatch "${FILESDIR}"/${P}-slot.patch
+ epatch "${FILESDIR}"/${P}-test-fixes.patch #79505
sed -i \
-e "/^@setfilename/s|automake|automake${SLOT}|" \
-e "s|automake: (automake)|automake v${SLOT}: (automake${SLOT})|" \
-e "s|aclocal: (automake)|aclocal v${SLOT}: (automake${SLOT})|" \
automake.texi || die "sed failed"
- gnuconfig_update
export WANT_AUTOCONF=2.5
}
src_install() {
- make install DESTDIR="${D}" || die
+ make install DESTDIR="${D}" || die "make install failed"
local x=
for x in aclocal automake ; do
- mv "${D}"/usr/bin/${x}{,-${SLOT}}
- mv "${D}"/usr/share/${x}{,-${SLOT}}
+ mv "${D}"/usr/bin/${x}{,-${SLOT}} || die "rename ${x}"
+ mv "${D}"/usr/share/${x}{,-${SLOT}} || die "move ${x}"
done
dodoc NEWS README THANKS TODO AUTHORS ChangeLog
diff --git a/sys-devel/automake/automake-1.6.3.ebuild b/sys-devel/automake/automake-1.6.3.ebuild
index 0d111cfa3a6d..0c721995f204 100644
--- a/sys-devel/automake/automake-1.6.3.ebuild
+++ b/sys-devel/automake/automake-1.6.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.6.3.ebuild,v 1.33 2005/03/13 04:40:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.6.3.ebuild,v 1.34 2005/08/23 23:58:59 vapier Exp $
-inherit eutils gnuconfig
+inherit eutils
DESCRIPTION="Used to generate Makefile.in from Makefile.am"
HOMEPAGE="http://sources.redhat.com/automake/"
@@ -20,13 +20,12 @@ DEPEND="dev-lang/perl
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
sed -i \
-e "/^@setfilename/s|automake|automake${SLOT}|" \
-e "s|automake: (automake)|automake v${SLOT}: (automake${SLOT})|" \
-e "s|aclocal: (automake)|aclocal v${SLOT}: (automake${SLOT})|" \
automake.texi || die "sed failed"
- gnuconfig_update
export WANT_AUTOCONF=2.5
}
diff --git a/sys-devel/automake/automake-1.7.9-r1.ebuild b/sys-devel/automake/automake-1.7.9-r1.ebuild
index 83de6bd18b32..a125bc821e3a 100644
--- a/sys-devel/automake/automake-1.7.9-r1.ebuild
+++ b/sys-devel/automake/automake-1.7.9-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.7.9-r1.ebuild,v 1.10 2005/03/13 04:40:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.7.9-r1.ebuild,v 1.11 2005/08/23 23:58:59 vapier Exp $
-inherit eutils gnuconfig
+inherit eutils
DESCRIPTION="Used to generate Makefile.in from Makefile.am"
HOMEPAGE="http://sources.redhat.com/automake/"
@@ -20,14 +20,13 @@ DEPEND="dev-lang/perl
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
sed -i \
-e "/^@setfilename/s|automake|automake${SLOT}|" \
-e "s|automake: (automake)|automake v${SLOT}: (automake${SLOT})|" \
-e "s|aclocal: (automake)|aclocal v${SLOT}: (automake${SLOT})|" \
automake.texi || die "sed texi failed"
- epatch ${FILESDIR}/${P}-infopage-namechange.patch
- gnuconfig_update
+ epatch "${FILESDIR}"/${P}-infopage-namechange.patch
export WANT_AUTOCONF=2.5
}
diff --git a/sys-devel/automake/automake-1.8.5-r3.ebuild b/sys-devel/automake/automake-1.8.5-r3.ebuild
index f76b825f36b5..7ea50974340e 100644
--- a/sys-devel/automake/automake-1.8.5-r3.ebuild
+++ b/sys-devel/automake/automake-1.8.5-r3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.8.5-r3.ebuild,v 1.10 2005/03/13 04:40:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.8.5-r3.ebuild,v 1.11 2005/08/23 23:58:59 vapier Exp $
-inherit eutils gnuconfig
+inherit eutils
DESCRIPTION="Used to generate Makefile.in from Makefile.am"
HOMEPAGE="http://sources.redhat.com/automake/"
@@ -20,14 +20,13 @@ DEPEND="dev-lang/perl
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
sed -i \
-e "/^@setfilename/s|automake|automake${SLOT}|" \
-e "s|automake: (automake)|automake v${SLOT}: (automake${SLOT})|" \
-e "s|aclocal: (automake)|aclocal v${SLOT}: (automake${SLOT})|" \
doc/automake.texi || die "sed failed"
- epatch ${FILESDIR}/${PN}-1.8.2-infopage-namechange.patch
- gnuconfig_update
+ epatch "${FILESDIR}"/${PN}-1.8.2-infopage-namechange.patch
export WANT_AUTOCONF=2.5
}
diff --git a/sys-devel/automake/automake-1.9.5.ebuild b/sys-devel/automake/automake-1.9.5.ebuild
index 0821e45c6169..4d0494190f9b 100644
--- a/sys-devel/automake/automake-1.9.5.ebuild
+++ b/sys-devel/automake/automake-1.9.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.9.5.ebuild,v 1.3 2005/05/05 22:54:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.9.5.ebuild,v 1.4 2005/08/23 23:58:59 vapier Exp $
-inherit eutils gnuconfig
+inherit eutils
DESCRIPTION="Used to generate Makefile.in from Makefile.am"
HOMEPAGE="http://sources.redhat.com/automake/"
@@ -21,14 +21,13 @@ RDEPEND="dev-lang/perl
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
sed -i \
-e "/^@setfilename/s|automake|automake${SLOT}|" \
-e "s|automake: (automake)|automake v${SLOT}: (automake${SLOT})|" \
-e "s|aclocal: (automake)|aclocal v${SLOT}: (automake${SLOT})|" \
doc/automake.texi || die "sed failed"
- epatch ${FILESDIR}/${PN}-1.9.3-infopage-namechange.patch
- gnuconfig_update
+ epatch "${FILESDIR}"/${PN}-1.9.3-infopage-namechange.patch
export WANT_AUTOCONF=2.5
}