summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-03-26 00:48:55 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-03-26 00:48:55 +0000
commitf57069766372fb193c5ac1259201571e52708172 (patch)
treec4c669be6099d217c7212f0eaefb95d3235b19a8 /sys-devel/automake
parentstamp fix (diff)
downloadgentoo-2-f57069766372fb193c5ac1259201571e52708172.tar.gz
gentoo-2-f57069766372fb193c5ac1259201571e52708172.tar.bz2
gentoo-2-f57069766372fb193c5ac1259201571e52708172.zip
add more compadible version
Diffstat (limited to 'sys-devel/automake')
-rw-r--r--sys-devel/automake/automake-1.5d-r1.ebuild119
-rw-r--r--sys-devel/automake/files/am-wrapper.pl-1.552
-rw-r--r--sys-devel/automake/files/digest-automake-1.5d-r12
3 files changed, 173 insertions, 0 deletions
diff --git a/sys-devel/automake/automake-1.5d-r1.ebuild b/sys-devel/automake/automake-1.5d-r1.ebuild
new file mode 100644
index 000000000000..c4e440a3a19b
--- /dev/null
+++ b/sys-devel/automake/automake-1.5d-r1.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.5d-r1.ebuild,v 1.1 2002/03/26 00:46:36 azarah Exp $
+
+OLD_PV=1.4-p5
+OLD_P=${PN}-${OLD_PV}
+S=${WORKDIR}/${P}
+OLD_S=${WORKDIR}/${OLD_P}
+DESCRIPTION="Used to generate Makefile.in from Makefile.am"
+SRC_URI="ftp://sources.redhat.com/pub/${PN}/${P}.tar.bz2
+ ftp://ftp.gnu.org/gnu/${PN}/${OLD_P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/automake/automake.html"
+
+DEPEND="sys-devel/perl
+ >=sys-devel/autoconf-2.52-r1"
+
+
+src_compile() {
+
+ #
+ # ************ automake-1.6x ************
+ #
+
+ # stupid configure script goes and run autoconf in a subdir,
+ # so 'ac-wrapper.pl' do not detect that it should use
+ # autoconf-2.5x
+ export WANT_AUTOCONF_2_5=1
+
+ cd ${S}
+
+ cp automake.texi automake.texi.orig
+ sed -e "s:setfilename automake.info:setfilename automake-1.5.info:" \
+ automake.texi.orig >automake.texi
+
+ ./configure --prefix=/usr \
+ --datadir=/usr/share/${P} \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake ${MAKEOPTS} || die
+
+ unset WANT_AUTOCONF_2_5
+
+ #
+ # ************ automake-1.4-p5 ************
+ #
+ cd ${OLD_S}
+ ./configure --prefix=/usr \
+ --datadir=/usr/share/${OLD_P} \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake ${MAKEOPTS} || die
+}
+
+src_install() {
+
+ # install wrapper script for autodetecting the proper version
+ # to use.
+ exeinto /usr/lib/${PN}
+ newexe ${FILESDIR}/am-wrapper.pl-1.5 am-wrapper.pl
+
+ #
+ # ************ automake-1.6x ************
+ #
+
+ cd ${S}
+ make DESTDIR=${D} \
+ datadir=/usr/share/${P} \
+ install || die
+
+ for x in automake aclocal
+ do
+ mv ${D}/usr/bin/${x}-${PV} ${D}/usr/bin/${x}-1.5x
+ rm -f ${D}/usr/bin/${x}
+ done
+
+ doinfo automake-1.5.info*
+
+ docinto ${PF}/${PV}
+ dodoc COPYING NEWS README THANKS TODO AUTHORS ChangeLog
+
+ #
+ # ************ automake-1.4-p5 ************
+ #
+
+ cd ${OLD_S}
+ make prefix=${D}/usr \
+ datadir=${D}/usr/share/${OLD_P} \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ for x in automake aclocal
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-1.4
+ dosym ../lib/${PN}/am-wrapper.pl /usr/bin/${x}
+ done
+
+ docinto ${PF}/${OLD_PV}
+ dodoc COPYING NEWS README THANKS TODO AUTHORS ChangeLog
+}
+
+pkg_preinst() {
+
+ # remove these to make sure symlinks install properly if old versions
+ # was binaries
+ for x in automake aclocal
+ do
+ if [ -e /usr/bin/${x} ]
+ then
+ rm -f /usr/bin/${x}
+ fi
+ done
+}
+
diff --git a/sys-devel/automake/files/am-wrapper.pl-1.5 b/sys-devel/automake/files/am-wrapper.pl-1.5
new file mode 100644
index 000000000000..c42858ee88c1
--- /dev/null
+++ b/sys-devel/automake/files/am-wrapper.pl-1.5
@@ -0,0 +1,52 @@
+#!/usr/bin/perl
+#
+#
+# Guillaume Cottenceau (gc@mandrakesoft.com)
+#
+# Copyright 2001 MandrakeSoft
+#
+# This software may be freely redistributed under the terms of the GNU
+# public license.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+#
+#
+# Executes the correct autoconf version.
+#
+# - defaults to automake-1.4
+# - runs automake-1.5x if it exists and...
+# - envvar WANT_AUTOMAKE_1_5 is set to `1'
+# -or-
+# - configure.ac is present
+# -or-
+# - `configure.in' contains AC_PREREQ and the value's 3 first letters
+# are stringwise greater than '2.1'
+#
+
+#use MDK::Common;
+
+sub cat_ { local *F; open F, $_[0] or return; my @l = <F>; wantarray ? @l : join '', @l }
+
+my $binary = "$0-1.4";
+my $binary_new = "$0-1.5x";
+
+if (!$ENV{WANT_AUTOMAKE_1_4}) {
+ if (-x $binary_new # user may have only 2.13
+ && ($ENV{WANT_AUTOMAKE_1_5}
+ || -r 'configure.ac'
+ || (cat_('configure.in') =~ /^\s*AC_PREREQ\(([^\)]{3})[^\)]*\)/m ? $1 : '') gt '2.1'
+ || (cat_('aclocal.m4') =~ /^\s*AC_PREREQ\(([^\)]{3})[^\)]*\)/m ? $1 : '') gt '2.1')) {
+ $ENV{WANT_AUTOMAKE_1_5} = 1; # to prevent further "cats" and to enhance consistency (possible cwd etc)
+ $binary = $binary_new;
+ } else {
+ $ENV{WANT_AUTOMAKE_1_4} = 1; # for further consistency
+ }
+}
+
+$ENV{WANT_AMWRAPPER_DEBUG} and print STDERR "am-wrapper: will execute <$binary>\n";
+
+exec $binary, @ARGV;
+
+die "am-wrapper: ouch, couldn't call binary ($binary).\n";
diff --git a/sys-devel/automake/files/digest-automake-1.5d-r1 b/sys-devel/automake/files/digest-automake-1.5d-r1
new file mode 100644
index 000000000000..feb51fd9db4a
--- /dev/null
+++ b/sys-devel/automake/files/digest-automake-1.5d-r1
@@ -0,0 +1,2 @@
+MD5 78b3eb4d3d593ceaa32c1d33d6abcdf6 automake-1.5d.tar.bz2 455041
+MD5 e10679bba411f8602eed004012d915e3 automake-1.4-p5.tar.gz 376992