summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-11-08 06:09:01 +0000
committerMike Frysinger <vapier@gentoo.org>2004-11-08 06:09:01 +0000
commitc168677961e93cd822dbcab96dd859b21745e022 (patch)
tree06b29d0a4f7fa4ff2fc102066bdff7dd4c25f8cc /sys-devel/bc
parentmake sure mail check default is set to no #70101 (Manifest recommit) (diff)
downloadgentoo-2-c168677961e93cd822dbcab96dd859b21745e022.tar.gz
gentoo-2-c168677961e93cd822dbcab96dd859b21745e022.tar.bz2
gentoo-2-c168677961e93cd822dbcab96dd859b21745e022.zip
USE=static support #70276 by Sascha Silbe.
Diffstat (limited to 'sys-devel/bc')
-rw-r--r--sys-devel/bc/ChangeLog5
-rw-r--r--sys-devel/bc/bc-1.06-r5.ebuild14
2 files changed, 11 insertions, 8 deletions
diff --git a/sys-devel/bc/ChangeLog b/sys-devel/bc/ChangeLog
index 55b3d5b168f8..d627f77ee3fa 100644
--- a/sys-devel/bc/ChangeLog
+++ b/sys-devel/bc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/bc
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bc/ChangeLog,v 1.15 2004/06/24 22:42:57 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bc/ChangeLog,v 1.16 2004/11/08 06:09:01 vapier Exp $
+
+ 08 Nov 2004; Mike Frysinger <vapier@gentoo.org> bc-1.06-r5.ebuild:
+ USE=static support #70276 by Sascha Silbe.
02 Mar 2004; Brian Jackson <iggy@gentoo.org> bc-1.06-r5.ebuild:
adding initial s390 support
diff --git a/sys-devel/bc/bc-1.06-r5.ebuild b/sys-devel/bc/bc-1.06-r5.ebuild
index 63f55cc57b22..1f6531e48dde 100644
--- a/sys-devel/bc/bc-1.06-r5.ebuild
+++ b/sys-devel/bc/bc-1.06-r5.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bc/bc-1.06-r5.ebuild,v 1.16 2004/06/24 22:42:57 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bc/bc-1.06-r5.ebuild,v 1.17 2004/11/08 06:09:01 vapier Exp $
inherit eutils flag-o-matic
DESCRIPTION="Handy console-based calculator utility"
-HOMEPAGE="http://www.gnu.org/software/bc/bc.html"
SRC_URI="mirror://gnu/bc/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/bc/bc.html"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-KEYWORDS="x86 ppc sparc mips alpha arm hppa mips amd64 ia64 ppc64 s390"
-IUSE="readline"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sparc x86"
+IUSE="readline static"
RDEPEND="readline? ( >=sys-libs/readline-4.1
>=sys-libs/ncurses-5.2 )"
@@ -38,9 +38,8 @@ src_unpack() {
"${flminor/flex* }" -ge 5 -a \
"${flmicro/flex* }" -ge 22 ]
then
- cd ${S}; cp configure configure.orig
- sed -e 's:flex -I8:flex -I:g' \
- configure.orig > configure
+ sed -i -e 's:flex -I8:flex -I:g' \
+ configure
fi
}
@@ -52,6 +51,7 @@ src_compile() {
esac
local myconf=""
+ use static && append-ldflags -static
use readline && myconf="--with-readline"
econf ${myconf} || die
emake || die