summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-01-15 12:15:23 +0000
committerLars Wendler <polynomial-c@gentoo.org>2015-01-15 12:15:23 +0000
commit22a104071bf1426bb56b5c629af0bba5229ce939 (patch)
tree0bf9a73ff9b7c51c5d1cec20b75f8d6aa0c44909 /sys-devel/bison
parentalpha/ia64/sh/sparc stable wrt #525766 (diff)
downloadgentoo-2-22a104071bf1426bb56b5c629af0bba5229ce939.tar.gz
gentoo-2-22a104071bf1426bb56b5c629af0bba5229ce939.tar.bz2
gentoo-2-22a104071bf1426bb56b5c629af0bba5229ce939.zip
Version bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-devel/bison')
-rw-r--r--sys-devel/bison/ChangeLog9
-rw-r--r--sys-devel/bison/bison-3.0.3.ebuild59
2 files changed, 66 insertions, 2 deletions
diff --git a/sys-devel/bison/ChangeLog b/sys-devel/bison/ChangeLog
index 8e61577f4453..a86aaf28194d 100644
--- a/sys-devel/bison/ChangeLog
+++ b/sys-devel/bison/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/bison
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.129 2014/01/18 03:19:42 vapier Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.130 2015/01/15 12:15:23 polynomial-c Exp $
+
+*bison-3.0.3 (15 Jan 2015)
+
+ 15 Jan 2015; Lars Wendler <polynomial-c@gentoo.org> +bison-3.0.3.ebuild:
+ Version bump.
18 Jan 2014; Mike Frysinger <vapier@gentoo.org> bison-1.875d.ebuild,
bison-2.4.3.ebuild, bison-2.7.1.ebuild, bison-3.0.2.ebuild:
diff --git a/sys-devel/bison/bison-3.0.3.ebuild b/sys-devel/bison/bison-3.0.3.ebuild
new file mode 100644
index 000000000000..ef80bda524cd
--- /dev/null
+++ b/sys-devel/bison/bison-3.0.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-3.0.3.ebuild,v 1.1 2015/01/15 12:15:23 polynomial-c Exp $
+
+EAPI=5
+
+inherit flag-o-matic
+
+DESCRIPTION="A general-purpose (yacc-compatible) parser generator"
+HOMEPAGE="http://www.gnu.org/software/bison/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls static"
+
+RDEPEND=">=sys-devel/m4-1.4.16"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ nls? ( sys-devel/gettext )"
+
+DOCS=( AUTHORS ChangeLog-2012 NEWS README THANKS TODO ) # ChangeLog-1998 PACKAGING README-alpha README-release
+
+src_configure() {
+ use static && append-ldflags -static
+
+ econf \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+
+ # This one is installed by dev-util/yacc
+ mv "${ED}"/usr/bin/yacc{,.bison} || die
+ mv "${ED}"/usr/share/man/man1/yacc{,.bison}.1 || die
+
+ # We do not need liby.a
+ rm -r "${ED}"/usr/lib* || die
+
+ # Move to documentation directory and leave compressing for EAPI>=4
+ mv "${ED}"/usr/share/${PN}/README "${ED}"/usr/share/doc/${PF}/README.data
+}
+
+pkg_postinst() {
+ local f="${EROOT}/usr/bin/yacc"
+ if [[ ! -e ${f} ]] ; then
+ ln -s yacc.bison "${f}"
+ fi
+}
+
+pkg_postrm() {
+ # clean up the dead symlink when we get unmerged #377469
+ local f="${EROOT}/usr/bin/yacc"
+ if [[ -L ${f} && ! -e ${f} ]] ; then
+ rm -f "${f}"
+ fi
+}