summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-04-03 07:03:42 +0000
committerMike Frysinger <vapier@gentoo.org>2015-04-03 07:03:42 +0000
commitbc4c3ba0229ad3d98e21bebde86a7858a845b55c (patch)
tree3630519d931b41ec4aa6bdb4d4f35d64606a79ce /sys-devel/bison
parentVersion bump. (diff)
downloadgentoo-2-bc4c3ba0229ad3d98e21bebde86a7858a845b55c.tar.gz
gentoo-2-bc4c3ba0229ad3d98e21bebde86a7858a845b55c.tar.bz2
gentoo-2-bc4c3ba0229ad3d98e21bebde86a7858a845b55c.zip
Make examples optional and fix perl dependency #538300 by Ben Kohler.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-devel/bison')
-rw-r--r--sys-devel/bison/ChangeLog8
-rw-r--r--sys-devel/bison/bison-3.0.4-r1.ebuild69
-rw-r--r--sys-devel/bison/files/bison-3.0.4-optional-perl.patch72
3 files changed, 148 insertions, 1 deletions
diff --git a/sys-devel/bison/ChangeLog b/sys-devel/bison/ChangeLog
index e3f1588056f3..836455b41f2b 100644
--- a/sys-devel/bison/ChangeLog
+++ b/sys-devel/bison/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/bison
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.133 2015/01/23 19:38:58 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.134 2015/04/03 07:03:42 vapier Exp $
+
+*bison-3.0.4-r1 (03 Apr 2015)
+
+ 03 Apr 2015; Mike Frysinger <vapier@gentoo.org> +bison-3.0.4-r1.ebuild,
+ +files/bison-3.0.4-optional-perl.patch:
+ Make examples optional and fix perl dependency #538300 by Ben Kohler.
*bison-3.0.4 (23 Jan 2015)
diff --git a/sys-devel/bison/bison-3.0.4-r1.ebuild b/sys-devel/bison/bison-3.0.4-r1.ebuild
new file mode 100644
index 000000000000..e096f2943a04
--- /dev/null
+++ b/sys-devel/bison/bison-3.0.4-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-3.0.4-r1.ebuild,v 1.1 2015/04/03 07:03:42 vapier Exp $
+
+EAPI=5
+
+inherit flag-o-matic eutils autotools
+
+DESCRIPTION="A general-purpose (yacc-compatible) parser generator"
+HOMEPAGE="http://www.gnu.org/software/bison/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples nls static test"
+
+RDEPEND=">=sys-devel/m4-1.4.16"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ examples? ( dev-lang/perl )
+ nls? ( sys-devel/gettext )
+ test? ( dev-lang/perl )"
+
+DOCS=( AUTHORS ChangeLog-2012 NEWS README THANKS TODO ) # ChangeLog-1998 PACKAGING README-alpha README-release
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-optional-perl.patch #538300
+ eautoreconf
+}
+
+src_configure() {
+ use static && append-ldflags -static
+
+ac_cv_path_PERL=true \
+ econf \
+ --docdir='$(datarootdir)'/doc/${PF} \
+ $(use_enable examples) \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+
+ # This one is installed by dev-util/yacc
+ mv "${ED}"/usr/bin/yacc{,.bison} || die
+ mv "${ED}"/usr/share/man/man1/yacc{,.bison}.1 || die
+
+ # We do not need liby.a
+ rm -r "${ED}"/usr/lib* || die
+
+ # Move to documentation directory and leave compressing for EAPI>=4
+ mv "${ED}"/usr/share/${PN}/README "${ED}"/usr/share/doc/${PF}/README.data
+}
+
+pkg_postinst() {
+ local f="${EROOT}/usr/bin/yacc"
+ if [[ ! -e ${f} ]] ; then
+ ln -s yacc.bison "${f}"
+ fi
+}
+
+pkg_postrm() {
+ # clean up the dead symlink when we get unmerged #377469
+ local f="${EROOT}/usr/bin/yacc"
+ if [[ -L ${f} && ! -e ${f} ]] ; then
+ rm -f "${f}"
+ fi
+}
diff --git a/sys-devel/bison/files/bison-3.0.4-optional-perl.patch b/sys-devel/bison/files/bison-3.0.4-optional-perl.patch
new file mode 100644
index 000000000000..16614157f95d
--- /dev/null
+++ b/sys-devel/bison/files/bison-3.0.4-optional-perl.patch
@@ -0,0 +1,72 @@
+https://bugs.gentoo.org/538300
+
+From 3da25ddd011c169b9857ed2f6a2e82988f059ba5 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Fri, 3 Apr 2015 02:39:21 -0400
+Subject: [PATCH] make perl & examples optional
+
+The normal bison program does not require perl to build or run, so lets
+soften that requirement in the configure script. We now warn if its not
+found, and we make the examples logic depend on that.
+
+* configure.ac: Change AC_MSG_ERROR to AC_MSG_WARN for perl.
+Add an --enable-examples flag.
+* Makefile.am: Only include examples/local.mk when ENABLE_EXAMPLES.
+---
+ Makefile.am | 2 ++
+ configure.ac | 21 ++++++++++++++++++++-
+ 2 files changed, 22 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index b6135cb..50ea0a0 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -59,7 +59,9 @@ include data/local.mk
+ include djgpp/local.mk
+ include doc/local.mk
+ include etc/local.mk
++if ENABLE_EXAMPLES
+ include examples/local.mk
++endif
+ include lib/local.mk
+ include src/local.mk
+ include tests/local.mk
+diff --git a/configure.ac b/configure.ac
+index 6f20040..e67249b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -179,12 +179,31 @@ AC_DEFINE_UNQUOTED([M4_GNU_OPTION], ["$M4_GNU"], [Define to "-g" if GNU M4
+ supports -g, otherwise to "".])
+ AC_PATH_PROG([PERL], [perl])
+ if test -z "$PERL"; then
+- AC_MSG_ERROR([perl not found])
++ AC_MSG_WARN([perl required for the testsuites])
+ fi
+ AM_MISSING_PROG([HELP2MAN], [help2man])
+ AC_PATH_PROG([XSLTPROC], [xsltproc])
+ AC_SUBST([XSLTPROC])
+
++AC_ARG_ENABLE([examples],
++ [AC_HELP_STRING([--disable-examples],
++ [do not build and install examples])])
++# Enable the examles by default if perl is available.
++case $enable_examples in
++no) ;;
++yes)
++ if test -z "$PERL"; then
++ AC_MSG_ERROR([perl required for the examples])
++ fi
++ ;;
++*)
++ if test -n "$PERL"; then
++ enable_examples=yes
++ fi
++ ;;
++esac
++AM_CONDITIONAL([ENABLE_EXAMPLES], [test "xenable_examples" = xyes])
++
+ # Checks for header files.
+ AC_CHECK_HEADERS_ONCE([locale.h])
+
+--
+2.3.4