summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-08-10 22:35:01 +0000
committerMichał Górny <mgorny@gentoo.org>2013-08-10 22:35:01 +0000
commit629126e5c49095dfe58f4d1c26c5c58714e4f20f (patch)
tree9f56a241c33211277bdb203dcc41efb039166973 /sys-devel/clang
parentconvert to multilib (diff)
downloadgentoo-2-629126e5c49095dfe58f4d1c26c5c58714e4f20f.tar.gz
gentoo-2-629126e5c49095dfe58f4d1c26c5c58714e4f20f.tar.bz2
gentoo-2-629126e5c49095dfe58f4d1c26c5c58714e4f20f.zip
Add multilib flags. Make the deps weaker (no need to enforce disabling everything in LLVM).
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'sys-devel/clang')
-rw-r--r--sys-devel/clang/ChangeLog7
-rw-r--r--sys-devel/clang/clang-3.3-r100.ebuild6
-rw-r--r--sys-devel/clang/clang-9999-r100.ebuild6
3 files changed, 14 insertions, 5 deletions
diff --git a/sys-devel/clang/ChangeLog b/sys-devel/clang/ChangeLog
index 1c019ab85caf..21229267726c 100644
--- a/sys-devel/clang/ChangeLog
+++ b/sys-devel/clang/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/clang
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.93 2013/07/31 21:51:47 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.94 2013/08/10 22:35:01 mgorny Exp $
+
+ 10 Aug 2013; Michał Górny <mgorny@gentoo.org> clang-3.3-r100.ebuild,
+ clang-9999-r100.ebuild:
+ Add multilib flags. Make the deps weaker (no need to enforce disabling
+ everything in LLVM).
31 Jul 2013; Alexis Ballier <aballier@gentoo.org> clang-3.3-r100.ebuild:
remove ppc keywords that were added by mistake
diff --git a/sys-devel/clang/clang-3.3-r100.ebuild b/sys-devel/clang/clang-3.3-r100.ebuild
index af912a090125..8b44c1fa3ad4 100644
--- a/sys-devel/clang/clang-3.3-r100.ebuild
+++ b/sys-devel/clang/clang-3.3-r100.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-3.3-r100.ebuild,v 1.2 2013/07/31 21:51:47 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-3.3-r100.ebuild,v 1.3 2013/08/10 22:35:01 mgorny Exp $
EAPI=5
+inherit multilib-build
+
DESCRIPTION="C language family frontend for LLVM (meta-ebuild)"
HOMEPAGE="http://clang.llvm.org/"
SRC_URI=""
@@ -13,7 +15,7 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos"
IUSE="debug multitarget python +static-analyzer"
-RDEPEND="~sys-devel/llvm-${PV}[clang(-),debug=,multitarget=,python=,static-analyzer=]"
+RDEPEND="~sys-devel/llvm-${PV}[clang(-),debug=,multitarget,python,static-analyzer,${MULTILIB_USEDEP}]"
# Please keep this package around since it's quite likely that we'll
# return to separate LLVM & clang ebuilds when the cmake build system
diff --git a/sys-devel/clang/clang-9999-r100.ebuild b/sys-devel/clang/clang-9999-r100.ebuild
index a1918dec2100..619bfba9c620 100644
--- a/sys-devel/clang/clang-9999-r100.ebuild
+++ b/sys-devel/clang/clang-9999-r100.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-9999-r100.ebuild,v 1.1 2013/07/21 10:03:46 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-9999-r100.ebuild,v 1.2 2013/08/10 22:35:01 mgorny Exp $
EAPI=5
+inherit multilib-build
+
DESCRIPTION="C language family frontend for LLVM (meta-ebuild)"
HOMEPAGE="http://clang.llvm.org/"
SRC_URI=""
@@ -13,7 +15,7 @@ SLOT="0"
KEYWORDS=""
IUSE="debug multitarget python +static-analyzer"
-RDEPEND="~sys-devel/llvm-${PV}[clang(-),debug=,multitarget=,python=,static-analyzer=]"
+RDEPEND="~sys-devel/llvm-${PV}[clang(-),debug=,multitarget,python,static-analyzer,${MULTILIB_USEDEP}]"
# Please keep this package around since it's quite likely that we'll
# return to separate LLVM & clang ebuilds when the cmake build system