summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-08-11 00:46:34 +0000
committerMike Gilbert <floppym@gentoo.org>2013-08-11 00:46:34 +0000
commite0ec1371eddc368682bb67dbfb55911f2510ecb2 (patch)
tree13a6a272426ac3b7bfab4481e8ac1878c5f5f09b /sys-devel/clang
parentnew revision featuring lcms:2, libpaper and tiff:3 conversion (diff)
downloadgentoo-2-e0ec1371eddc368682bb67dbfb55911f2510ecb2.tar.gz
gentoo-2-e0ec1371eddc368682bb67dbfb55911f2510ecb2.tar.bz2
gentoo-2-e0ec1371eddc368682bb67dbfb55911f2510ecb2.zip
Fix use flags; a hard dependency on llvm[multitarget,python] seems unlikely to be correct.
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'sys-devel/clang')
-rw-r--r--sys-devel/clang/ChangeLog7
-rw-r--r--sys-devel/clang/clang-3.3-r100.ebuild4
-rw-r--r--sys-devel/clang/clang-9999-r100.ebuild4
3 files changed, 10 insertions, 5 deletions
diff --git a/sys-devel/clang/ChangeLog b/sys-devel/clang/ChangeLog
index 21229267726c..60ed75f24336 100644
--- a/sys-devel/clang/ChangeLog
+++ b/sys-devel/clang/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/clang
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.94 2013/08/10 22:35:01 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.95 2013/08/11 00:46:34 floppym Exp $
+
+ 11 Aug 2013; Mike Gilbert <floppym@gentoo.org> clang-3.3-r100.ebuild,
+ clang-9999-r100.ebuild:
+ Fix use flags; a hard dependency on llvm[multitarget,python] seems unlikely to
+ be correct.
10 Aug 2013; Michał Górny <mgorny@gentoo.org> clang-3.3-r100.ebuild,
clang-9999-r100.ebuild:
diff --git a/sys-devel/clang/clang-3.3-r100.ebuild b/sys-devel/clang/clang-3.3-r100.ebuild
index 8b44c1fa3ad4..ba542e73a2a9 100644
--- a/sys-devel/clang/clang-3.3-r100.ebuild
+++ b/sys-devel/clang/clang-3.3-r100.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-3.3-r100.ebuild,v 1.3 2013/08/10 22:35:01 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-3.3-r100.ebuild,v 1.4 2013/08/11 00:46:34 floppym Exp $
EAPI=5
@@ -15,7 +15,7 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos"
IUSE="debug multitarget python +static-analyzer"
-RDEPEND="~sys-devel/llvm-${PV}[clang(-),debug=,multitarget,python,static-analyzer,${MULTILIB_USEDEP}]"
+RDEPEND="~sys-devel/llvm-${PV}[clang(-),debug=,multitarget?,python?,static-analyzer,${MULTILIB_USEDEP}]"
# Please keep this package around since it's quite likely that we'll
# return to separate LLVM & clang ebuilds when the cmake build system
diff --git a/sys-devel/clang/clang-9999-r100.ebuild b/sys-devel/clang/clang-9999-r100.ebuild
index 619bfba9c620..f8b7277cf507 100644
--- a/sys-devel/clang/clang-9999-r100.ebuild
+++ b/sys-devel/clang/clang-9999-r100.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-9999-r100.ebuild,v 1.2 2013/08/10 22:35:01 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-9999-r100.ebuild,v 1.3 2013/08/11 00:46:34 floppym Exp $
EAPI=5
@@ -15,7 +15,7 @@ SLOT="0"
KEYWORDS=""
IUSE="debug multitarget python +static-analyzer"
-RDEPEND="~sys-devel/llvm-${PV}[clang(-),debug=,multitarget,python,static-analyzer,${MULTILIB_USEDEP}]"
+RDEPEND="~sys-devel/llvm-${PV}[clang(-),debug=,multitarget?,python?,static-analyzer,${MULTILIB_USEDEP}]"
# Please keep this package around since it's quite likely that we'll
# return to separate LLVM & clang ebuilds when the cmake build system