summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-04 03:27:27 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-04 03:27:27 +0000
commit3fa73a766b859416382a8dfe379d9ab7bc29c940 (patch)
tree81ac13143c9e11d36d4d4ea59303ab5f1988df73 /sys-devel/crossdev
parentold (diff)
downloadgentoo-2-3fa73a766b859416382a8dfe379d9ab7bc29c940.tar.gz
gentoo-2-3fa73a766b859416382a8dfe379d9ab7bc29c940.tar.bz2
gentoo-2-3fa73a766b859416382a8dfe379d9ab7bc29c940.zip
Add sanity checks to keep from breaking the host system.
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-devel/crossdev')
-rw-r--r--sys-devel/crossdev/ChangeLog8
-rw-r--r--sys-devel/crossdev/crossdev-0.9-r2.ebuild20
-rwxr-xr-xsys-devel/crossdev/files/crossdev21
-rw-r--r--sys-devel/crossdev/files/digest-crossdev-0.9-r20
4 files changed, 43 insertions, 6 deletions
diff --git a/sys-devel/crossdev/ChangeLog b/sys-devel/crossdev/ChangeLog
index b49314b40f12..6c277e203cdb 100644
--- a/sys-devel/crossdev/ChangeLog
+++ b/sys-devel/crossdev/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/crossdev
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.8 2005/03/04 02:59:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.9 2005/03/04 03:27:27 vapier Exp $
+
+*crossdev-0.9-r2 (03 Mar 2005)
+
+ 03 Mar 2005; Mike Frysinger <vapier@gentoo.org> files/crossdev,
+ +crossdev-0.9-r2.ebuild:
+ Add sanity checks to keep from breaking the host system.
*crossdev-0.9-r1 (03 Mar 2005)
diff --git a/sys-devel/crossdev/crossdev-0.9-r2.ebuild b/sys-devel/crossdev/crossdev-0.9-r2.ebuild
new file mode 100644
index 000000000000..37c5b2175e68
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-0.9-r2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-0.9-r2.ebuild,v 1.1 2005/03/04 03:27:27 vapier Exp $
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="sys-apps/portage
+ app-shells/bash
+ sys-apps/coreutils"
+
+src_install() {
+ dobin "${FILESDIR}"/crossdev || die
+}
diff --git a/sys-devel/crossdev/files/crossdev b/sys-devel/crossdev/files/crossdev
index e3ef3c037fe5..b5904d12ef1a 100755
--- a/sys-devel/crossdev/files/crossdev
+++ b/sys-devel/crossdev/files/crossdev
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.2 2005/03/04 02:59:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.3 2005/03/04 03:27:27 vapier Exp $
source /sbin/functions.sh || exit 1
die() {
@@ -88,11 +88,12 @@ hr() {
echo ${br}
}
-#################
+##################
+### setup vars ###
EOPTS=
UOPTS=
TARCH=
-HARCH=
+HARCH=$(env -uARCH portageq envvar ARCH)
CTARGET=
STAGE=3
BVER="[latest]"
@@ -118,8 +119,18 @@ done
[[ -z ${CTARGET} ]] && usage 1
[[ ${CTARGET} == *-uclibc ]] && LPKG="uclibc"
-#################
-HARCH=$(env -uARCH portageq envvar ARCH)
+#####################
+### sanity checks ###
+if [[ -z $(portageq best_version / binutils-config) ]] ; then
+ eerror "Sorry, but your host system needs to have binutils-config"
+ eerror "in order to keep from screwing things up."
+ eerror "That means you must be running unstable versions of"
+ eerror "both binutils and binutils-config."
+ exit 1
+fi
+
+#####################
+### do the emerge ###
PORTDIR_OVERLAY=$(portageq envvar PORTDIR_OVERLAY)
PORTDIR=$(portageq envvar PORTDIR)
PORT_LOGDIR=$(portageq envvar PORT_LOGDIR)
diff --git a/sys-devel/crossdev/files/digest-crossdev-0.9-r2 b/sys-devel/crossdev/files/digest-crossdev-0.9-r2
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/sys-devel/crossdev/files/digest-crossdev-0.9-r2