summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-10-12 10:29:48 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-10-12 10:29:48 +0000
commit3bbb41c87230fd0c06bcd3dacf4caffefd73167a (patch)
tree1790fd8e1aabc3e6b64ada15caf89fc1523d3d7a /sys-devel/ct-ng
parentMarked stable on AMD64 based on arch testing by Agostino "ago" Sarubbo & Ian ... (diff)
downloadgentoo-2-3bbb41c87230fd0c06bcd3dacf4caffefd73167a.tar.gz
gentoo-2-3bbb41c87230fd0c06bcd3dacf4caffefd73167a.tar.bz2
gentoo-2-3bbb41c87230fd0c06bcd3dacf4caffefd73167a.zip
Version bump
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/ct-ng')
-rw-r--r--sys-devel/ct-ng/ChangeLog7
-rw-r--r--sys-devel/ct-ng/ct-ng-1.12.4.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/sys-devel/ct-ng/ChangeLog b/sys-devel/ct-ng/ChangeLog
index 631a0bcf9abf..8ece2ffdeb67 100644
--- a/sys-devel/ct-ng/ChangeLog
+++ b/sys-devel/ct-ng/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/ct-ng
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/ct-ng/ChangeLog,v 1.18 2011/09/25 12:48:16 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/ct-ng/ChangeLog,v 1.19 2011/10/12 10:29:48 blueness Exp $
+
+*ct-ng-1.12.4 (12 Oct 2011)
+
+ 12 Oct 2011; Anthony G. Basile <blueness@gentoo.org> +ct-ng-1.12.4.ebuild:
+ Version bump
*ct-ng-1.12.3 (25 Sep 2011)
diff --git a/sys-devel/ct-ng/ct-ng-1.12.4.ebuild b/sys-devel/ct-ng/ct-ng-1.12.4.ebuild
new file mode 100644
index 000000000000..2d17917efb9d
--- /dev/null
+++ b/sys-devel/ct-ng/ct-ng-1.12.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/ct-ng/ct-ng-1.12.4.ebuild,v 1.1 2011/10/12 10:29:48 blueness Exp $
+
+EAPI="4"
+
+inherit bash-completion-r1
+
+DESCRIPTION="crosstool-ng is a tool to build cross-compiling toolchains"
+HOMEPAGE="http://ymorin.is-a-geek.org/projects/crosstool"
+MY_P=${P/ct/crosstool}
+S=${WORKDIR}/${MY_P}
+SRC_URI="http://ymorin.is-a-geek.org/download/crosstool-ng/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bash-completion"
+
+RDEPEND="net-misc/curl
+ dev-vcs/cvs
+ dev-vcs/subversion"
+
+src_install() {
+ emake DESTDIR="${D%/}" install || die "install failed"
+ dobashcomp ${PN}.comp
+ dodoc README TODO
+}