summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-05-09 10:35:06 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-05-09 10:35:06 +0000
commit4040045c807644c79605bc2650a21a847d61e88e (patch)
tree9017dbd1285305b77f0290a28b8a30fab88e6d19 /sys-devel/ct-ng
parentStable for amd64/x86, wrt to bug #414683. Removed old. (diff)
downloadgentoo-2-4040045c807644c79605bc2650a21a847d61e88e.tar.gz
gentoo-2-4040045c807644c79605bc2650a21a847d61e88e.tar.bz2
gentoo-2-4040045c807644c79605bc2650a21a847d61e88e.zip
Version bump
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/ct-ng')
-rw-r--r--sys-devel/ct-ng/ChangeLog7
-rw-r--r--sys-devel/ct-ng/ct-ng-1.15.1.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/sys-devel/ct-ng/ChangeLog b/sys-devel/ct-ng/ChangeLog
index 15bc6b4241cf..afdaa86eebf7 100644
--- a/sys-devel/ct-ng/ChangeLog
+++ b/sys-devel/ct-ng/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/ct-ng
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/ct-ng/ChangeLog,v 1.34 2012/05/01 12:28:25 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/ct-ng/ChangeLog,v 1.35 2012/05/09 10:35:06 blueness Exp $
+
+*ct-ng-1.15.1 (09 May 2012)
+
+ 09 May 2012; Anthony G. Basile <blueness@gentoo.org> +ct-ng-1.15.1.ebuild:
+ Version bump
01 May 2012; Anthony G. Basile <blueness@gentoo.org> -ct-ng-1.13.3.ebuild,
-ct-ng-1.14.0.ebuild:
diff --git a/sys-devel/ct-ng/ct-ng-1.15.1.ebuild b/sys-devel/ct-ng/ct-ng-1.15.1.ebuild
new file mode 100644
index 000000000000..4fb4541f84ad
--- /dev/null
+++ b/sys-devel/ct-ng/ct-ng-1.15.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/ct-ng/ct-ng-1.15.1.ebuild,v 1.1 2012/05/09 10:35:06 blueness Exp $
+
+EAPI="4"
+
+inherit bash-completion-r1 autotools
+
+DESCRIPTION="crosstool-ng is a tool to build cross-compiling toolchains"
+HOMEPAGE="http://ymorin.is-a-geek.org/projects/crosstool"
+MY_P=${P/ct/crosstool}
+S=${WORKDIR}/${MY_P}
+SRC_URI="http://ymorin.is-a-geek.org/download/crosstool-ng/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bash-completion"
+
+RDEPEND="net-misc/curl
+ dev-util/gperf
+ dev-vcs/cvs
+ dev-vcs/subversion"
+
+src_prepare() {
+ #Upstream provides ${S}/bootstrap which runs autoconf -Wall --force
+ #We'll use eautoconf to be portage friendly
+ eautoconf -Wall --force
+}
+
+src_install() {
+ emake DESTDIR="${D%/}" install || die "install failed"
+ dobashcomp ${PN}.comp
+ dodoc README TODO
+}