summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-02-10 11:44:10 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-02-10 11:44:10 +0000
commit566dc9d7f0c51dea32536baa7a574e6e8b5b7269 (patch)
tree25690a6926625f17b94c6c707c8778f56ea60aa3 /sys-devel/ct-ng
parentold (diff)
downloadgentoo-2-566dc9d7f0c51dea32536baa7a574e6e8b5b7269.tar.gz
gentoo-2-566dc9d7f0c51dea32536baa7a574e6e8b5b7269.tar.bz2
gentoo-2-566dc9d7f0c51dea32536baa7a574e6e8b5b7269.zip
Version bump 1.13 branch
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/ct-ng')
-rw-r--r--sys-devel/ct-ng/ChangeLog13
-rw-r--r--sys-devel/ct-ng/ct-ng-1.13.4.ebuild28
2 files changed, 37 insertions, 4 deletions
diff --git a/sys-devel/ct-ng/ChangeLog b/sys-devel/ct-ng/ChangeLog
index 0a1156469c9d..8c56b0bc90f3 100644
--- a/sys-devel/ct-ng/ChangeLog
+++ b/sys-devel/ct-ng/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/ct-ng
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/ct-ng/ChangeLog,v 1.30 2012/02/08 11:23:42 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/ct-ng/ChangeLog,v 1.31 2012/02/10 11:44:10 blueness Exp $
+
+*ct-ng-1.13.4 (10 Feb 2012)
+
+ 10 Feb 2012; Anthony G. Basile <blueness@gentoo.org> +ct-ng-1.13.4.ebuild:
+ Version bump 1.13 branch
*ct-ng-1.14.1 (08 Feb 2012)
@@ -8,11 +13,11 @@
Version bump
04 Feb 2012; Anthony G. Basile <blueness@gentoo.org> ct-ng-1.14.0.ebuild:
- Add dependency on dev-util/gperf in 1.14 series
+ Add dependency on dev-util/gperf in 1.14 branch
01 Feb 2012; Anthony G. Basile <blueness@gentoo.org> -ct-ng-1.13.1.ebuild,
-ct-ng-1.13.2.ebuild:
- Removed older versions in 1.13 series
+ Removed older versions in 1.13 branch
*ct-ng-1.14.0 (01 Feb 2012)
@@ -25,7 +30,7 @@
Version bump
21 Nov 2011; Anthony G. Basile <blueness@gentoo.org> -ct-ng-1.13.0.ebuild:
- Removed older version in 1.13 series
+ Removed older version in 1.13 branch
*ct-ng-1.13.2 (21 Nov 2011)
diff --git a/sys-devel/ct-ng/ct-ng-1.13.4.ebuild b/sys-devel/ct-ng/ct-ng-1.13.4.ebuild
new file mode 100644
index 000000000000..720de88beac6
--- /dev/null
+++ b/sys-devel/ct-ng/ct-ng-1.13.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/ct-ng/ct-ng-1.13.4.ebuild,v 1.1 2012/02/10 11:44:10 blueness Exp $
+
+EAPI="4"
+
+inherit bash-completion-r1
+
+DESCRIPTION="crosstool-ng is a tool to build cross-compiling toolchains"
+HOMEPAGE="http://ymorin.is-a-geek.org/projects/crosstool"
+MY_P=${P/ct/crosstool}
+S=${WORKDIR}/${MY_P}
+SRC_URI="http://ymorin.is-a-geek.org/download/crosstool-ng/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bash-completion"
+
+RDEPEND="net-misc/curl
+ dev-vcs/cvs
+ dev-vcs/subversion"
+
+src_install() {
+ emake DESTDIR="${D%/}" install || die "install failed"
+ dobashcomp ${PN}.comp
+ dodoc README TODO
+}