summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-05-31 04:32:38 +0000
committerMike Frysinger <vapier@gentoo.org>2012-05-31 04:32:38 +0000
commit48c8706e7b4df4a5516b43e907aaf1aefe4e8f24 (patch)
treea6741819540c786debf7340c8a885155c201235e /sys-devel/gcc-config
parentMark 2to3 patch as binary to prevent $ expansion by CVS (diff)
downloadgentoo-2-48c8706e7b4df4a5516b43e907aaf1aefe4e8f24.tar.gz
gentoo-2-48c8706e7b4df4a5516b43e907aaf1aefe4e8f24.tar.bz2
gentoo-2-48c8706e7b4df4a5516b43e907aaf1aefe4e8f24.zip
Fix clean up in unlikely error handler.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/gcc-config')
-rw-r--r--sys-devel/gcc-config/ChangeLog7
-rw-r--r--sys-devel/gcc-config/gcc-config-1.7.2.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/sys-devel/gcc-config/ChangeLog b/sys-devel/gcc-config/ChangeLog
index 786b981bbdd7..b43c1854c4fc 100644
--- a/sys-devel/gcc-config/ChangeLog
+++ b/sys-devel/gcc-config/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gcc-config
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.211 2012/05/13 20:14:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.212 2012/05/31 04:32:38 vapier Exp $
+
+*gcc-config-1.7.2 (31 May 2012)
+
+ 31 May 2012; Mike Frysinger <vapier@gentoo.org> +gcc-config-1.7.2.ebuild:
+ Fix clean up in unlikely error handler.
*gcc-config-1.7.1 (13 May 2012)
diff --git a/sys-devel/gcc-config/gcc-config-1.7.2.ebuild b/sys-devel/gcc-config/gcc-config-1.7.2.ebuild
new file mode 100644
index 000000000000..bed819c29f1b
--- /dev/null
+++ b/sys-devel/gcc-config/gcc-config-1.7.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.7.2.ebuild,v 1.1 2012/05/31 04:32:38 vapier Exp $
+
+inherit unpacker toolchain-funcs multilib
+
+DESCRIPTION="utility to manage compilers"
+HOMEPAGE="http://git.overlays.gentoo.org/gitweb/?p=proj/gcc-config.git"
+SRC_URI="mirror://gentoo/${P}.tar.xz
+ http://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PV="${PV}" \
+ SUBLIBDIR="$(get_libdir)" \
+ install || die
+}
+
+pkg_postinst() {
+ # Scrub eselect-compiler remains
+ rm -f "${ROOT}"/etc/env.d/05compiler &
+
+ # Make sure old versions dont exist #79062
+ rm -f "${ROOT}"/usr/sbin/gcc-config &
+
+ # We not longer use the /usr/include/g++-v3 hacks, as
+ # it is not needed ...
+ rm -f "${ROOT}"/usr/include/g++{,-v3} &
+
+ # Do we have a valid multi ver setup ?
+ local x
+ for x in $(gcc-config -C -l 2>/dev/null | awk '$NF == "*" { print $2 }') ; do
+ gcc-config ${x}
+ done
+
+ wait
+}