summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-01-15 22:28:10 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-01-15 22:28:10 +0000
commitb45ce0155e6cd8565f3c6caf2a59cafa60b7b24a (patch)
tree8682372a49a5d51d3fef2622e8fb0793b3f0b78e /sys-devel/gcc-config
parentfixes bug# 13963 (diff)
downloadgentoo-2-b45ce0155e6cd8565f3c6caf2a59cafa60b7b24a.tar.gz
gentoo-2-b45ce0155e6cd8565f3c6caf2a59cafa60b7b24a.tar.bz2
gentoo-2-b45ce0155e6cd8565f3c6caf2a59cafa60b7b24a.zip
fix gcc not finding internal headers, bug #8132
Diffstat (limited to 'sys-devel/gcc-config')
-rw-r--r--sys-devel/gcc-config/ChangeLog9
-rw-r--r--sys-devel/gcc-config/files/digest-gcc-config-1.3.00
-rw-r--r--sys-devel/gcc-config/files/gcc-config-1.3.0357
-rw-r--r--sys-devel/gcc-config/files/wrapper.c6
-rw-r--r--sys-devel/gcc-config/gcc-config-1.3.0.ebuild84
5 files changed, 454 insertions, 2 deletions
diff --git a/sys-devel/gcc-config/ChangeLog b/sys-devel/gcc-config/ChangeLog
index 322453367f37..5141da042dd7 100644
--- a/sys-devel/gcc-config/ChangeLog
+++ b/sys-devel/gcc-config/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/gcc-config
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.16 2003/01/15 01:59:58 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.17 2003/01/15 22:28:10 azarah Exp $
+
+*gcc-config-1.3.0 (16 Jan 2003)
+
+ 16 Jan 2003; Martin Schlemmer <azarah@gentoo.org> gcc-config-1.3.0.ebuild :
+
+ Set argv[0] to the correct binary, else gcc do not find internal
+ headers, etc (bug #8132). Fixed files/wrapper.c for this.
*gcc-config-1.2.9 (15 Jan 2003)
diff --git a/sys-devel/gcc-config/files/digest-gcc-config-1.3.0 b/sys-devel/gcc-config/files/digest-gcc-config-1.3.0
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/sys-devel/gcc-config/files/digest-gcc-config-1.3.0
diff --git a/sys-devel/gcc-config/files/gcc-config-1.3.0 b/sys-devel/gcc-config/files/gcc-config-1.3.0
new file mode 100644
index 000000000000..929a3b1e1c18
--- /dev/null
+++ b/sys-devel/gcc-config/files/gcc-config-1.3.0
@@ -0,0 +1,357 @@
+#!/bin/bash
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Martin Schlemmer <azarah@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.0,v 1.1 2003/01/15 22:28:10 azarah Exp $
+
+
+source /etc/init.d/functions.sh || {
+ echo "$0: Could not source /etc/init.d/functions.sh!"
+ exit 1
+}
+
+usage() {
+cat << "USAGE_END"
+Usage: gcc-config [Option] [CC Profile]
+Change the current cc/gcc profile, or give info about profiles.
+
+Options:
+
+ --use-old Use the old profile if one was selected.
+
+ --use-portage-chost Only set to given profile if its CHOST is the same
+ as that set for portage in /etc/make.conf (or one of
+ other portage config files...).
+
+ --get-current-profile Print current used gcc profile.
+
+ --list-profiles Print a list of available profiles.
+
+ --print-environ Print environment that can be used to setup things
+ for current gcc profile, or specified one ...
+
+ --get-bin-path Print path where binaries of given/current profile
+ are located.
+
+ --get-lib-path Print path where libraries of given/current profile
+ are located.
+
+ --get-stdcxx-incdir Print path to g++ include files of given/current
+ profile.
+
+The profile name is in the form of:
+
+ <CHOST>-<gcc version>
+
+For example:
+
+ i686-pc-linux-gnu-3.2.1
+
+
+
+USAGE_END
+
+ exit 1
+}
+
+if [ "$#" -lt 1 ]
+then
+ usage
+fi
+
+cmd_setup() {
+
+ # Sourcing /etc/env.d/gcc/${CC_COMP} is going to mess up
+ # PATH among things...
+ CP="$(find_path cp)"
+ RM="$(find_path rm)"
+ MV="$(find_path mv)"
+ LN="$(find_path ln)"
+ CAT="$(find_path cat)"
+ AWK="$(find_path gawk)"
+ GREP="$(find_path grep)"
+ FIND="$(find_path find)"
+ CHMOD="$(find_path chmod)"
+ TOUCH="$(find_path touch)"
+ ENV_UPDATE="$(find_path env-update)"
+}
+
+find_path() {
+ [ -z "$1" ] && return 0
+
+ for x in /bin /sbin /usr/bin /usr/sbin
+ do
+ if [ -x ${x}/$1 -a -r ${x}/$1 ]
+ then
+ echo "${x}/$1"
+ break
+ fi
+ done
+}
+
+CC_COMP=""
+REAL_CHOST="$(/usr/bin/python -c 'import portage; print portage.settings["CHOST"];')"
+
+switch_profile() {
+ local MY_LDPATH=""
+ local GCC_PROFILES=""
+
+ if [ "$(id -u)" -ne 0 ]
+ then
+ eerror "$0: Must be root."
+ exit 1
+ fi
+
+ ebegin "Switching to ${CC_COMP} compiler"
+
+ # Sourcing /etc/env.d/gcc/${CC_COMP} is going to mess up
+ # PATH among things...
+ cmd_setup
+
+ # Order our profiles to have the default first...
+ # We do this so that we can have them ordered with default
+ # first in /etc/ld.so.conf, as the logical is that all
+ # compilers for default CHOST will be used to compile stuff,
+ # and thus we want all their lib paths in /etc/ld.so.conf ...
+ GCC_PROFILES="$(${FIND} /etc/env.d/gcc/ -name "${REAL_CHOST}-*")"
+ GCC_PROFILES="${GCC_PROFILES/\/etc\/env.d\/gcc\/${CC_COMP}}"
+ GCC_PROFILES="/etc/env.d/gcc/${CC_COMP} ${GCC_PROFILES}"
+
+ # Extract all LDPATH's for our CHOST
+ for x in ${GCC_PROFILES}
+ do
+ if [ -f ${x} ]
+ then
+ source ${x}
+
+ if [ -z "${MY_LDPATH}" ]
+ then
+ if [ -d ${LDPATH} ]
+ then
+ MY_LDPATH="${LDPATH}"
+ fi
+ else
+ if [ -d ${LDPATH} ]
+ then
+ MY_LDPATH="${MY_LDPATH}:${LDPATH}"
+ fi
+ fi
+ fi
+ done
+
+ # Setup things properly again for this profile
+ source /etc/env.d/gcc/${CC_COMP}
+
+ # Setup /etc/env.d/05gcc
+ ${AWK} '!/^STDCXX_INCDIR=|^LDPATH=/ {print $0}' \
+ /etc/env.d/gcc/${CC_COMP} > /etc/env.d/05gcc
+
+ # Add our custom LDPATH
+ echo "LDPATH=\"${MY_LDPATH}\"" >> /etc/env.d/05gcc
+
+ # Make sure we do not recreate /lib/cpp and /usr/bin/cc ...
+# echo "DISABLE_GEN_GCC_WRAPPERS=\"yes\"" >> /etc/env.d/05gcc
+
+ echo "CURRENT=${CC_COMP}" > /etc/env.d/gcc/config
+
+ source /etc/profile
+
+ # These might not be installed, and we want to update the mtime
+ # for ccache and distcc anyhow ...
+ ${RM} -f /lib/cpp
+ ${CP} -f /usr/lib/gcc-config/wrapper /lib/cpp
+ for x in gcc cpp cc c++ g++ ${CHOST}-gcc ${CHOST}-c++ ${CHOST}-g++
+ do
+ ${RM} -f /usr/bin/${x}
+ ${CP} -f /usr/lib/gcc-config/wrapper /usr/bin/${x}
+ ${TOUCH} -m /usr/bin/${x}
+ done
+
+
+ ${ENV_UPDATE} &> /dev/null
+
+ eend 0
+
+ return 0
+}
+
+get_current_profile() {
+ if [ ! -f /etc/env.d/gcc/config ]
+ then
+ eerror "$0: No gcc profile is active!"
+ return 1
+ fi
+
+ source /etc/env.d/gcc/config
+
+ if [ -z "${CURRENT}" ]
+ then
+ eerror "$0: No gcc profile is active!"
+ return 1
+ fi
+
+ echo "${CURRENT}"
+
+ return 0
+}
+
+list_profiles() {
+ if [ ! -f /etc/env.d/gcc/config ]
+ then
+ eerror "$0: No gcc profile is active!"
+ return 1
+ fi
+
+ for x in /etc/env.d/gcc/*
+ do
+ if [ -f ${x} -a ${x} != "/etc/env.d/gcc/config" ]
+ then
+ echo "${x##*/}"
+ fi
+ done
+}
+
+print_environ() {
+ local OLDPATH="${PATH}"
+
+ source /etc/env.d/gcc/${CC_COMP}
+
+ echo "export PATH=\"${PATH}:${OLDPATH}\""
+
+# if [ -z "${LD_LIBRARY_PATH}" ]
+# then
+# echo "export LD_LIBRARY_PATH=\"${LDPATH}\""
+# else
+# echo "export LD_LIBRARY_PATH=\"${LDPATH}:${LD_LIBRARY_PATH}\""
+# fi
+
+ echo "export CC=\"${CC}\""
+ echo "export CXX=\"${CXX}\""
+}
+
+get_bin_path() {
+ source /etc/env.d/gcc/${CC_COMP}
+
+ echo "${PATH}"
+
+ return 0
+}
+
+get_lib_path() {
+ source /etc/env.d/gcc/${CC_COMP}
+
+ echo "${LDPATH}"
+
+ return 0
+}
+
+get_stdcxx_incdir() {
+ source /etc/env.d/gcc/${CC_COMP}
+
+ echo "${LDPATH}/include/${STDCXX_INCDIR}"
+
+ return 0
+}
+
+NEED_ACTION="yes"
+DOIT="switch_profile"
+CHECK_CHOST="no"
+
+for x in $*
+do
+ case ${x} in
+ # Only use specified compiler if one is not already selected.
+ --use-old)
+ if get_current_profile &> /dev/null
+ then
+ CC_COMP="$(get_current_profile)"
+ fi
+ ;;
+ --use-portage-chost)
+ CHECK_CHOST="yes"
+ ;;
+ --get-current-profile)
+ if [ "${NEED_ACTION}" = "yes" ]
+ then
+ NEED_ACTION="no"
+ DOIT="get_current_profile"
+ fi
+ ;;
+ --list-profiles)
+ if [ "${NEED_ACTION}" = "yes" ]
+ then
+ NEED_ACTION="no"
+ DOIT="list_profiles"
+ fi
+ ;;
+ --print-environ)
+ if [ "${NEED_ACTION}" = "yes" ]
+ then
+ NEED_ACTION="no"
+ DOIT="print_environ"
+ fi
+ ;;
+ --get-bin-path)
+ if [ "${NEED_ACTION}" = "yes" ]
+ then
+ NEED_ACTION="no"
+ DOIT="get_bin_path"
+ fi
+ ;;
+ --get-lib-path)
+ if [ "${NEED_ACTION}" = "yes" ]
+ then
+ NEED_ACTION="no"
+ DOIT="get_lib_path"
+ fi
+ ;;
+ --get-stdcxx-incdir)
+ if [ "${NEED_ACTION}" = "yes" ]
+ then
+ NEED_ACTION="no"
+ DOIT="get_stdcxx_incdir"
+ fi
+ ;;
+ *)
+ if [ -z "${CC_COMP}" ]
+ then
+ CC_COMP="${x}"
+ fi
+ ;;
+ esac
+done
+
+if [ "${DOIT}" = "switch_profile" -a -z "${CC_COMP}" ]
+then
+ usage
+fi
+
+if [ -z "${CC_COMP}" ]
+then
+ if get_current_profile &> /dev/null
+ then
+ CC_COMP="$(get_current_profile)"
+ else
+ eerror "$0: No default profile setup!"
+ exit 1
+ fi
+fi
+
+if [ ! -d /usr/lib/gcc-lib/${CC_COMP%-*}/${CC_COMP##*-} -o \
+ ! -f /etc/env.d/gcc/${CC_COMP} ]
+then
+ eerror "$0: Profile does not exist!"
+ exit 1
+fi
+
+# Chosen CHOST are not the same as the real CHOST according to make.conf,
+# and --use-portage-chost option was given, so do nothing ...
+if [ "${CHECK_CHOST}" = "yes" -a "${CC_COMP%-*}" != "${REAL_CHOST}" ]
+then
+ exit 0
+fi
+
+eval ${DOIT}
+
+
+# vim:ts=4
diff --git a/sys-devel/gcc-config/files/wrapper.c b/sys-devel/gcc-config/files/wrapper.c
index 8ea3aa928d6b..a88626547183 100644
--- a/sys-devel/gcc-config/files/wrapper.c
+++ b/sys-devel/gcc-config/files/wrapper.c
@@ -2,7 +2,7 @@
* Copyright 1999-2003 Gentoo Technologies, Inc.
* Distributed under the terms of the GNU General Public License v2
* Author: Martin Schlemmer <azarah@gentoo.org>
- * $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/wrapper.c,v 1.2 2003/01/15 01:59:58 azarah Exp $
+ * $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/wrapper.c,v 1.3 2003/01/15 22:28:10 azarah Exp $
*/
#define _REENTRANT
@@ -114,6 +114,10 @@ int main(int argc, char **argv) {
}
}
+ /* Set argv[0] to the correct binary, else gcc do not find internal
+ * headers, etc (bug #8132). */
+ argv[0] = wrapperbin;
+
/* Ok, do it ... */
if (execv(wrapperbin, argv) < 0) {
fprintf(stderr, "Could not run/locate %s!\n", wrappername);
diff --git a/sys-devel/gcc-config/gcc-config-1.3.0.ebuild b/sys-devel/gcc-config/gcc-config-1.3.0.ebuild
new file mode 100644
index 000000000000..768423afa829
--- /dev/null
+++ b/sys-devel/gcc-config/gcc-config-1.3.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.0.ebuild,v 1.1 2003/01/15 22:28:10 azarah Exp $
+
+DISABLE_GEN_GCC_WRAPPERS="yes"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Utility to change the gcc compiler being used."
+SRC_URI=""
+HOMEPAGE="http://www.gentoo.org/"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc"
+
+
+src_install() {
+
+ # Setup PATH just in case ...
+ if /usr/bin/gcc-config --get-current-profile &> /dev/null || \
+ /usr/sbin/gcc-config --get-current-profile &> /dev/null
+ then
+ if [ -x /usr/bin/gcc-config ]
+ then
+ export PATH="`/usr/bin/gcc-config --get-bin-path`:${PATH}"
+ else
+ export PATH="`/usr/sbin/gcc-config --get-bin-path`:${PATH}"
+ fi
+ fi
+
+ einfo "Compiling wrapper..."
+ gcc -O2 -Wall -o ${WORKDIR}/wrapper ${FILESDIR}/wrapper.c
+
+ exeinto /usr/lib/gcc-config
+ doexe ${WORKDIR}/wrapper
+
+ # Only setup this if we have a proper gcc version installed, else
+ # we will nuke the non gcc-config versions ...
+ if /usr/bin/gcc-config --get-current-profile &> /dev/null || \
+ /usr/sbin/gcc-config --get-current-profile &> /dev/null
+ then
+ einfo "Creating wrappers for compiler tools..."
+ exeinto /lib
+ newexe ${WORKDIR}/wrapper cpp
+
+ exeinto /usr/bin
+ for x in gcc cpp cc c++ g++ ${CHOST}-gcc ${CHOST}-c++ ${CHOST}-g++
+ do
+ newexe ${WORKDIR}/wrapper ${x}
+ done
+ fi
+
+ einfo "Adding compat symlinks..."
+ into /usr
+ dodir /usr/sbin
+ newbin ${FILESDIR}/${PN}-${PV} ${PN}
+ dosym ../bin/${PN} /usr/sbin/${PN}
+}
+
+pkg_postinst() {
+
+ # Do we have a valid multi ver setup ?
+ if ${ROOT}/usr/bin/gcc-config --get-current-profile &> /dev/null
+ then
+ # We not longer use the /usr/include/g++-v3 hacks, as
+ # it is not needed ...
+ if [ -L ${ROOT}/usr/include/g++ ]
+ then
+ rm -f ${ROOT}/usr/include/g++
+ fi
+ if [ -L ${ROOT}/usr/include/g++-v3 ]
+ then
+ rm -f ${ROOT}/usr/include/g++-v3
+ fi
+
+ if [ ${ROOT} = "/" ]
+ then
+ /usr/bin/gcc-config $(/usr/bin/gcc-config --get-current-profile)
+ fi
+ fi
+}
+