summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-19 00:46:46 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-19 00:46:46 +0000
commit6cf5d4ff6c35240c2fc3b18a1971d85438e6a1f3 (patch)
treecc781e1c13842551afadc4be90751d2a6cf2b55b /sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-6cf5d4ff6c35240c2fc3b18a1971d85438e6a1f3.tar.gz
gentoo-2-6cf5d4ff6c35240c2fc3b18a1971d85438e6a1f3.tar.bz2
gentoo-2-6cf5d4ff6c35240c2fc3b18a1971d85438e6a1f3.zip
Update uclibc patches and split them off into a sep tarball.
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild')
-rw-r--r--sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild93
1 files changed, 93 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild b/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild
new file mode 100644
index 000000000000..4c119c932866
--- /dev/null
+++ b/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild,v 1.1 2005/03/19 00:46:46 vapier Exp $
+
+MAN_VER="3.3.5"
+PATCH_VER="1.3"
+UCLIBC_VER="1.0"
+PIE_VER="8.7.7.1"
+PIE_CORE="gcc-3.3.5-piepatches-v${PIE_VER}.tar.bz2"
+PP_VER="3_3_5_20050130"
+PP_FVER="${PP_VER//_/.}-1"
+HTB_VER="1.00-r2"
+#HTB_GCC_VER="3.3.5"
+
+ETYPE="gcc-compiler"
+
+# arch/libc configurations known to be stable with {PIE,SSP}-by-default
+SSP_STABLE="x86 sparc amd64"
+SSP_UCLIBC_STABLE="arm mips ppc x86"
+PIE_GLIBC_STABLE="x86 sparc amd64"
+PIE_UCLIBC_STABLE="x86 mips ppc"
+
+# arch/libc configurations known to be broken with {PIE,SSP}-by-default
+SSP_UNSUPPORTED="hppa"
+SSP_UCLIBC_UNSUPPORTED="${SSP_UNSUPPORTED}"
+PIE_UCLIBC_UNSUPPORTED="alpha amd64 arm hppa ia64 m68k ppc64 s390 sh sparc"
+PIE_GLIBC_UNSUPPORTED="hppa"
+
+# whether we should split out specs files for multiple {PIE,SSP}-by-default
+# and vanilla configurations.
+SPLIT_SPECS=${SPLIT_SPECS:-"true"}
+
+#GENTOO_PATCH_EXCLUDE=""
+#PIEPATCH_EXCLUDE=""
+
+inherit toolchain eutils
+
+DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
+
+KEYWORDS="~alpha -amd64 ~arm ~hppa -ia64 ~mips ~sh sparc ~x86"
+
+# NOTE: we SHOULD be using at least binutils 2.15.90.0.1 everywhere for proper
+# .eh_frame ld optimisation and symbol visibility support, but it hasnt been
+# well tested in gentoo on any arch other than amd64!!
+RDEPEND="virtual/libc
+ >=sys-devel/gcc-config-1.3.6
+ >=sys-libs/zlib-1.1.4
+ !sys-devel/hardened-gcc
+ !uclibc? ( >=sys-libs/glibc-2.3.2-r9 )
+ >=sys-devel/binutils-2.14.90.0.6-r1
+ >=sys-devel/bison-1.875
+ amd64? ( multilib? ( >=app-emulation/emul-linux-x86-glibc-1.1 ) )
+ sparc? ( hardened? ( >=sys-libs/glibc-2.3.3.20040420 ) )
+ !build? (
+ gcj? (
+ gtk? ( >=x11-libs/gtk+-2.2 )
+ >=media-libs/libart_lgpl-2.1
+ )
+ >=sys-libs/ncurses-5.2-r2
+ nls? ( sys-devel/gettext )
+ )"
+
+if [[ ${CATEGORY/cross-} != ${CATEGORY} ]]; then
+ RDEPEND="${RDEPEND} ${CATEGORY}/binutils"
+fi
+
+DEPEND="${RDEPEND}
+ >=sys-apps/texinfo-4.2-r4
+ amd64? ( >=sys-devel/binutils-2.15.90.0.1.1-r1 )"
+PDEPEND="sys-devel/gcc-config"
+
+src_unpack() {
+ gcc_src_unpack
+
+ # bah
+ sed -e 's/3\.3\.6/3.3.5/' -i "${S}"/gcc/version.c
+
+ if [[ -n ${PATCH_VER} ]] && is_uclibc ; then
+ mv ${S}/gcc-3.3.2/libstdc++-v3/config/os/uclibc ${S}/libstdc++-v3/config/os/ || die
+ mv ${S}/gcc-3.3.2/libstdc++-v3/config/locale/uclibc ${S}/libstdc++-v3/config/locale/ || die
+ fi
+
+ # misc patches that havent made it into a patch tarball yet
+ epatch ${FILESDIR}/gcc-spec-env.patch
+
+ # Anything useful and objc will require libffi. Seriously. Lets just force
+ # libffi to install with USE="objc", even though it normally only installs
+ # if you attempt to build gcj.
+ if ! ( ! use build && use objc && ! use gcj ) ; then
+ GENTOO_PATCH_EXCLUDE="42*"
+ #epatch ${FILESDIR}/3.4.3/libffi-nogcj-lib-path-fix.patch
+ fi
+}