summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-07-14 23:28:59 +0000
committerTravis Tilley <lv@gentoo.org>2004-07-14 23:28:59 +0000
commita6a4e97c18c501b2d4b3c768530a7ada872e8548 (patch)
tree008980b92d432cfab830f4d4642ef3aa47a6ff8e /sys-devel/gcc/gcc-3.4.0-r6.ebuild
parentsync IUSE (missing) (Manifest recommit) (diff)
downloadgentoo-2-a6a4e97c18c501b2d4b3c768530a7ada872e8548.tar.gz
gentoo-2-a6a4e97c18c501b2d4b3c768530a7ada872e8548.tar.bz2
gentoo-2-a6a4e97c18c501b2d4b3c768530a7ada872e8548.zip
fix version checking to work with gcc 3.4's /usr/lib/gcc
Diffstat (limited to 'sys-devel/gcc/gcc-3.4.0-r6.ebuild')
-rw-r--r--sys-devel/gcc/gcc-3.4.0-r6.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-devel/gcc/gcc-3.4.0-r6.ebuild b/sys-devel/gcc/gcc-3.4.0-r6.ebuild
index b090c3d50eb1..2affe134becc 100644
--- a/sys-devel/gcc/gcc-3.4.0-r6.ebuild
+++ b/sys-devel/gcc/gcc-3.4.0-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.0-r6.ebuild,v 1.18 2004/07/12 17:22:19 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.0-r6.ebuild,v 1.19 2004/07/14 23:28:59 lv Exp $
IUSE="static nls bootstrap build multilib gcj gtk2 f77 objc hardened uclibc n32 n64"
@@ -190,7 +190,7 @@ chk_gcc_version() {
# This next bit is for updating libtool linker scripts ...
local OLD_GCC_VERSION="`gcc -dumpversion`"
local OLD_GCC_CHOST="$(gcc -v 2>&1 | egrep '^Reading specs' |\
- sed -e 's:^.*/gcc-lib/\([^/]*\)/[0-9]\+.*$:\1:')"
+ sed -e 's:^.*/gcc[^/]*/\([^/]*\)/[0-9]\+.*$:\1:')"
if [ "${OLD_GCC_VERSION}" != "${MY_PV_FULL}" ]
then