summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-10-17 17:49:53 +0000
committerMike Frysinger <vapier@gentoo.org>2014-10-17 17:49:53 +0000
commit4329f7cb722ad14365f2cf86930904c14e806f1e (patch)
tree9416f8ff131a8b23f6971b007d106a785b444864 /sys-devel/gcc/gcc-4.2.4-r1.ebuild
parentDrop softfloat support in older versions. (diff)
downloadgentoo-2-4329f7cb722ad14365f2cf86930904c14e806f1e.tar.gz
gentoo-2-4329f7cb722ad14365f2cf86930904c14e806f1e.tar.bz2
gentoo-2-4329f7cb722ad14365f2cf86930904c14e806f1e.zip
Drop $GCC_SPECS support in older versions.
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-devel/gcc/gcc-4.2.4-r1.ebuild')
-rw-r--r--sys-devel/gcc/gcc-4.2.4-r1.ebuild12
1 files changed, 2 insertions, 10 deletions
diff --git a/sys-devel/gcc/gcc-4.2.4-r1.ebuild b/sys-devel/gcc/gcc-4.2.4-r1.ebuild
index 5c00703ae509..47cfa7f2574f 100644
--- a/sys-devel/gcc/gcc-4.2.4-r1.ebuild
+++ b/sys-devel/gcc/gcc-4.2.4-r1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.2.4-r1.ebuild,v 1.17 2014/10/17 17:47:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.2.4-r1.ebuild,v 1.18 2014/10/17 17:49:53 vapier Exp $
EAPI="2"
PATCH_VER="1.3"
UCLIBC_VER="1.0"
-inherit eutils toolchain
+inherit toolchain
DESCRIPTION="The GNU Compiler Collection"
@@ -19,11 +19,3 @@ DEPEND="${RDEPEND}
ppc? ( >=${CATEGORY}/binutils-2.17 )
ppc64? ( >=${CATEGORY}/binutils-2.17 )
>=${CATEGORY}/binutils-2.15.94"
-
-src_prepare() {
- toolchain_src_prepare
-
- use vanilla && return 0
-
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
-}