summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2005-12-24 00:59:20 +0000
committerMark Loeser <halcy0n@gentoo.org>2005-12-24 00:59:20 +0000
commit17f7c7d247e5c0b36bcc2fcd8c7d1b636fa641c2 (patch)
treeadc9f6e8181015417a02d6ba1a45bce461943277 /sys-devel/gcc
parentAdded patch to make unconditional the GNU stack marking (fixes executable sta... (diff)
downloadgentoo-2-17f7c7d247e5c0b36bcc2fcd8c7d1b636fa641c2.tar.gz
gentoo-2-17f7c7d247e5c0b36bcc2fcd8c7d1b636fa641c2.tar.bz2
gentoo-2-17f7c7d247e5c0b36bcc2fcd8c7d1b636fa641c2.zip
Bump to a new gcc-4.1 snapshot. The patch from pr22313 is now included upstream.
(Portage version: 2.1_pre1)
Diffstat (limited to 'sys-devel/gcc')
-rw-r--r--sys-devel/gcc/ChangeLog10
-rw-r--r--sys-devel/gcc/files/4.1.0/gcc-4.1.0-pr22313.patch65
-rw-r--r--sys-devel/gcc/files/digest-gcc-4.1.0_beta200512161
-rw-r--r--sys-devel/gcc/files/digest-gcc-4.1.0_beta200512231
-rw-r--r--sys-devel/gcc/gcc-4.1.0_beta20051223.ebuild (renamed from sys-devel/gcc/gcc-4.1.0_beta20051216.ebuild)3
5 files changed, 11 insertions, 69 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index ca551d0155e9..3f85d4defaea 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.478 2005/12/20 21:08:16 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.479 2005/12/24 00:59:19 halcy0n Exp $
+
+*gcc-4.1.0_beta20051223 (24 Dec 2005)
+
+ 24 Dec 2005; Mark Loeser <halcy0n@gentoo.org>
+ -files/4.1.0/gcc-4.1.0-pr22313.patch, -gcc-4.1.0_beta20051216.ebuild,
+ +gcc-4.1.0_beta20051223.ebuild:
+ Bump to a new gcc-4.1 snapshot. The patch from pr22313 is now included
+ upstream.
20 Dec 2005; Mark Loeser <halcy0n@gentoo.org> gcc-4.0.1.ebuild,
gcc-4.0.2-r2.ebuild, gcc-4.1.0_beta20051216.ebuild:
diff --git a/sys-devel/gcc/files/4.1.0/gcc-4.1.0-pr22313.patch b/sys-devel/gcc/files/4.1.0/gcc-4.1.0-pr22313.patch
deleted file mode 100644
index 9787a204ae29..000000000000
--- a/sys-devel/gcc/files/4.1.0/gcc-4.1.0-pr22313.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-Andrew Pinski
-
-ChangeLog:
-
- * dwarf2out.c (dwarf2out_switch_text_section): Export.
- * debug.h (dwarf2out_switch_text_section): Prototype.
- * final.c (final_scan_insn): Call dwarf2out_switch_text_section
- if we need to call it for dwarf2 unwind info.
-
-diff -ur gcc-4.1-20051105-orig/gcc/debug.h gcc-4.1-20051105/gcc/debug.h
---- gcc-4.1-20051105-orig/gcc/debug.h 2005-11-12 00:09:33.376787809 +0000
-+++ gcc-4.1-20051105/gcc/debug.h 2005-11-12 00:10:06.962349214 +0000
-@@ -160,6 +160,7 @@
- /* Decide whether we want to emit frame unwind information for the current
- translation unit. */
- extern int dwarf2out_do_frame (void);
-+void dwarf2out_switch_text_section (void);
-
- extern void debug_flush_symbol_queue (void);
- extern void debug_queue_symbol (tree);
-diff -ur gcc-4.1-20051105-orig/gcc/dwarf2out.c gcc-4.1-20051105/gcc/dwarf2out.c
---- gcc-4.1-20051105-orig/gcc/dwarf2out.c 2005-11-12 00:09:26.948488952 +0000
-+++ gcc-4.1-20051105/gcc/dwarf2out.c 2005-11-12 00:10:06.962349214 +0000
-@@ -3520,7 +3520,6 @@
- static void dwarf2out_abstract_function (tree);
- static void dwarf2out_var_location (rtx);
- static void dwarf2out_begin_function (tree);
--static void dwarf2out_switch_text_section (void);
-
- /* The debug hooks structure. */
-
-@@ -6866,7 +6865,7 @@
- *d = new_loc_list (descr, begin, end, section, 0);
- }
-
--static void
-+void
- dwarf2out_switch_text_section (void)
- {
- dw_fde_ref fde;
-diff -ur gcc-4.1-20051105-orig/gcc/final.c gcc-4.1-20051105/gcc/final.c
---- gcc-4.1-20051105-orig/gcc/final.c 2005-11-12 00:09:26.912487279 +0000
-+++ gcc-4.1-20051105/gcc/final.c 2005-11-12 00:10:06.962349214 +0000
-@@ -1717,11 +1717,21 @@
- if (last_text_section == in_text)
- {
- (*debug_hooks->switch_text_section) ();
-+#if defined (DWARF2_UNWIND_INFO)
-+ if (write_symbols != DWARF2_DEBUG && write_symbols != VMS_AND_DWARF2_DEBUG
-+ && dwarf2out_do_frame ())
-+ dwarf2out_switch_text_section ();
-+#endif
- unlikely_text_section ();
- }
- else
- {
- (*debug_hooks->switch_text_section) ();
-+#if defined (DWARF2_UNWIND_INFO)
-+ if (write_symbols != DWARF2_DEBUG && write_symbols != VMS_AND_DWARF2_DEBUG
-+ && dwarf2out_do_frame ())
-+ dwarf2out_switch_text_section ();
-+#endif
- text_section ();
- }
- break;
diff --git a/sys-devel/gcc/files/digest-gcc-4.1.0_beta20051216 b/sys-devel/gcc/files/digest-gcc-4.1.0_beta20051216
deleted file mode 100644
index d3f89ea1e24b..000000000000
--- a/sys-devel/gcc/files/digest-gcc-4.1.0_beta20051216
+++ /dev/null
@@ -1 +0,0 @@
-MD5 85abcb1651194c9d1ae2cd3e3c797e1b gcc-4.1-20051216.tar.bz2 36693636
diff --git a/sys-devel/gcc/files/digest-gcc-4.1.0_beta20051223 b/sys-devel/gcc/files/digest-gcc-4.1.0_beta20051223
new file mode 100644
index 000000000000..e924cb7d7df4
--- /dev/null
+++ b/sys-devel/gcc/files/digest-gcc-4.1.0_beta20051223
@@ -0,0 +1 @@
+MD5 3fc04589e6930277d859f9896acaffab gcc-4.1-20051223.tar.bz2 36686699
diff --git a/sys-devel/gcc/gcc-4.1.0_beta20051216.ebuild b/sys-devel/gcc/gcc-4.1.0_beta20051223.ebuild
index 47eb4509e0b5..f326b052bace 100644
--- a/sys-devel/gcc/gcc-4.1.0_beta20051216.ebuild
+++ b/sys-devel/gcc/gcc-4.1.0_beta20051223.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.1.0_beta20051216.ebuild,v 1.2 2005/12/20 21:08:16 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.1.0_beta20051223.ebuild,v 1.1 2005/12/24 00:59:19 halcy0n Exp $
ETYPE="gcc-compiler"
@@ -50,7 +50,6 @@ pkg_setup() {
src_unpack() {
toolchain_src_unpack
- epatch "${FILESDIR}"/4.1.0/gcc-4.1.0-pr22313.patch
echo ${PV/_/-} > "${S}"/gcc/BASE-VER
echo "" > "${S}"/gcc/DATESTAMP