summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2009-05-03 19:36:55 +0000
committerMark Loeser <halcy0n@gentoo.org>2009-05-03 19:36:55 +0000
commit5c13c7e2877c4fc741e9d78a1a476f55acf92b62 (patch)
treebbb7916c8e609fcf27195da06bcce607699554ba /sys-devel/gcc
parentStable on alpha, bug #267663 (diff)
downloadgentoo-2-5c13c7e2877c4fc741e9d78a1a476f55acf92b62.tar.gz
gentoo-2-5c13c7e2877c4fc741e9d78a1a476f55acf92b62.tar.bz2
gentoo-2-5c13c7e2877c4fc741e9d78a1a476f55acf92b62.zip
Add DEPEND on >=glibc-2.8; bug #267650
(Portage version: 2.2_rc32/cvs/Linux i686)
Diffstat (limited to 'sys-devel/gcc')
-rw-r--r--sys-devel/gcc/ChangeLog6
-rw-r--r--sys-devel/gcc/gcc-4.3.3-r2.ebuild3
-rw-r--r--sys-devel/gcc/gcc-4.3.3.ebuild76
3 files changed, 7 insertions, 78 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 0ec419cfbda6..2c315cc1412d 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.702 2009/05/03 00:21:52 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.703 2009/05/03 19:36:55 halcy0n Exp $
+
+ 03 May 2009; Mark Loeser <halcy0n@gentoo.org> -gcc-4.3.3.ebuild,
+ gcc-4.3.3-r2.ebuild:
+ Add DEPEND on >=glibc-2.8; bug #267650
03 May 2009; Mark Loeser <halcy0n@gentoo.org> gcc-3.4.6-r2.ebuild,
gcc-4.0.4.ebuild, gcc-4.1.2.ebuild, gcc-4.2.4-r1.ebuild, gcc-4.3.0.ebuild,
diff --git a/sys-devel/gcc/gcc-4.3.3-r2.ebuild b/sys-devel/gcc/gcc-4.3.3-r2.ebuild
index dc4d81866867..3524c2f9f27b 100644
--- a/sys-devel/gcc/gcc-4.3.3-r2.ebuild
+++ b/sys-devel/gcc/gcc-4.3.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.3-r2.ebuild,v 1.2 2009/05/03 00:21:52 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.3-r2.ebuild,v 1.3 2009/05/03 19:36:55 halcy0n Exp $
GENTOO_PATCH_EXCLUDE="69_all_gcc43-pr39013.patch" #262567
@@ -58,6 +58,7 @@ DEPEND="${RDEPEND}
>=sys-apps/texinfo-4.2-r4
>=sys-devel/bison-1.875
sys-devel/flex
+ elibc_glibc? ( >=sys-libs/glibc-2.8 )
amd64? ( multilib? ( gcj? ( app-emulation/emul-linux-x86-xlibs ) ) )
ppc? ( >=${CATEGORY}/binutils-2.17 )
ppc64? ( >=${CATEGORY}/binutils-2.17 )
diff --git a/sys-devel/gcc/gcc-4.3.3.ebuild b/sys-devel/gcc/gcc-4.3.3.ebuild
deleted file mode 100644
index 17714ab4a8ab..000000000000
--- a/sys-devel/gcc/gcc-4.3.3.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.3.ebuild,v 1.4 2009/05/03 00:21:52 halcy0n Exp $
-
-PATCH_VER="1.0"
-UCLIBC_VER="1.0"
-
-ETYPE="gcc-compiler"
-
-# Hardened gcc 4 stuff
-PIE_VER="10.1.5"
-SPECS_VER="0.9.4"
-
-# arch/libc configurations known to be stable or untested with {PIE,SSP,FORTIFY}-by-default
-PIE_GLIBC_STABLE="x86 amd64 ~ppc ~ppc64 ~arm ~sparc"
-PIE_UCLIBC_STABLE="x86 arm"
-#SSP_STABLE="amd64 x86 ppc ppc64 ~arm ~sparc"
-#SSP_UCLIBC_STABLE=""
-
-# whether we should split out specs files for multiple {PIE,SSP}-by-default
-# and vanilla configurations.
-SPLIT_SPECS=no #${SPLIT_SPECS-true} hard disable until #106690 is fixed
-
-inherit toolchain
-
-DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
-
-LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-
-RDEPEND=">=sys-libs/zlib-1.1.4
- >=sys-devel/gcc-config-1.4
- virtual/libiconv
- >=dev-libs/gmp-4.2.1
- >=dev-libs/mpfr-2.3
- !build? (
- gcj? (
- gtk? (
- x11-libs/libXt
- x11-libs/libX11
- x11-libs/libXtst
- x11-proto/xproto
- x11-proto/xextproto
- >=x11-libs/gtk+-2.2
- x11-libs/pango
- )
- >=media-libs/libart_lgpl-2.1
- app-arch/zip
- app-arch/unzip
- )
- >=sys-libs/ncurses-5.2-r2
- nls? ( sys-devel/gettext )
- )"
-DEPEND="${RDEPEND}
- test? ( sys-devel/autogen dev-util/dejagnu )
- >=sys-apps/texinfo-4.2-r4
- >=sys-devel/bison-1.875
- sys-devel/flex
- amd64? ( multilib? ( gcj? ( app-emulation/emul-linux-x86-xlibs ) ) )
- ppc? ( >=${CATEGORY}/binutils-2.17 )
- ppc64? ( >=${CATEGORY}/binutils-2.17 )
- >=${CATEGORY}/binutils-2.15.94"
-PDEPEND=">=sys-devel/gcc-config-1.4"
-if [[ ${CATEGORY} != cross-* ]] ; then
- PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
-fi
-
-src_unpack() {
- gcc_src_unpack
-
- use vanilla && return 0
-
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
-
- [[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.3.2/gcc-4.3.2-softfloat.patch
-}