summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-03-22 16:14:19 +0000
committerMike Frysinger <vapier@gentoo.org>2011-03-22 16:14:19 +0000
commit471fc27af03f58c3a7776cf130202e291aa0060f (patch)
tree48ffe24a8cb991ccf03704a80a72c75715788603 /sys-devel/gdb
parentRemove PROVIDE="virtual/bootloader" (bug #359971). (diff)
downloadgentoo-2-471fc27af03f58c3a7776cf130202e291aa0060f.tar.gz
gentoo-2-471fc27af03f58c3a7776cf130202e291aa0060f.tar.bz2
gentoo-2-471fc27af03f58c3a7776cf130202e291aa0060f.zip
Switch back to system readline now that newer versions work again.
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/gdb')
-rw-r--r--sys-devel/gdb/ChangeLog6
-rw-r--r--sys-devel/gdb/gdb-7.1.ebuild6
-rw-r--r--sys-devel/gdb/gdb-7.2.ebuild4
3 files changed, 10 insertions, 6 deletions
diff --git a/sys-devel/gdb/ChangeLog b/sys-devel/gdb/ChangeLog
index 98398b820b7c..15abb9943b64 100644
--- a/sys-devel/gdb/ChangeLog
+++ b/sys-devel/gdb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/gdb
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/ChangeLog,v 1.182 2011/03/16 15:18:22 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/ChangeLog,v 1.183 2011/03/22 16:14:19 vapier Exp $
+
+ 22 Mar 2011; Mike Frysinger <vapier@gentoo.org> gdb-7.1.ebuild,
+ gdb-7.2.ebuild:
+ Switch back to system readline now that newer versions work again.
16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> gdb-7.2.ebuild:
ppc64 stable wrt #350259
diff --git a/sys-devel/gdb/gdb-7.1.ebuild b/sys-devel/gdb/gdb-7.1.ebuild
index b3e286247d11..12fa13f1617b 100644
--- a/sys-devel/gdb/gdb-7.1.ebuild
+++ b/sys-devel/gdb/gdb-7.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.1.ebuild,v 1.1 2010/03/19 02:21:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.1.ebuild,v 1.2 2011/03/22 16:14:19 vapier Exp $
inherit flag-o-matic eutils
@@ -57,7 +57,7 @@ src_compile() {
--with-pkgversion="$(gdb_branding)" \
--with-bugurl='http://bugs.gentoo.org/' \
--disable-werror \
- $(has_version '=sys-libs/readline-5*:0' && echo --with-system-readline) \
+ --with-system-readline \
$(is_cross && echo --with-sysroot=/usr/${CTARGET}) \
$(use_with expat) \
$(use_enable nls) \
diff --git a/sys-devel/gdb/gdb-7.2.ebuild b/sys-devel/gdb/gdb-7.2.ebuild
index 7a62f105c05b..e228a15bf4c5 100644
--- a/sys-devel/gdb/gdb-7.2.ebuild
+++ b/sys-devel/gdb/gdb-7.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.2.ebuild,v 1.10 2011/03/16 15:18:22 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.2.ebuild,v 1.11 2011/03/22 16:14:19 vapier Exp $
EAPI="3"
@@ -76,7 +76,7 @@ src_configure() {
--with-bugurl='http://bugs.gentoo.org/' \
--disable-werror \
--enable-64-bit-bfd \
- $(has_version '=sys-libs/readline-5*:0' && echo --with-system-readline) \
+ --with-system-readline \
$(is_cross && echo --with-sysroot=/usr/${CTARGET}) \
$(use_with expat) \
$(use_enable nls) \