summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-06-10 19:39:55 +0000
committerMike Frysinger <vapier@gentoo.org>2006-06-10 19:39:55 +0000
commita04278a6adafa52a1947b36c5f0876f43d120069 (patch)
treeba8f781b59ed025a1e13c291e68874e465ba6313 /sys-devel/gdb
parentbetter NLS patch #124063 (diff)
downloadgentoo-2-a04278a6adafa52a1947b36c5f0876f43d120069.tar.gz
gentoo-2-a04278a6adafa52a1947b36c5f0876f43d120069.tar.bz2
gentoo-2-a04278a6adafa52a1947b36c5f0876f43d120069.zip
fix building in et_EE locale #125264
(Portage version: 2.1)
Diffstat (limited to 'sys-devel/gdb')
-rw-r--r--sys-devel/gdb/files/gdb-configure-LANG.patch44
-rw-r--r--sys-devel/gdb/gdb-6.4-r4.ebuild3
2 files changed, 46 insertions, 1 deletions
diff --git a/sys-devel/gdb/files/gdb-configure-LANG.patch b/sys-devel/gdb/files/gdb-configure-LANG.patch
new file mode 100644
index 000000000000..e95ad8755670
--- /dev/null
+++ b/sys-devel/gdb/files/gdb-configure-LANG.patch
@@ -0,0 +1,44 @@
+The LANG vars aren't reset early enough so when sed tries to use [a-zA-Z] in
+option parsing, it may break.
+
+http://bugs.gentoo.org/125264
+
+--- configure
++++ configure
+@@ -54,6 +54,19 @@
+ infodir='${prefix}/info'
+ mandir='${prefix}/man'
+
++# NLS nuisances.
++for as_var in \
++ LANG LANGUAGE LC_ADDRESS LC_ALL LC_COLLATE LC_CTYPE LC_IDENTIFICATION \
++ LC_MEASUREMENT LC_MESSAGES LC_MONETARY LC_NAME LC_NUMERIC LC_PAPER \
++ LC_TELEPHONE LC_TIME
++do
++ if (set +x; test -z "`(eval $as_var=C; export $as_var) 2>&1`"); then
++ eval $as_var=C; export $as_var
++ else
++ unset $as_var
++ fi
++done
++
+ # Initialize some other variables.
+ subdirs=
+ MFLAGS= MAKEFLAGS=
+@@ -452,16 +463,6 @@
+ esac
+ done
+
+-# NLS nuisances.
+-# Only set these to C if already set. These must not be set unconditionally
+-# because not all systems understand e.g. LANG=C (notably SCO).
+-# Fixing LC_MESSAGES prevents Solaris sh from translating var values in `set'!
+-# Non-C LC_CTYPE values break the ctype check.
+-if test "${LANG+set}" = set; then LANG=C; export LANG; fi
+-if test "${LC_ALL+set}" = set; then LC_ALL=C; export LC_ALL; fi
+-if test "${LC_MESSAGES+set}" = set; then LC_MESSAGES=C; export LC_MESSAGES; fi
+-if test "${LC_CTYPE+set}" = set; then LC_CTYPE=C; export LC_CTYPE; fi
+-
+ # confdefs.h avoids OS command line length limits that DEFS can exceed.
+ rm -rf conftest* confdefs.h
+ # AIX cpp loses on an empty file, so make sure it contains at least a newline.
diff --git a/sys-devel/gdb/gdb-6.4-r4.ebuild b/sys-devel/gdb/gdb-6.4-r4.ebuild
index 1c67ad721d29..c0020140da5c 100644
--- a/sys-devel/gdb/gdb-6.4-r4.ebuild
+++ b/sys-devel/gdb/gdb-6.4-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-6.4-r4.ebuild,v 1.2 2006/05/03 14:32:40 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-6.4-r4.ebuild,v 1.3 2006/06/10 19:39:55 vapier Exp $
inherit flag-o-matic eutils
@@ -57,6 +57,7 @@ src_unpack() {
epatch "${FILESDIR}"/gdb-6.2.1-libiberty-pic.patch
fi
+ epatch "${FILESDIR}"/gdb-configure-LANG.patch
strip-linguas -u bfd/po opcodes/po
}