summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-01 06:50:27 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-01 06:50:27 +0000
commit6e35a017716e4573b3cebc678cd72031d1e5b1dd (patch)
tree712867b145178251047557d80088143344f28683 /sys-devel/gettext
parentVersion bump. (diff)
downloadgentoo-2-6e35a017716e4573b3cebc678cd72031d1e5b1dd.tar.gz
gentoo-2-6e35a017716e4573b3cebc678cd72031d1e5b1dd.tar.bz2
gentoo-2-6e35a017716e4573b3cebc678cd72031d1e5b1dd.zip
Version bump.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-devel/gettext')
-rw-r--r--sys-devel/gettext/ChangeLog7
-rw-r--r--sys-devel/gettext/files/digest-gettext-0.14.51
-rw-r--r--sys-devel/gettext/gettext-0.14.5.ebuild124
3 files changed, 131 insertions, 1 deletions
diff --git a/sys-devel/gettext/ChangeLog b/sys-devel/gettext/ChangeLog
index b50180ba76e0..bd157ff08aba 100644
--- a/sys-devel/gettext/ChangeLog
+++ b/sys-devel/gettext/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gettext
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/ChangeLog,v 1.94 2005/06/30 03:55:15 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/ChangeLog,v 1.95 2005/09/01 06:50:27 vapier Exp $
+
+*gettext-0.14.5 (01 Sep 2005)
+
+ 01 Sep 2005; Mike Frysinger <vapier@gentoo.org> +gettext-0.14.5.ebuild:
+ Version bump.
29 Jun 2005; Joshua Kinard <kumba@gentoo.org> gettext-0.14.4.ebuild:
Marked stable on mips.
diff --git a/sys-devel/gettext/files/digest-gettext-0.14.5 b/sys-devel/gettext/files/digest-gettext-0.14.5
new file mode 100644
index 000000000000..457f67f7a9d9
--- /dev/null
+++ b/sys-devel/gettext/files/digest-gettext-0.14.5
@@ -0,0 +1 @@
+MD5 e2f6581626a22a0de66dce1d81d00de3 gettext-0.14.5.tar.gz 7105715
diff --git a/sys-devel/gettext/gettext-0.14.5.ebuild b/sys-devel/gettext/gettext-0.14.5.ebuild
new file mode 100644
index 000000000000..8ba18e62e521
--- /dev/null
+++ b/sys-devel/gettext/gettext-0.14.5.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.14.5.ebuild,v 1.1 2005/09/01 06:50:27 vapier Exp $
+
+inherit flag-o-matic eutils toolchain-funcs mono libtool elisp-common
+
+DESCRIPTION="GNU locale utilities"
+HOMEPAGE="http://www.gnu.org/software/gettext/gettext.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="emacs nls doc"
+
+DEPEND="|| ( sys-libs/glibc dev-libs/libiconv )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epunt_cxx
+
+ epatch "${FILESDIR}"/${PN}-0.14.1-lib-path-tests.patch #81628
+ # java sucks
+ epatch "${FILESDIR}"/${PN}-0.14.1-without_java.patch
+ epatch "${FILESDIR}"/${PN}-0.14.2-no-java-tests.patch
+ # Fix race, bug #85054
+ epatch "${FILESDIR}"/${PN}-0.14.2-fix-race.patch
+
+ # bundled libtool seems to be broken so skip certain rpath tests
+ # http://lists.gnu.org/archive/html/bug-libtool/2005-03/msg00070.html
+ sed -i \
+ -e '2iexit 77' \
+ autoconf-lib-link/tests/rpath-3*[ef] || die "sed tests"
+
+ # use Gentoo std docdir
+ sed -i \
+ -e "/^docdir=/s:=.*:=/usr/share/doc/${PF}:" \
+ gettext-runtime/configure \
+ gettext-tools/configure \
+ gettext-tools/examples/installpaths.in \
+ || die "sed docdir"
+
+ if use ppc-macos ; then
+ glibtoolize
+ append-flags -bind_at_load
+ fi
+}
+
+src_compile() {
+ local myconf=""
+ # Build with --without-included-gettext (on glibc systems)
+ if use elibc_glibc ; then
+ myconf="${myconf} --without-included-gettext $(use_enable nls)"
+ else
+ myconf="${myconf} --with-included-gettext --enable-nls"
+ fi
+ use emacs || export EMACS=no #93823
+ CXX=$(tc-getCC) \
+ econf \
+ --without-java \
+ ${myconf} \
+ || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "install failed"
+ use nls || rm -r "${D}"/usr/share/locale
+ dosym msgfmt /usr/bin/gmsgfmt #43435
+ dobin gettext-tools/misc/gettextize || die "gettextize"
+
+ # remove stuff that glibc handles
+ if use elibc_glibc ; then
+ rm -f "${D}"/usr/include/libintl.h
+ rm -f "${D}"/usr/$(get_libdir)/libintl.*
+ fi
+ rm -f "${D}"/usr/share/locale/locale.alias
+
+ # older gettext's sometimes installed libintl ...
+ # need to keep the linked version or the system
+ # could die (things like sed link against it :/)
+ if use ppc-macos; then
+ rm -f "${D}"/usr/lib/charset.alias
+ if [ -e "${ROOT}"/usr/$(get_libdir)/libintl.2.dylib ] ; then
+ cp -pPR ${ROOT}/usr/$(get_libdir)/libintl.2.dylib ${D}/usr/$(get_libdir)/
+ touch "${D}"/usr/$(get_libdir)/libintl.2.dylib
+ fi
+ else
+ if [ -e "${ROOT}"/usr/$(get_libdir)/libintl.so.2 ] ; then
+ cp -pPR ${ROOT}/usr/$(get_libdir)/libintl.so.2* ${D}/usr/$(get_libdir)/
+ touch "${D}"/usr/$(get_libdir)/libintl.so.2*
+ fi
+ fi
+
+ if ! use doc ; then
+ rm -r "${D}"/usr/share/doc/${PF}/html
+ rm -r "${D}"/usr/share/doc/${PF}/{csharpdoc,examples,javadoc2,javadoc1}
+ fi
+ dohtml "${D}"/usr/share/doc/${PF}/*.html
+ rm -f "${D}"/usr/share/doc/${PF}/*.html
+
+ # Remove emacs site-lisp stuff if 'emacs' is not in USE
+ if use emacs ; then
+ elisp-site-file-install "${FILESDIR}"/50po-mode-gentoo.el
+ else
+ rm -rf "${D}"/usr/share/emacs
+ fi
+
+ dodoc AUTHORS BUGS ChangeLog DISCLAIM NEWS README* THANKS TODO
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ ewarn "Any package that linked against the previous version"
+ ewarn "of gettext will have to be rebuilt."
+ ewarn "Please 'emerge gentoolkit' and run:"
+ ewarn "revdep-rebuild --soname libintl.so.2"
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}