summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuele Giaquinta <exg@gentoo.org>2006-10-09 17:50:05 +0000
committerEmanuele Giaquinta <exg@gentoo.org>2006-10-09 17:50:05 +0000
commitf0b445243496ff387b8f50caf9dacbfe687120f4 (patch)
tree1e4f54fa2aa2b2f18a36893b5c68911e43765614 /sys-devel/gettext
parentRemoved mplayer-bin patch for amd64 for version 0.9.3 (see bug #148419 for de... (diff)
downloadgentoo-2-f0b445243496ff387b8f50caf9dacbfe687120f4.tar.gz
gentoo-2-f0b445243496ff387b8f50caf9dacbfe687120f4.tar.bz2
gentoo-2-f0b445243496ff387b8f50caf9dacbfe687120f4.zip
Add support for expat-2 to xgettext by linking it at build time rather than
at runtime using dlopen, bug #146211. (Portage version: 2.1.2_pre2-r7)
Diffstat (limited to 'sys-devel/gettext')
-rw-r--r--sys-devel/gettext/ChangeLog9
-rw-r--r--sys-devel/gettext/files/digest-gettext-0.15-r13
-rw-r--r--sys-devel/gettext/files/gettext-0.15-expat-no-dlopen.patch31
-rw-r--r--sys-devel/gettext/gettext-0.15-r1.ebuild131
4 files changed, 173 insertions, 1 deletions
diff --git a/sys-devel/gettext/ChangeLog b/sys-devel/gettext/ChangeLog
index ceee853516da..06ad9248282a 100644
--- a/sys-devel/gettext/ChangeLog
+++ b/sys-devel/gettext/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/gettext
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/ChangeLog,v 1.127 2006/09/30 17:40:17 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/ChangeLog,v 1.128 2006/10/09 17:50:05 exg Exp $
+
+*gettext-0.15-r1 (09 Oct 2006)
+
+ 09 Oct 2006; Emanuele Giaquinta <exg@gentoo.org>
+ +files/gettext-0.15-expat-no-dlopen.patch, +gettext-0.15-r1.ebuild:
+ Add support for expat-2 to xgettext by linking it at build time rather than
+ at runtime using dlopen, bug #146211.
30 Sep 2006; Fabian Groffen <grobian@gentoo.org> gettext-0.15.ebuild:
Backport fix from prefix. On Darwin don't do library moving, it breaks the
diff --git a/sys-devel/gettext/files/digest-gettext-0.15-r1 b/sys-devel/gettext/files/digest-gettext-0.15-r1
new file mode 100644
index 000000000000..ab028c6c56a0
--- /dev/null
+++ b/sys-devel/gettext/files/digest-gettext-0.15-r1
@@ -0,0 +1,3 @@
+MD5 16bc6e4d37ac3d07495f737a2349a22b gettext-0.15.tar.gz 8081941
+RMD160 e485b60965cf74808801e674c570c7ccd63bd61e gettext-0.15.tar.gz 8081941
+SHA256 178100e9375df74e6569e8ac89790b713476204e27283287e2637d07a5760e08 gettext-0.15.tar.gz 8081941
diff --git a/sys-devel/gettext/files/gettext-0.15-expat-no-dlopen.patch b/sys-devel/gettext/files/gettext-0.15-expat-no-dlopen.patch
new file mode 100644
index 000000000000..d2088978eca5
--- /dev/null
+++ b/sys-devel/gettext/files/gettext-0.15-expat-no-dlopen.patch
@@ -0,0 +1,31 @@
+--- gettext-0.15/gettext-tools/configure.orig 2006-07-21 15:38:28.000000000 +0200
++++ gettext-0.15/gettext-tools/configure 2006-10-07 01:19:15.295758370 +0200
+@@ -44267,19 +44266,6 @@
+
+
+
+-case "$host_os" in
+- linux*)
+-
+-cat >>confdefs.h <<\_ACEOF
+-#define DYNLOAD_LIBEXPAT 1
+-_ACEOF
+-
+- LIBEXPAT="-ldl"
+- LTLIBEXPAT="-ldl"
+-
+-
+- ;;
+- *)
+
+
+
+@@ -44786,8 +44772,6 @@
+
+
+
+- ;;
+-esac
+
+ # If set to t, that means we are running in a shell under Emacs.
+ # If you have an Emacs named "t", then use the full path.
diff --git a/sys-devel/gettext/gettext-0.15-r1.ebuild b/sys-devel/gettext/gettext-0.15-r1.ebuild
new file mode 100644
index 000000000000..582454607e75
--- /dev/null
+++ b/sys-devel/gettext/gettext-0.15-r1.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.15-r1.ebuild,v 1.1 2006/10/09 17:50:05 exg Exp $
+
+inherit flag-o-matic eutils multilib toolchain-funcs mono libtool elisp-common
+
+DESCRIPTION="GNU locale utilities"
+HOMEPAGE="http://www.gnu.org/software/gettext/gettext.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="emacs nls doc nocxx"
+
+DEPEND="virtual/libiconv
+ dev-libs/expat"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epunt_cxx
+
+ epatch "${FILESDIR}"/${PN}-0.14.1-lib-path-tests.patch #81628
+ # Fix race, bug #85054
+ epatch "${FILESDIR}"/${PN}-0.14.2-fix-race.patch
+ epatch "${FILESDIR}"/${P}-expat-no-dlopen.patch
+
+ # bundled libtool seems to be broken so skip certain rpath tests
+ # http://lists.gnu.org/archive/html/bug-libtool/2005-03/msg00070.html
+ sed -i \
+ -e '2iexit 77' \
+ autoconf-lib-link/tests/rpath-3*[ef] || die "sed tests"
+
+ # use Gentoo std docdir
+ sed -i \
+ -e "/^docdir=/s:=.*:=/usr/share/doc/${PF}:" \
+ gettext-runtime/configure \
+ gettext-tools/configure \
+ gettext-tools/examples/installpaths.in \
+ || die "sed docdir"
+
+ # sanity check for Bug 105304
+ if [[ -z ${USERLAND} ]] ; then
+ eerror "You just hit Bug 105304, please post your 'emerge info' here:"
+ eerror "http://bugs.gentoo.org/105304"
+ die "Aborting to prevent screwing your system"
+ fi
+}
+
+src_compile() {
+ local myconf=""
+ # Build with --without-included-gettext (on glibc systems)
+ if use elibc_glibc ; then
+ myconf="${myconf} --without-included-gettext $(use_enable nls)"
+ else
+ myconf="${myconf} --with-included-gettext --enable-nls"
+ fi
+ use nocxx && export CXX=$(tc-getCC)
+ econf \
+ $(use_with emacs) \
+ --disable-java \
+ ${myconf} \
+ || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "install failed"
+ use nls || rm -r "${D}"/usr/share/locale
+ dosym msgfmt /usr/bin/gmsgfmt #43435
+ dobin gettext-tools/misc/gettextize || die "gettextize"
+
+ # remove stuff that glibc handles
+ if use elibc_glibc ; then
+ rm -f "${D}"/usr/include/libintl.h
+ rm -f "${D}"/usr/$(get_libdir)/libintl.*
+ fi
+ rm -f "${D}"/usr/share/locale/locale.alias "${D}"/usr/lib/charset.alias
+
+ # older gettext's sometimes installed libintl ...
+ # need to keep the linked version or the system
+ # could die (things like sed link against it :/)
+ local libname="libintl$(get_libname 7)"
+ if [[ -e ${ROOT}/usr/$(get_libdir)/${libname} ]] ; then
+ cp -pPR ${ROOT}/usr/$(get_libdir)/${libname}* "${D}"/usr/$(get_libdir)/
+ touch "${D}"/usr/$(get_libdir)/${libname}*
+ fi
+ if [[ -e ${ROOT}/$(get_libdir)/${libname} ]] ; then
+ dodir /$(get_libdir)
+ cp -pPR ${ROOT}/$(get_libdir)/${libname}* "${D}"/$(get_libdir)/
+ touch "${D}"/$(get_libdir)/${libname}*
+ fi
+
+ if [[ $USERLAND == "BSD" ]] ; then
+ libname="libintl$(get_libname 8)"
+ # Move dynamic libs and creates ldscripts into /usr/lib
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/${libname}* "${D}"/$(get_libdir)/
+ gen_usr_ldscript ${libname}
+ fi
+
+ if ! use doc ; then
+ rm -rf "${D}"/usr/share/doc/${PF}/html
+ rm -rf "${D}"/usr/share/doc/${PF}/{csharpdoc,examples,javadoc2,javadoc1}
+ fi
+ dohtml "${D}"/usr/share/doc/${PF}/*.html
+ rm -f "${D}"/usr/share/doc/${PF}/*.html
+
+ # Remove emacs site-lisp stuff if 'emacs' is not in USE
+ if use emacs ; then
+ elisp-site-file-install "${FILESDIR}"/50po-mode-gentoo.el
+ else
+ rm -rf "${D}"/usr/share/emacs
+ fi
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ ewarn "Any package that linked against the previous version"
+ ewarn "of gettext will have to be rebuilt."
+ ewarn "Please 'emerge gentoolkit' and run:"
+ ewarn "revdep-rebuild --library libintl.so.7"
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}