summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-09-11 12:30:59 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-09-11 12:30:59 +0000
commit44e3d8c98e3a30136abaa4b06113e0badbb3f83e (patch)
tree593bd64a487d9a68cc7ee7d0834be1eb9c841299 /sys-devel/icecream/files
parentWith USE=-emacs, don't byte-compile emacs lisp files. Fixes bug 336708. (diff)
downloadgentoo-2-44e3d8c98e3a30136abaa4b06113e0badbb3f83e.tar.gz
gentoo-2-44e3d8c98e3a30136abaa4b06113e0badbb3f83e.tar.bz2
gentoo-2-44e3d8c98e3a30136abaa4b06113e0badbb3f83e.zip
Drop all old releases. Cleanup ebuild. Remove only stable version. Open stablereq if you use it in stable environment and trust it is working reliably.
(Portage version: 2.2_rc79/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/icecream/files')
-rw-r--r--sys-devel/icecream/files/0.9.6-symlinks.patch19
-rw-r--r--sys-devel/icecream/files/icecream7
-rw-r--r--sys-devel/icecream/files/icecream-config4
-rw-r--r--sys-devel/icecream/files/icecream-create-env4
-rw-r--r--sys-devel/icecream/files/icecream-dont-create-symlinks.patch14
5 files changed, 27 insertions, 21 deletions
diff --git a/sys-devel/icecream/files/0.9.6-symlinks.patch b/sys-devel/icecream/files/0.9.6-symlinks.patch
new file mode 100644
index 000000000000..279ee0cc0f99
--- /dev/null
+++ b/sys-devel/icecream/files/0.9.6-symlinks.patch
@@ -0,0 +1,19 @@
+diff -urN icecc-0.9.6//client/Makefile.am icecc-0.9.6.new//client/Makefile.am
+--- icecc-0.9.6//client/Makefile.am 2010-09-11 13:43:53.922000148 +0200
++++ icecc-0.9.6.new//client/Makefile.am 2010-09-11 13:44:39.950000148 +0200
+@@ -7,15 +7,3 @@
+ noinst_HEADERS = client.h md5.h util.h
+
+ EXTRA_DIST = icecc-create-env
+-
+-install-exec-local:
+- $(mkinstalldirs) $(DESTDIR)$(bindir)
+- for link in g++ gcc c++ cc icerun; do \
+- rm -f $(DESTDIR)$(bindir)/$$link ;\
+- $(LN_S) icecc $(DESTDIR)$(bindir)/$$link ;\
+- done
+-
+-uninstall-local:
+- for link in g++ gcc c++ cc; do \
+- rm $(DESTDIR)$(bindir)/$$link ;\
+- done
diff --git a/sys-devel/icecream/files/icecream b/sys-devel/icecream/files/icecream
index cae25eb28a4f..b3f5d791a686 100644
--- a/sys-devel/icecream/files/icecream
+++ b/sys-devel/icecream/files/icecream
@@ -1,13 +1,13 @@
#!/sbin/runscript
-
-#NB: Config is in /etc/conf.d/icecream
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/icecream/files/icecream,v 1.3 2010/09/11 12:30:59 scarabeus Exp $
depend() {
need net
}
start() {
-
local basedir=${ICECREAM_BASEDIR:-"/var/cache/icecream"}
local netname=${ICECREAM_NETNAME:+"-n ${ICECREAM_NETNAME}"}
local logfile=${ICECREAM_LOG_FILE:+"-l ${ICECREAM_LOG_FILE}"}
@@ -35,6 +35,7 @@ stop() {
ebegin "Stopping Distributed Compiler Daemon"
start-stop-daemon --stop --quiet --name iceccd
eend ${?}
+
if [[ "${ICECREAM_RUN_SCHEDULER}" == "yes" ]]; then
ebegin "Stopping Distributed Compiler Scheduler"
start-stop-daemon --stop --quiet --name scheduler
diff --git a/sys-devel/icecream/files/icecream-config b/sys-devel/icecream/files/icecream-config
index d520072090f0..6ed24c743772 100644
--- a/sys-devel/icecream/files/icecream-config
+++ b/sys-devel/icecream/files/icecream-config
@@ -1,8 +1,8 @@
-#!/bin/bash
+#!/bin/sh
#
# icecream-config - helper script for icecream and its ebuild
#
-# Copyright 2003 Superlucidity Services, LLC
+# Copyright 2003-2010 Superlucidity Services, LLC
# This program licensed under the GNU GPL version 2.
#
# This script developed by Zachary T Welch at Superlucidity Services, LLC
diff --git a/sys-devel/icecream/files/icecream-create-env b/sys-devel/icecream/files/icecream-create-env
index 92b08364d908..632bdc5bd2dd 100644
--- a/sys-devel/icecream/files/icecream-create-env
+++ b/sys-devel/icecream/files/icecream-create-env
@@ -1,8 +1,8 @@
-#!/bin/bash
+#!/bin/sh
#
# icecream-create-env - helper script to create icecc environments(mostly for cross-compiling)
#
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
#
# Please note, this script has been designed to work with Gentoo's crossdev, it may or may
diff --git a/sys-devel/icecream/files/icecream-dont-create-symlinks.patch b/sys-devel/icecream/files/icecream-dont-create-symlinks.patch
deleted file mode 100644
index 5f9daa5f7e18..000000000000
--- a/sys-devel/icecream/files/icecream-dont-create-symlinks.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -urN icecream.orig/client/Makefile.am icecream/client/Makefile.am
---- icecream.orig/client/Makefile.am
-+++ icecream/client/Makefile.am
-@@ -17,10 +17,6 @@
-
- install-exec-local:
- $(mkinstalldirs) $(DESTDIR)$(bindir)
-- for link in g++ gcc c++ cc; do \
-- rm -f $(DESTDIR)$(bindir)/$$link ;\
-- $(LN_S) icecc $(DESTDIR)$(bindir)/$$link ;\
-- done
-
- uninstall-local:
- for link in g++ gcc c++ cc; do \