summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-11-01 01:42:59 +0000
committerMike Frysinger <vapier@gentoo.org>2014-11-01 01:42:59 +0000
commit5f81f7715824e9863f821cbd365dc200d93db820 (patch)
tree97b9e77d9fce3ff45a3e6890383bcfa3c1425646 /sys-devel/libtool/libtool-2.4.3-r1.ebuild
parentRun tests in parallel (diff)
downloadgentoo-2-5f81f7715824e9863f821cbd365dc200d93db820.tar.gz
gentoo-2-5f81f7715824e9863f821cbd365dc200d93db820.tar.bz2
gentoo-2-5f81f7715824e9863f821cbd365dc200d93db820.zip
Respect EPREFIX during install.
Diffstat (limited to 'sys-devel/libtool/libtool-2.4.3-r1.ebuild')
-rw-r--r--sys-devel/libtool/libtool-2.4.3-r1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sys-devel/libtool/libtool-2.4.3-r1.ebuild b/sys-devel/libtool/libtool-2.4.3-r1.ebuild
index a5e768051aa8..ca337e748b3d 100644
--- a/sys-devel/libtool/libtool-2.4.3-r1.ebuild
+++ b/sys-devel/libtool/libtool-2.4.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-2.4.3-r1.ebuild,v 1.2 2014/11/01 01:41:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-2.4.3-r1.ebuild,v 1.3 2014/11/01 01:42:59 vapier Exp $
EAPI="4"
@@ -78,16 +78,16 @@ multilib_src_install_all() {
# While the libltdl.la file is not used directly, the m4 ltdl logic
# keys off of its existence when searching for ltdl support. #293921
- #use static-libs || find "${D}" -name libltdl.la -delete
+ #use static-libs || find "${ED}" -name libltdl.la -delete
# Building libtool with --disable-static will cause the installed
# helper to not build static objects by default. This is undesirable
# for crappy packages that utilize the system libtool, so undo that.
- sed -i -e '1,/^build_old_libs=/{/^build_old_libs=/{s:=.*:=yes:}}' "${D}"/usr/bin/libtool || die
+ sed -i -e '1,/^build_old_libs=/{/^build_old_libs=/{s:=.*:=yes:}}' "${ED}"/usr/bin/libtool || die
local x
- for x in $(find "${D}" -name config.guess -o -name config.sub) ; do
- ln -sf /usr/share/gnuconfig/${x##*/} "${x}" || die
+ for x in $(find "${ED}" -name config.guess -o -name config.sub) ; do
+ ln -sf "${EPREFIX}"/usr/share/gnuconfig/${x##*/} "${x}" || die
done
}