summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-09-21 08:27:37 +0000
committerMike Frysinger <vapier@gentoo.org>2008-09-21 08:27:37 +0000
commited03af82d0aaa3cff1874fddc12d6e0abdb2e514 (patch)
tree55d657b7b3abb574a857017caf0a2b9ffc604d19 /sys-devel/libtool
parentVersion bump #236197. (diff)
downloadgentoo-2-ed03af82d0aaa3cff1874fddc12d6e0abdb2e514.tar.gz
gentoo-2-ed03af82d0aaa3cff1874fddc12d6e0abdb2e514.tar.bz2
gentoo-2-ed03af82d0aaa3cff1874fddc12d6e0abdb2e514.zip
Version bump #237168 by Conrad Kostecki.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.2 x86_64)
Diffstat (limited to 'sys-devel/libtool')
-rw-r--r--sys-devel/libtool/ChangeLog7
-rw-r--r--sys-devel/libtool/libtool-2.2.6a.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/sys-devel/libtool/ChangeLog b/sys-devel/libtool/ChangeLog
index 9780000fda80..1c962f1772e0 100644
--- a/sys-devel/libtool/ChangeLog
+++ b/sys-devel/libtool/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/libtool
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/ChangeLog,v 1.138 2008/06/10 04:34:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/ChangeLog,v 1.139 2008/09/21 08:27:37 vapier Exp $
+
+*libtool-2.2.6a (21 Sep 2008)
+
+ 21 Sep 2008; Mike Frysinger <vapier@gentoo.org> +libtool-2.2.6a.ebuild:
+ Version bump #237168 by Conrad Kostecki.
10 Jun 2008; Mike Frysinger <vapier@gentoo.org> libtool-2.2.4.ebuild:
Do not run libtoolize when rebuilding other autotools #225559.
diff --git a/sys-devel/libtool/libtool-2.2.6a.ebuild b/sys-devel/libtool/libtool-2.2.6a.ebuild
new file mode 100644
index 000000000000..5e6a54015059
--- /dev/null
+++ b/sys-devel/libtool/libtool-2.2.6a.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-2.2.6a.ebuild,v 1.1 2008/09/21 08:27:37 vapier Exp $
+
+LIBTOOLIZE="true" #225559
+inherit eutils autotools
+
+DESCRIPTION="A shared library tool for developers"
+HOMEPAGE="http://www.gnu.org/software/libtool/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.lzma"
+
+LICENSE="GPL-2"
+SLOT="1.5"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="vanilla"
+
+RDEPEND="sys-devel/gnuconfig
+ >=sys-devel/autoconf-2.60
+ >=sys-devel/automake-1.10"
+DEPEND="${RDEPEND}
+ app-arch/lzma-utils
+ sys-apps/help2man"
+
+S=${WORKDIR}/${P%a}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if ! use vanilla ; then
+ epunt_cxx
+ cd libltdl/m4
+ epatch "${FILESDIR}"/1.5.20/${PN}-1.5.20-use-linux-version-in-fbsd.patch #109105
+ cd ..
+ eautoreconf
+ cd ..
+ eautoreconf
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog* NEWS README THANKS TODO doc/PLATFORMS
+
+ local x
+ for x in libtool libtoolize ; do
+ help2man ${x} > ${x}.1
+ doman ${x}.1 || die
+ done
+
+ for x in $(find "${D}" -name config.guess -o -name config.sub) ; do
+ rm -f "${x}" ; ln -sf /usr/share/gnuconfig/${x##*/} "${x}"
+ done
+}