summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-10-25 20:20:12 +0000
committerMike Frysinger <vapier@gentoo.org>2008-10-25 20:20:12 +0000
commit73252d14a3d03b0ef32f2dabd6962ce0787b8d69 (patch)
tree147a740a04581b7d921b3f46849abbfbdc64853d /sys-devel/m4/m4-1.4.12.ebuild
parentFix CC for bug #243648, fix unquoted variable and remove old (diff)
downloadgentoo-2-73252d14a3d03b0ef32f2dabd6962ce0787b8d69.tar.gz
gentoo-2-73252d14a3d03b0ef32f2dabd6962ce0787b8d69.tar.bz2
gentoo-2-73252d14a3d03b0ef32f2dabd6962ce0787b8d69.zip
Version bump.
(Portage version: 2.2_rc12/cvs/Linux 2.6.26.2 x86_64)
Diffstat (limited to 'sys-devel/m4/m4-1.4.12.ebuild')
-rw-r--r--sys-devel/m4/m4-1.4.12.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-devel/m4/m4-1.4.12.ebuild b/sys-devel/m4/m4-1.4.12.ebuild
new file mode 100644
index 000000000000..f2c91d09e9e5
--- /dev/null
+++ b/sys-devel/m4/m4-1.4.12.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/m4-1.4.12.ebuild,v 1.1 2008/10/25 20:20:12 vapier Exp $
+
+DESCRIPTION="GNU macro processor"
+HOMEPAGE="http://www.gnu.org/software/m4/m4.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.lzma"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="examples nls"
+
+# remember: cannot dep on autoconf since it needs us
+DEPEND="nls? ( sys-devel/gettext )
+ app-arch/lzma-utils"
+RDEPEND=""
+
+src_compile() {
+ local myconf=""
+ [[ ${USERLAND} != "GNU" ]] && myconf="--program-prefix=g"
+ econf \
+ $(use_enable nls) \
+ --enable-changeword \
+ ${myconf} \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc BACKLOG ChangeLog NEWS README* THANKS TODO
+ if use examples ; then
+ docinto examples
+ dodoc examples/*
+ rm -f "${D}"/usr/share/doc/${PF}/examples/Makefile*
+ fi
+ rm -f "${D}"/usr/lib/charset.alias #172864
+}