summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-28 05:17:11 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-28 05:17:11 +0000
commit03df47610a71499d47040f42ccb5e37b543a62d6 (patch)
treec338446fc172c71c98e37ee6610956e52dff3b61 /sys-devel/make
parentgcc 3.4 fix (Manifest recommit) (diff)
downloadgentoo-2-03df47610a71499d47040f42ccb5e37b543a62d6.tar.gz
gentoo-2-03df47610a71499d47040f42ccb5e37b543a62d6.tar.bz2
gentoo-2-03df47610a71499d47040f42ccb5e37b543a62d6.zip
arm KEYWORDS
Diffstat (limited to 'sys-devel/make')
-rw-r--r--sys-devel/make/make-3.80.ebuild25
1 files changed, 12 insertions, 13 deletions
diff --git a/sys-devel/make/make-3.80.ebuild b/sys-devel/make/make-3.80.ebuild
index 5c845bc5cc4a..08288276da54 100644
--- a/sys-devel/make/make-3.80.ebuild
+++ b/sys-devel/make/make-3.80.ebuild
@@ -1,38 +1,37 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/make/make-3.80.ebuild,v 1.15 2004/03/22 03:20:08 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/make/make-3.80.ebuild,v 1.16 2004/04/28 05:17:11 vapier Exp $
inherit gnuconfig
-IUSE="nls static build"
-
-S=${WORKDIR}/${P}
DESCRIPTION="Standard tool to compile source trees"
-SRC_URI="ftp://ftp.gnu.org/gnu/make/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/make/make.html"
+SRC_URI="ftp://ftp.gnu.org/gnu/make/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 x86 ppc sparc alpha hppa mips ia64 ppc64 s390"
+KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 ppc64 s390"
+IUSE="nls static build"
-DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )"
RDEPEND="virtual/glibc"
src_compile() {
-
# Detect mips systems properly
use mips && gnuconfig_update
local myconf=""
use nls || myconf="--disable-nls"
- ./configure --prefix=/usr \
+ ./configure \
+ --prefix=/usr \
--mandir=/usr/share/man \
--info=/usr/share/info \
--host=${CHOST} \
${myconf} || die
- if [ -z "`use static`" ]
+ if ! use static
then
make ${MAKEOPTS} || die
else
@@ -41,15 +40,15 @@ src_compile() {
}
src_install() {
- if [ -z "`use build`" ]
+ if ! use build
then
make DESTDIR=${D} install || die
fperms 0755 /usr/bin/make
dosym make /usr/bin/gmake
- dodoc AUTHORS COPYING ChangeLog NEWS README*
+ dodoc AUTHORS ChangeLog NEWS README*
else
- dobin make
+ dobin make || die
fi
}