summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-24 05:11:20 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-24 05:11:20 +0000
commit716f0d0d75b83d6a2fa4b1911544e714b8a6bd65 (patch)
treef44ea32797c5e73332f73bb10c42e65c1e0ffc8d /sys-devel/patch/patch-2.5.9.ebuild
parentFix use invocation and regenerate broken manifest (Manifest recommit) (diff)
downloadgentoo-2-716f0d0d75b83d6a2fa4b1911544e714b8a6bd65.tar.gz
gentoo-2-716f0d0d75b83d6a2fa4b1911544e714b8a6bd65.tar.bz2
gentoo-2-716f0d0d75b83d6a2fa4b1911544e714b8a6bd65.zip
QA - fix use invocation. This also fixes an ebuild error due in part to the less readable use syntax. It was written [ "is-ldflags -pie" ] when it should have been [ "`is-ldflags -pie`" ]. The way it was written would have always evaluated to true.
Diffstat (limited to 'sys-devel/patch/patch-2.5.9.ebuild')
-rw-r--r--sys-devel/patch/patch-2.5.9.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-devel/patch/patch-2.5.9.ebuild b/sys-devel/patch/patch-2.5.9.ebuild
index 729c6c129406..5170174748ca 100644
--- a/sys-devel/patch/patch-2.5.9.ebuild
+++ b/sys-devel/patch/patch-2.5.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.5.9.ebuild,v 1.17 2004/06/22 17:08:34 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.5.9.ebuild,v 1.18 2004/06/24 05:11:20 agriffis Exp $
inherit flag-o-matic
@@ -21,7 +21,7 @@ src_compile() {
strip-flags
CFLAGS="$CFLAGS -DLINUX -D_XOPEN_SOURCE=500"
# workaround for hardened on amd64, 1st part
- if [ "`use amd64`" ] && [ "is-ldflags -pie" ]; then
+ if use amd64 && is-ldflags -pie; then
einfo Stripping "-pie" from LDFLAGS, adding it to Makefile manually
filter-ldflags -pie
append-flags -fPIC