summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-08-24 04:45:53 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-08-24 04:45:53 +0000
commit018b560a551469b325df119e17cb31e3a9f28a68 (patch)
tree6e2a11246cda7acf00bde907f210b9e38a837c39 /sys-devel/spython
parentremoved supervise support and added runscript support (diff)
downloadgentoo-2-018b560a551469b325df119e17cb31e3a9f28a68.tar.gz
gentoo-2-018b560a551469b325df119e17cb31e3a9f28a68.tar.bz2
gentoo-2-018b560a551469b325df119e17cb31e3a9f28a68.zip
python, portage fixes
Diffstat (limited to 'sys-devel/spython')
-rw-r--r--sys-devel/spython/spython-2.0-r4.ebuild91
-rw-r--r--sys-devel/spython/spython-2.0-r5.ebuild84
-rw-r--r--sys-devel/spython/spython-2.0-r6.ebuild93
-rw-r--r--sys-devel/spython/spython-2.0-r7.ebuild4
4 files changed, 2 insertions, 270 deletions
diff --git a/sys-devel/spython/spython-2.0-r4.ebuild b/sys-devel/spython/spython-2.0-r4.ebuild
deleted file mode 100644
index ee09fa17c991..000000000000
--- a/sys-devel/spython/spython-2.0-r4.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/spython-2.0-r4.ebuild,v 1.5 2001/04/28 08:24:12 achim Exp $
-
-S=${WORKDIR}/Python-2.0
-S2=${WORKDIR}/python-fchksum-1.1
-DESCRIPTION="A really great language -- minimalist python environment"
-SRC_URI="http://www.python.org/ftp/python/src/BeOpen-Python-2.0.tar.bz2
- http://www.azstarnet.com/~donut/programs/fchksum/python-fchksum-1.1.tar.gz"
-
-HOMEPAGE="http://www.python.org http://www.azstarnet.com/~donut/programs/fchksum/"
-
-DEPEND=">=sys-libs/zlib-1.1.3 readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )"
-
-RDEPEND="virtual/glibc"
-PROVIDE="virtual/python"
-
-src_unpack() {
-
- unpack BeOpen-Python-2.0.tar.bz2
-
- cd ${S}/Modules
-
- cp ${FILESDIR}/pfconfig.h .
- unpack python-fchksum-1.1.tar.gz
-
- echo '*static*' >> Setup.local
-
- echo "zlib zlibmodule.c -lz" >> Setup.local
- if [ "`use readline`" ]
- then
- echo "readline readline.c -lreadline -lncurses" >> Setup.local
- fi
-
- echo "fchksum fchksum.c md5_2.c" >> Setup.local
-
- cd python-fchksum-1.1
- mv md5.h ../md5_2.h
- sed -e 's:"md5.h":"md5_2.h":' md5.c > ../md5_2.c
- sed -e 's:"md5.h":"md5_2.h":' fchksum.c > ../fchksum.c
-
- #for some reason, python 2.0 can't find /usr/lib/python2.0 without this fix to the source code.
- cd ${S}/Python
- cp pythonrun.c pythonrun.c.orig
- sed -e 's:static char \*default_home = NULL:static char \*default_home = "/usr":' pythonrun.c.orig > pythonrun.c
-
-}
-
-src_compile() {
-
- export LDFLAGS=-static
-
- try ./configure --prefix=/usr --without-libdb
-
- #libdb3 support is available from http://pybsddb.sourceforge.net/; the one
- #included with python is for db 1.85 only.
-
- cp Makefile Makefile.orig
- sed -e "s/-g -O2/${CFLAGS}/" Makefile.orig > Makefile
- cd ${S}/Modules
- cp Makefile.pre Makefile.orig
- sed -e "s:MODOBJS=:MODOBJS=fchksum.o md5_2.o:" \
- Makefile.orig > Makefile.pre
-
- # Parallel make does not work
- cd ${S}
- try make
-
-}
-
-src_install() {
-
- dodir /usr/share/man
- try make install prefix=${D}/usr MANDIR=${D}/usr/share/man
- rm ${D}/usr/bin/python
- mv ${D}/usr/bin/python2.0 ${D}/usr/bin/spython
-
- if [ "`use build`" ]
- then
- rm -rf ${D}/usr/share/man
- fi
-}
-
-pkg_postinst() {
-
- if [ ! -e "${ROOT}/usr/bin/python" ]
- then
- ln -s spython ${ROOT}/usr/bin/python
- fi
-}
diff --git a/sys-devel/spython/spython-2.0-r5.ebuild b/sys-devel/spython/spython-2.0-r5.ebuild
deleted file mode 100644
index a6766fc94fa2..000000000000
--- a/sys-devel/spython/spython-2.0-r5.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/spython-2.0-r5.ebuild,v 1.1 2001/07/12 03:08:24 pete Exp $
-
-S=${WORKDIR}/Python-2.0
-S2=${WORKDIR}/python-fchksum-1.1
-DESCRIPTION="A really great language -- minimalist python environment"
-SRC_URI="http://www.python.org/ftp/python/src/BeOpen-Python-2.0.tar.bz2
- http://www.azstarnet.com/~donut/programs/fchksum/python-fchksum-1.1.tar.gz"
-
-HOMEPAGE="http://www.python.org http://www.azstarnet.com/~donut/programs/fchksum/"
-
-DEPEND=">=sys-devel/autoconf-2.13
- >=sys-libs/zlib-1.1.3
- readline? ( >=sys-libs/readline-4.1
- >=sys-libs/ncurses-5.2 )"
-
-RDEPEND="virtual/glibc"
-PROVIDE="virtual/python"
-
-src_unpack() {
-
- unpack BeOpen-Python-2.0.tar.bz2
- cd ${S}
- patch -p1 < ${FILESDIR}/${PF}-gentoo.diff
- autoconf
-
- cd ${S}/Modules
-
- cp -a ${FILESDIR}/pfconfig.h .
- unpack python-fchksum-1.1.tar.gz
-
- echo '*static*' >> Setup.local
-
- echo "zlib zlibmodule.c -lz" >> Setup.local
- if [ "`use readline`" ]
- then
- echo "readline readline.c -lreadline -lncurses" >> Setup.local
- fi
-
- echo "fchksum fchksum.c md5_2.c" >> Setup.local
-
- cd python-fchksum-1.1
- cp -a md5.h ../md5_2.h
- sed -e 's:"md5.h":"md5_2.h":' md5.c > ../md5_2.c
- sed -e 's:"md5.h":"md5_2.h":' fchksum.c > ../fchksum.c
-
-}
-
-src_compile() {
-
- export LDFLAGS=-static
-
- try ./configure --prefix=/usr --without-libdb
-
- #libdb3 support is available from http://pybsddb.sourceforge.net/; the one
- #included with python is for db 1.85 only.
-
- cp Makefile Makefile.orig
- sed -e "s/-g -O2/${CFLAGS}/" Makefile.orig > Makefile
- cd ${S}/Modules
- cp Makefile.pre Makefile.orig
- sed -e "s:MODOBJS=:MODOBJS=fchksum.o md5_2.o:" \
- Makefile.orig > Makefile.pre
-
- # Parallel make does not work
- cd ${S}
- try make
-
-}
-
-src_install() {
-
- dodir /usr/share/man
- try make install prefix=${D}/usr MANDIR=${D}/usr/share/man
-
- rm -rf ${D}/usr/include
- rm -rf ${D}/usr/lib/${PN}${PV}/config
- if [ "`use build`" ]
- then
- rm -rf ${D}/usr/share
- fi
-}
diff --git a/sys-devel/spython/spython-2.0-r6.ebuild b/sys-devel/spython/spython-2.0-r6.ebuild
deleted file mode 100644
index 6656acefcd27..000000000000
--- a/sys-devel/spython/spython-2.0-r6.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/spython-2.0-r6.ebuild,v 1.1 2001/08/04 18:22:45 pete Exp $
-
-S=${WORKDIR}/Python-2.0
-S2=${WORKDIR}/python-fchksum-1.1
-DESCRIPTION="A really great language -- minimalist python environment"
-SRC_URI="http://www.python.org/ftp/python/src/BeOpen-Python-2.0.tar.bz2
- http://www.azstarnet.com/~donut/programs/fchksum/python-fchksum-1.1.tar.gz"
-
-HOMEPAGE="http://www.python.org http://www.azstarnet.com/~donut/programs/fchksum/"
-
-DEPEND=">=sys-libs/zlib-1.1.3 readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )"
-
-RDEPEND="virtual/glibc"
-PROVIDE="virtual/python"
-
-src_unpack() {
-
- unpack BeOpen-Python-2.0.tar.bz2
-
- cd ${S}/Modules
-
- cp ${FILESDIR}/pfconfig.h .
- unpack python-fchksum-1.1.tar.gz
-
- echo '*static*' >> Setup.local
-
- echo "zlib zlibmodule.c -lz" >> Setup.local
- if [ "`use readline`" ]
- then
- echo "readline readline.c -lreadline -lncurses" >> Setup.local
- fi
-
- echo "fchksum fchksum.c md5_2.c" >> Setup.local
-
- cd python-fchksum-1.1
- mv md5.h ../md5_2.h
- sed -e 's:"md5.h":"md5_2.h":' md5.c > ../md5_2.c
- sed -e 's:"md5.h":"md5_2.h":' fchksum.c > ../fchksum.c
-
- #for some reason, python 2.0 can't find /usr/lib/python2.0 without this fix to the source code.
- cd ${S}/Python
- cp pythonrun.c pythonrun.c.orig
- sed -e 's:static char \*default_home = NULL:static char \*default_home = "/usr":' pythonrun.c.orig > pythonrun.c
-
-}
-
-src_compile() {
-
- export LDFLAGS=-static
-
- try ./configure --prefix=/usr --without-libdb
-
- #libdb3 support is available from http://pybsddb.sourceforge.net/; the one
- #included with python is for db 1.85 only.
-
- cp Makefile Makefile.orig
- sed -e "s/-g -O2/${CFLAGS}/" Makefile.orig > Makefile
- cd ${S}/Modules
- cp Makefile.pre Makefile.orig
- sed -e "s:MODOBJS=:MODOBJS=fchksum.o md5_2.o:" \
- Makefile.orig > Makefile.pre
-
- # Parallel make does not work
- cd ${S}
- try make
-
-}
-
-src_install() {
-
- dodir /usr/share/man
- try make install prefix=${D}/usr MANDIR=${D}/usr/share/man
- rm ${D}/usr/bin/python
- mv ${D}/usr/bin/python2.0 ${D}/usr/bin/spython
-
- if [ "`use build`" ] || [ "`use bootcd`" ]
- then
- rm -rf ${D}/usr/share/man
- rm -rf ${D}/usr/lib/python${PV}/{test,config}
- rm -rf ${D}/usr/include
- fi
-}
-
-pkg_postinst() {
-
- if [ ! -e "${ROOT}/usr/bin/python" ]
- then
- ln -s spython ${ROOT}/usr/bin/python
- fi
-}
diff --git a/sys-devel/spython/spython-2.0-r7.ebuild b/sys-devel/spython/spython-2.0-r7.ebuild
index 5c5c7f526cee..e33a9cc274ed 100644
--- a/sys-devel/spython/spython-2.0-r7.ebuild
+++ b/sys-devel/spython/spython-2.0-r7.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/spython-2.0-r7.ebuild,v 1.3 2001/08/17 23:41:54 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/spython-2.0-r7.ebuild,v 1.4 2001/08/24 04:45:53 drobbins Exp $
S=${WORKDIR}/Python-2.0
S2=${WORKDIR}/python-fchksum-1.1
DESCRIPTION="A really great language -- minimalist python environment"
-SRC_URI="http://www.python.org/ftp/python/src/BeOpen-Python-2.0.tar.bz2
+SRC_URI="http://www.python.org/ftp/python/2.0/BeOpen-Python-2.0.tar.bz2
http://www.azstarnet.com/~donut/programs/fchksum/python-fchksum-1.1.tar.gz"
HOMEPAGE="http://www.python.org http://www.azstarnet.com/~donut/programs/fchksum/"