summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-08-15 02:25:56 +0000
committerTravis Tilley <lv@gentoo.org>2004-08-15 02:25:56 +0000
commit007841f7f19e1db1c1012776318bc649e15d2c40 (patch)
tree8a973771b8263a75ca06348f841b13b7c5600347 /sys-devel
parentver bump (Manifest recommit) (diff)
downloadgentoo-2-007841f7f19e1db1c1012776318bc649e15d2c40.tar.gz
gentoo-2-007841f7f19e1db1c1012776318bc649e15d2c40.tar.bz2
gentoo-2-007841f7f19e1db1c1012776318bc649e15d2c40.zip
-mcpu is deprecated on amd64 and x86
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog6
-rw-r--r--sys-devel/gcc/gcc-3.4.0-r6.ebuild20
-rw-r--r--sys-devel/gcc/gcc-3.4.1-r2.ebuild20
-rw-r--r--sys-devel/gcc/gcc-3.4.1.ebuild20
4 files changed, 35 insertions, 31 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 9b13d1fabf70..cd2aa2cfa9ff 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/gcc
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.304 2004/08/13 20:14:05 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.305 2004/08/15 02:25:56 lv Exp $
+
+ 14 Aug 2004; Travis Tilley <lv@gentoo.org> gcc-3.4.0-r6.ebuild,
+ gcc-3.4.1-r2.ebuild, gcc-3.4.1.ebuild:
+ -mcpu is deprecated on amd64 and x86
13 Aug 2004; Travis Tilley <lv@gentoo.org> gcc-3.4.1-r2.ebuild:
stable on amd64 :)
diff --git a/sys-devel/gcc/gcc-3.4.0-r6.ebuild b/sys-devel/gcc/gcc-3.4.0-r6.ebuild
index 9096b124d53f..610fcc90d3e6 100644
--- a/sys-devel/gcc/gcc-3.4.0-r6.ebuild
+++ b/sys-devel/gcc/gcc-3.4.0-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.0-r6.ebuild,v 1.23 2004/08/08 00:45:48 slarti Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.0-r6.ebuild,v 1.24 2004/08/15 02:25:56 lv Exp $
IUSE="static nls bootstrap build multilib gcj gtk f77 objc hardened uclibc n32 n64"
@@ -36,15 +36,15 @@ do_filter_flags() {
# it is safe. This is especially true for gcc 3.3 + 3.4
replace-flags -O? -O2
- # -mcpu is deprecated, and will actually break the gcc build on
- # a few archs... so we change it to mtune, and then strip unsupported
- # flags so we dont break versions of gcc that dont understand mtune.
- setting="`get-flag mcpu`"
- [ ! -z "${setting}" ] && \
- replace-flags -mcpu="${setting}" -mtune="${setting}" && \
- ewarn "-mcpu is deprecated" && \
- sleep 5
- strip-unsupported-flags
+ # -mcpu is deprecated on these archs, and possibly others
+ if use amd64 || use x86 ; then
+ setting="`get-flag mcpu`"
+ [ ! -z "${setting}" ] && \
+ replace-flags -mcpu="${setting}" -mtune="${setting}" && \
+ ewarn "-mcpu is deprecated on your arch\a\a\a" && \
+ sleep 5
+ strip-unsupported-flags
+ fi
# If we use multilib on mips, we shouldn't pass -mabi flag - it breaks
# build of non-default-abi libraries.
diff --git a/sys-devel/gcc/gcc-3.4.1-r2.ebuild b/sys-devel/gcc/gcc-3.4.1-r2.ebuild
index 4768ff7ef9de..ea12c2140ce2 100644
--- a/sys-devel/gcc/gcc-3.4.1-r2.ebuild
+++ b/sys-devel/gcc/gcc-3.4.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.1-r2.ebuild,v 1.7 2004/08/13 20:14:05 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.1-r2.ebuild,v 1.8 2004/08/15 02:25:56 lv Exp $
IUSE="static nls bootstrap build multilib gcj gtk f77 objc hardened uclibc n32 n64"
@@ -143,15 +143,15 @@ do_filter_flags() {
# it is safe. This is especially true for gcc 3.3 + 3.4
replace-flags -O? -O2
- # -mcpu is deprecated, and will actually break the gcc build on
- # a few archs... so we change it to mtune, and then strip unsupported
- # flags so we dont break versions of gcc that dont understand mtune.
- setting="`get-flag mcpu`"
- [ ! -z "${setting}" ] && \
- replace-flags -mcpu="${setting}" -mtune="${setting}" && \
- ewarn "-mcpu is deprecated\a\a\a" && \
- sleep 5
- strip-unsupported-flags
+ # -mcpu is deprecated on these archs, and possibly others
+ if use amd64 || use x86 ; then
+ setting="`get-flag mcpu`"
+ [ ! -z "${setting}" ] && \
+ replace-flags -mcpu="${setting}" -mtune="${setting}" && \
+ ewarn "-mcpu is deprecated on your arch\a\a\a" && \
+ sleep 5
+ strip-unsupported-flags
+ fi
# If we use multilib on mips, we shouldn't pass -mabi flag - it breaks
# build of non-default-abi libraries.
diff --git a/sys-devel/gcc/gcc-3.4.1.ebuild b/sys-devel/gcc/gcc-3.4.1.ebuild
index 4b989919ad18..4bef85840f6c 100644
--- a/sys-devel/gcc/gcc-3.4.1.ebuild
+++ b/sys-devel/gcc/gcc-3.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.1.ebuild,v 1.19 2004/08/11 18:18:46 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.1.ebuild,v 1.20 2004/08/15 02:25:56 lv Exp $
inherit eutils flag-o-matic libtool gnuconfig
@@ -31,15 +31,15 @@ do_filter_flags() {
# it is safe. This is especially true for gcc 3.3 + 3.4
replace-flags -O? -O2
- # -mcpu is deprecated, and will actually break the gcc build on
- # a few archs... so we change it to mtune, and then strip unsupported
- # flags so we dont break versions of gcc that dont understand mtune.
- setting="`get-flag mcpu`"
- [ ! -z "${setting}" ] && \
- replace-flags -mcpu="${setting}" -mtune="${setting}" && \
- ewarn "-mcpu is deprecated" && \
- sleep 5
- strip-unsupported-flags
+ # -mcpu is deprecated on these archs, and possibly others
+ if use amd64 || use x86 ; then
+ setting="`get-flag mcpu`"
+ [ ! -z "${setting}" ] && \
+ replace-flags -mcpu="${setting}" -mtune="${setting}" && \
+ ewarn "-mcpu is deprecated on your arch\a\a\a" && \
+ sleep 5
+ strip-unsupported-flags
+ fi
# If we use multilib on mips, we shouldn't pass -mabi flag - it breaks
# build of non-default-abi libraries.