summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-06 23:04:43 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-06 23:04:43 +0000
commit042921546c980385cd72f74a4335b3ce903a5707 (patch)
treeecfa3632665df68b9b8e1442b39bd8b2dce931ac /sys-devel
parentNew version 2.40 (Manifest recommit) (diff)
downloadgentoo-2-042921546c980385cd72f74a4335b3ce903a5707.tar.gz
gentoo-2-042921546c980385cd72f74a4335b3ce903a5707.tar.bz2
gentoo-2-042921546c980385cd72f74a4335b3ce903a5707.zip
also port changes to multi-ldpath
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc-config/ChangeLog4
-rw-r--r--sys-devel/gcc-config/files/gcc-config-1.3.5-multi-ldpath60
2 files changed, 28 insertions, 36 deletions
diff --git a/sys-devel/gcc-config/ChangeLog b/sys-devel/gcc-config/ChangeLog
index 8b61427571b9..34a962adc8da 100644
--- a/sys-devel/gcc-config/ChangeLog
+++ b/sys-devel/gcc-config/ChangeLog
@@ -1,9 +1,9 @@
# ChangeLog for sys-devel/gcc-config
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.41 2004/05/06 23:01:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.42 2004/05/06 23:04:43 vapier Exp $
06 May 2004; Mike Frysinger <vapier@gentoo.org> files/gcc-config-1.3.5,
- gcc-config-1.3.5.ebuild:
+ files/gcc-config-1.3.5-multi-ldpath, gcc-config-1.3.5.ebuild:
clean up the help output, add support for -v|--version and -h|--help options,
and then add the version to the gcc-config after installing
diff --git a/sys-devel/gcc-config/files/gcc-config-1.3.5-multi-ldpath b/sys-devel/gcc-config/files/gcc-config-1.3.5-multi-ldpath
index eed4df366bd4..3c6bdc34b211 100644
--- a/sys-devel/gcc-config/files/gcc-config-1.3.5-multi-ldpath
+++ b/sys-devel/gcc-config/files/gcc-config-1.3.5-multi-ldpath
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.5-multi-ldpath,v 1.2 2004/03/06 04:14:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.5-multi-ldpath,v 1.3 2004/05/06 23:04:43 vapier Exp $
# Author: Martin Schlemmer <azarah@gentoo.org>
source /etc/init.d/functions.sh || {
@@ -11,51 +11,35 @@ source /etc/init.d/functions.sh || {
usage() {
cat << "USAGE_END"
-Usage: gcc-config [Option] [CC Profile]
+Usage: gcc-config [options] [CC Profile]
Change the current cc/gcc profile, or give info about profiles.
Options:
- -O, --use-old
- Use the old profile if one was selected.
-
- -P, --use-portage-chost
- Only set to given profile if its CHOST is the same
- as that set for portage in /etc/make.conf (or one of
- other portage config files...).
-
- -c, --get-current-profile
- Print current used gcc profile.
+ -O, --use-old Use the old profile if one was selected.
- -l, --list-profiles
- Print a list of available profiles.
-
- -E, --print-environ
- Print environment that can be used to setup things
- for current gcc profile, or specified one ...
-
- -B, --get-bin-path
- Print path where binaries of given/current profile
- are located.
-
- -L, --get-lib-path
- Print path where libraries of given/current profile
- are located.
+ -P, --use-portage-chost Only set to given profile if its CHOST is the
+ same as that set for portage in /etc/make.conf
+ (or one of other portage config files...).
- -X, --get-stdcxx-incdir
- Print path to g++ include files of given/current
- profile.
-
-The profile name is in the form of:
+ -c, --get-current-profile Print current used gcc profile.
- <CHOST>-<gcc version>
+ -l, --list-profiles Print a list of available profiles.
-For example:
+ -E, --print-environ Print environment that can be used to setup the
+ current gcc profile, or a specified one.
- i686-pc-linux-gnu-3.2.1
+ -B, --get-bin-path Print path where binaries of the given/current
+ profile are located.
+ -L, --get-lib-path Print path where libraries of the given/current
+ profile are located.
+ -X, --get-stdcxx-incdir Print path where g++ include files of the
+ given/current profile are located.
+Profile names are of the form: <CHOST>-<gcc version>
+For example: i686-pc-linux-gnu-3.2.1
USAGE_END
exit 1
@@ -379,6 +363,14 @@ do
DOIT="get_stdcxx_incdir"
fi
;;
+ -h|--help)
+ usage
+ exit 0
+ ;;
+ -v|--version)
+ echo "gcc-config-PORTAGE-VERSION"
+ exit 0
+ ;;
-*)
eerror "$0: Invalid switch! Run $0 without parameters for help."
exit 1