summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-05-09 21:10:44 +0000
committerMichał Górny <mgorny@gentoo.org>2014-05-09 21:10:44 +0000
commit0c349052585ca1ab79540299a13e5aed2031eab0 (patch)
treeb5b97cb588a394afee83de803b9f778364c05d04 /sys-devel
parentVersion bump. (diff)
downloadgentoo-2-0c349052585ca1ab79540299a13e5aed2031eab0.tar.gz
gentoo-2-0c349052585ca1ab79540299a13e5aed2031eab0.tar.bz2
gentoo-2-0c349052585ca1ab79540299a13e5aed2031eab0.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang/ChangeLog7
-rw-r--r--sys-devel/clang/clang-3.4.1-r100.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-devel/clang/ChangeLog b/sys-devel/clang/ChangeLog
index d5d73f8322ad..996e5a70b11a 100644
--- a/sys-devel/clang/ChangeLog
+++ b/sys-devel/clang/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/clang
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.106 2014/03/31 21:20:04 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.107 2014/05/09 21:10:44 mgorny Exp $
+
+*clang-3.4.1-r100 (09 May 2014)
+
+ 09 May 2014; Michał Górny <mgorny@gentoo.org> +clang-3.4.1-r100.ebuild:
+ Version bump.
31 Mar 2014; Michał Górny <mgorny@gentoo.org> clang-3.2.ebuild,
clang-3.3.ebuild, clang-9999.ebuild:
diff --git a/sys-devel/clang/clang-3.4.1-r100.ebuild b/sys-devel/clang/clang-3.4.1-r100.ebuild
new file mode 100644
index 000000000000..e191bcf49146
--- /dev/null
+++ b/sys-devel/clang/clang-3.4.1-r100.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-3.4.1-r100.ebuild,v 1.1 2014/05/09 21:10:44 mgorny Exp $
+
+EAPI=5
+
+inherit multilib-build
+
+DESCRIPTION="C language family frontend for LLVM (meta-ebuild)"
+HOMEPAGE="http://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="UoI-NCSA"
+SLOT="0/3.4"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="debug multitarget python +static-analyzer"
+
+RDEPEND="~sys-devel/llvm-${PV}[clang(-),debug=,multitarget?,python?,static-analyzer,${MULTILIB_USEDEP}]"
+
+# Please keep this package around since it's quite likely that we'll
+# return to separate LLVM & clang ebuilds when the cmake build system
+# is complete.
+
+pkg_postinst() {
+ if has_version ">=dev-util/ccache-3.1.9-r2" ; then
+ #add ccache links as clang might get installed after ccache
+ "${EROOT}"/usr/bin/ccache-config --install-links
+ fi
+}
+
+pkg_postrm() {
+ if has_version ">=dev-util/ccache-3.1.9-r2" && [[ -z ${REPLACED_BY_VERSION} ]]; then
+ # --remove-links would remove all links, --install-links updates them
+ "${EROOT}"/usr/bin/ccache-config --install-links
+ fi
+}