summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2004-04-04 01:37:59 +0000
committerJon Portnoy <avenj@gentoo.org>2004-04-04 01:37:59 +0000
commit1917aa2745b7b9b99279327e7ec534291162f107 (patch)
treeae6be9688e140dfadfdd9253a661cc08afac4f91 /sys-devel
parentStable on x86. (Manifest recommit) (diff)
downloadgentoo-2-1917aa2745b7b9b99279327e7ec534291162f107.tar.gz
gentoo-2-1917aa2745b7b9b99279327e7ec534291162f107.tar.bz2
gentoo-2-1917aa2745b7b9b99279327e7ec534291162f107.zip
Removed unnecessary amd64 construct
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog6
-rw-r--r--sys-devel/gcc/gcc-3.3.3-r1.ebuild13
2 files changed, 12 insertions, 7 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 958c665933ef..bdb2c63f7e91 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/gcc
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.198 2004/03/26 14:38:50 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.199 2004/04/04 01:37:59 avenj Exp $
+
+ 03 Apr 2004; Jon Portnoy <avenj@gentoo.org> gcc-3.3.3.ebuild :
+ Yanked unnecessary amd64-related construct for finding libc.
+ Bug #46697.
26 Mar 2004; Jason Wever <weeve@gentoo.org> gcc-3.3.3.ebuild:
And on the 5th date, gcc-3.3.3 was stable for sparc, and it was good.
diff --git a/sys-devel/gcc/gcc-3.3.3-r1.ebuild b/sys-devel/gcc/gcc-3.3.3-r1.ebuild
index e5dd1a0fdad0..797cf184a19e 100644
--- a/sys-devel/gcc/gcc-3.3.3-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.3.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.3-r1.ebuild,v 1.8 2004/03/06 17:22:47 pappy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.3-r1.ebuild,v 1.9 2004/04/04 01:37:59 avenj Exp $
IUSE="static nls bootstrap java build X multilib nogcj hardened"
@@ -190,11 +190,12 @@ version_patch() {
glibc_have_ssp() {
local my_libc="${ROOT}/lib/libc.so.6"
- case "${ARCH}" in
- "amd64")
- my_libc="${ROOT}/lib64/libc.so.?"
- ;;
- esac
+# Not necessary. lib64 is a symlink to /lib. -- avenj@gentoo.org 3 Apr 04
+# case "${ARCH}" in
+# "amd64")
+# my_libc="${ROOT}/lib64/libc.so.?"
+# ;;
+# esac
# Check for the glibc to have the __guard symbols
if [ "$(readelf -s "${my_libc}" 2>/dev/null | \