summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2012-03-13 17:08:38 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2012-03-13 17:08:38 +0000
commit1b80dc057ebc7fc1fa7f8226055804bf0f1a30b4 (patch)
tree62b4ebb0f4c6f3b74dec4714b4b508071460801c /sys-devel
parentVersion bump (diff)
downloadgentoo-2-1b80dc057ebc7fc1fa7f8226055804bf0f1a30b4.tar.gz
gentoo-2-1b80dc057ebc7fc1fa7f8226055804bf0f1a30b4.tar.bz2
gentoo-2-1b80dc057ebc7fc1fa7f8226055804bf0f1a30b4.zip
Tests require python-2, continuation of bug #407885
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang/ChangeLog6
-rw-r--r--sys-devel/clang/clang-3.0-r3.ebuild15
-rw-r--r--sys-devel/clang/clang-9999.ebuild15
3 files changed, 25 insertions, 11 deletions
diff --git a/sys-devel/clang/ChangeLog b/sys-devel/clang/ChangeLog
index 54fe580c0b41..af11d06f33a3 100644
--- a/sys-devel/clang/ChangeLog
+++ b/sys-devel/clang/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/clang
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.57 2012/03/08 16:37:54 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.58 2012/03/13 17:08:38 voyageur Exp $
+
+ 13 Mar 2012; Bernard Cafarelli <voyageur@gentoo.org> clang-3.0-r3.ebuild,
+ clang-9999.ebuild:
+ Tests require python-2, continuation of bug #407885
08 Mar 2012; Bernard Cafarelli <voyageur@gentoo.org> clang-9999.ebuild:
Add AddressSanitizer (asan) support with compiler-rt, bug #407295
diff --git a/sys-devel/clang/clang-3.0-r3.ebuild b/sys-devel/clang/clang-3.0-r3.ebuild
index e9bd61a12dda..37826b1da79b 100644
--- a/sys-devel/clang/clang-3.0-r3.ebuild
+++ b/sys-devel/clang/clang-3.0-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-3.0-r3.ebuild,v 1.3 2012/02/28 09:09:31 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-3.0-r3.ebuild,v 1.4 2012/03/13 17:08:38 voyageur Exp $
EAPI=3
@@ -52,6 +52,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-3.0-gentoo-binutils-apple.patch
# Specify python version
python_convert_shebangs 2 tools/clang/tools/scan-view/scan-view
+ python_convert_shebangs -r 2 test/Scripts
# From llvm src_prepare
einfo "Fixing install dirs"
@@ -125,10 +126,14 @@ src_test() {
rm -f test/Driver/linux-ld.c
echo ">>> Test phase [test]: ${CATEGORY}/${PF}"
- if ! emake -j1 VERBOSE=1 test; then
- has test $FEATURES && die "Make test failed. See above for details."
- has test $FEATURES || eerror "Make test failed. See above for details."
- fi
+
+ testing() {
+ if ! emake -j1 VERBOSE=1 test; then
+ has test $FEATURES && die "Make test failed. See above for details."
+ has test $FEATURES || eerror "Make test failed. See above for details."
+ fi
+ }
+ python_execute_function testing
}
src_install() {
diff --git a/sys-devel/clang/clang-9999.ebuild b/sys-devel/clang/clang-9999.ebuild
index 4378a8b7db3e..66f2c910e410 100644
--- a/sys-devel/clang/clang-9999.ebuild
+++ b/sys-devel/clang/clang-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-9999.ebuild,v 1.27 2012/03/08 16:37:54 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-9999.ebuild,v 1.28 2012/03/13 17:08:38 voyageur Exp $
EAPI=4
@@ -55,6 +55,7 @@ src_prepare() {
|| die "gold plugin path sed failed"
# Specify python version
python_convert_shebangs 2 tools/clang/tools/scan-view/scan-view
+ python_convert_shebangs -r 2 test/Scripts
python_convert_shebangs 2 projects/compiler-rt/lib/asan/scripts/asan_symbolize.py
# From llvm src_prepare
@@ -111,10 +112,14 @@ src_test() {
cd "${S}"/tools/clang || die "cd clang failed"
echo ">>> Test phase [test]: ${CATEGORY}/${PF}"
- if ! emake -j1 VERBOSE=1 test; then
- has test $FEATURES && die "Make test failed. See above for details."
- has test $FEATURES || eerror "Make test failed. See above for details."
- fi
+
+ testing() {
+ if ! emake -j1 VERBOSE=1 test; then
+ has test $FEATURES && die "Make test failed. See above for details."
+ has test $FEATURES || eerror "Make test failed. See above for details."
+ fi
+ }
+ python_execute_function testing
}
src_install() {