summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2009-04-26 20:14:11 +0000
committerMark Loeser <halcy0n@gentoo.org>2009-04-26 20:14:11 +0000
commit1d1d8b6627c3205012f9788167ee38e0c08aa564 (patch)
tree217f07beafaa13ad44c9ac2de769f8f9994cf163 /sys-devel
parentBump to 3.5.3.2, fixes #262609 (diff)
downloadgentoo-2-1d1d8b6627c3205012f9788167ee38e0c08aa564.tar.gz
gentoo-2-1d1d8b6627c3205012f9788167ee38e0c08aa564.tar.bz2
gentoo-2-1d1d8b6627c3205012f9788167ee38e0c08aa564.zip
Bump patchset to fix bug #261111 and bug #265367 for arm
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog7
-rw-r--r--sys-devel/gcc/gcc-4.3.2-r4.ebuild84
2 files changed, 90 insertions, 1 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 4d7a4edb56a0..d2cd8ce6a94d 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.700 2009/04/14 20:07:45 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.701 2009/04/26 20:14:11 halcy0n Exp $
+
+*gcc-4.3.2-r4 (26 Apr 2009)
+
+ 26 Apr 2009; Mark Loeser <halcy0n@gentoo.org> +gcc-4.3.2-r4.ebuild:
+ Bump patchset to fix bug #261111 and bug #265367 for arm
14 Apr 2009; Brent Baude <ranger@gentoo.org> gcc-4.3.2-r3.ebuild:
Marking gcc-4.3.2-r3 ppc64 for bug 264121
diff --git a/sys-devel/gcc/gcc-4.3.2-r4.ebuild b/sys-devel/gcc/gcc-4.3.2-r4.ebuild
new file mode 100644
index 000000000000..31834143a197
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.3.2-r4.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.2-r4.ebuild,v 1.1 2009/04/26 20:14:11 halcy0n Exp $
+
+PATCH_VER="1.7"
+UCLIBC_VER="1.0"
+
+ETYPE="gcc-compiler"
+
+# Hardened gcc 4 stuff
+PIE_VER="10.1.5"
+PIE_GCC_VER="4.3.2"
+SPECS_VER="0.9.4"
+SPECS_GCC_VER="4.3.2"
+
+# arch/libc configurations known to be stable or untested with {PIE,SSP,FORTIFY}-by-default
+PIE_GLIBC_STABLE="x86 amd64 ~ppc ~ppc64 ~arm ~sparc"
+PIE_UCLIBC_STABLE="x86 arm"
+#SSP_STABLE="amd64 x86 ppc ppc64 ~arm ~sparc"
+#SSP_UCLIBC_STABLE=""
+
+# whether we should split out specs files for multiple {PIE,SSP}-by-default
+# and vanilla configurations.
+SPLIT_SPECS=no #${SPLIT_SPECS-true} hard disable until #106690 is fixed
+
+inherit toolchain
+
+DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
+
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ >=sys-devel/gcc-config-1.4
+ virtual/libiconv
+ >=dev-libs/gmp-4.2.1
+ >=dev-libs/mpfr-2.3
+ !build? (
+ gcj? (
+ gtk? (
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-libs/libXtst
+ x11-proto/xproto
+ x11-proto/xextproto
+ >=x11-libs/gtk+-2.2
+ x11-libs/pango
+ )
+ >=media-libs/libart_lgpl-2.1
+ app-arch/zip
+ app-arch/unzip
+ )
+ >=sys-libs/ncurses-5.2-r2
+ nls? ( sys-devel/gettext )
+ )"
+DEPEND="${RDEPEND}
+ test? ( sys-devel/autogen dev-util/dejagnu )
+ >=sys-apps/texinfo-4.2-r4
+ >=sys-devel/bison-1.875
+ amd64? (
+ >=sys-libs/glibc-2.7-r2
+ multilib? (
+ gcj? ( app-emulation/emul-linux-x86-xlibs )
+ )
+ )
+ ppc? ( >=${CATEGORY}/binutils-2.17 )
+ ppc64? ( >=${CATEGORY}/binutils-2.17 )
+ >=${CATEGORY}/binutils-2.15.94"
+PDEPEND=">=sys-devel/gcc-config-1.4"
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.6 )"
+fi
+
+src_unpack() {
+ gcc_src_unpack
+
+ use vanilla && return 0
+
+ sed -i 's/use_fixproto=yes/:/' gcc/config.gcc #PR33200
+
+ [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
+
+ [[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.3.2/gcc-4.3.2-softfloat.patch
+}