summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Gavin <pete@gentoo.org>2001-08-06 23:01:55 +0000
committerPeter Gavin <pete@gentoo.org>2001-08-06 23:01:55 +0000
commit2ce3096280fa008c85761409730c9cb079805826 (patch)
treed8df28470e7b2bfb92cce3a2949164b662753f9b /sys-devel
parentadded mozilla 0.9.3 until new galeon (diff)
downloadgentoo-2-2ce3096280fa008c85761409730c9cb079805826.tar.gz
gentoo-2-2ce3096280fa008c85761409730c9cb079805826.tar.bz2
gentoo-2-2ce3096280fa008c85761409730c9cb079805826.zip
*** empty log message ***
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/spython/spython-2.0-r7.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/sys-devel/spython/spython-2.0-r7.ebuild b/sys-devel/spython/spython-2.0-r7.ebuild
index 90f574a4ab5b..93bc5f7f0730 100644
--- a/sys-devel/spython/spython-2.0-r7.ebuild
+++ b/sys-devel/spython/spython-2.0-r7.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/spython-2.0-r7.ebuild,v 1.1 2001/08/04 02:10:10 pete Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/spython-2.0-r7.ebuild,v 1.2 2001/08/06 23:01:55 pete Exp $
S=${WORKDIR}/Python-2.0
S2=${WORKDIR}/python-fchksum-1.1
@@ -71,7 +71,7 @@ src_compile() {
}
src_install() {
-
+
dodir /usr/share/man
try make install prefix=${D}/usr MANDIR=${D}/usr/share/man
@@ -89,3 +89,13 @@ src_install() {
rm -rf ${D}/usr/include
fi
}
+
+pkg_preinst() {
+ # keep portage from breaking from this move
+ for file in ${ROOT}/usr/lib/python2.0/{xpak,portage}.py
+ do
+ [ -f ${file} ] || continue
+ cp -a ${file} ${ROOT}/usr/lib/python2.0/site-packages
+ rm -f ${file}
+ done
+}