summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-08-15 05:14:35 +0000
committerMike Frysinger <vapier@gentoo.org>2010-08-15 05:14:35 +0000
commit456b4ddb338946a5910389ced029610cb2c594dd (patch)
tree66aa85d2db5e1c19a39ec568879a1e1f7b545863 /sys-devel
parentold (diff)
downloadgentoo-2-456b4ddb338946a5910389ced029610cb2c594dd.tar.gz
gentoo-2-456b4ddb338946a5910389ced029610cb2c594dd.tar.bz2
gentoo-2-456b4ddb338946a5910389ced029610cb2c594dd.zip
Fix incorrect header deletion when switching profiles #330299 by Pinky.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils-config/ChangeLog10
-rw-r--r--sys-devel/binutils-config/binutils-config-2-r1.ebuild19
-rwxr-xr-xsys-devel/binutils-config/files/binutils-config-28
3 files changed, 31 insertions, 6 deletions
diff --git a/sys-devel/binutils-config/ChangeLog b/sys-devel/binutils-config/ChangeLog
index 28f9f1af0b0c..74cbdbb1a4ee 100644
--- a/sys-devel/binutils-config/ChangeLog
+++ b/sys-devel/binutils-config/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/binutils-config
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/ChangeLog,v 1.36 2009/12/20 19:56:56 vapier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/ChangeLog,v 1.37 2010/08/15 05:14:35 vapier Exp $
+
+*binutils-config-2-r1 (15 Aug 2010)
+
+ 15 Aug 2010; Mike Frysinger <vapier@gentoo.org> files/binutils-config-2,
+ +binutils-config-2-r1.ebuild:
+ Fix incorrect header deletion when switching profiles #330299 by Pinky.
*binutils-config-2 (20 Dec 2009)
diff --git a/sys-devel/binutils-config/binutils-config-2-r1.ebuild b/sys-devel/binutils-config/binutils-config-2-r1.ebuild
new file mode 100644
index 000000000000..f8f68a30d06d
--- /dev/null
+++ b/sys-devel/binutils-config/binutils-config-2-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/binutils-config-2-r1.ebuild,v 1.1 2010/08/15 05:14:35 vapier Exp $
+
+DESCRIPTION="Utility to change the binutils version being used"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND="userland_GNU? ( >=sys-apps/findutils-4.2 )"
+
+src_install() {
+ newbin "${FILESDIR}"/${PN}-${PV} ${PN} || die
+ doman "${FILESDIR}"/${PN}.8
+}
diff --git a/sys-devel/binutils-config/files/binutils-config-2 b/sys-devel/binutils-config/files/binutils-config-2
index 6b172dbc6f8a..e5a36d0c7ec8 100755
--- a/sys-devel/binutils-config/files/binutils-config-2
+++ b/sys-devel/binutils-config/files/binutils-config-2
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/files/binutils-config-2,v 1.1 2009/12/20 19:56:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/files/binutils-config-2,v 1.2 2010/08/15 05:14:35 vapier Exp $
# Format of /etc/env.d/binutils/:
# config-TARGET: CURRENT=version for TARGET
@@ -159,8 +159,8 @@ switch_profile() {
ln -sf "${INCPATH}/${x}" "${ROOT}/usr/include/${x}"
done
else
- # Clean out old path
- find . -type f -exec rm -f "${ROOT}/usr/${TARGET}/usr/include/{}" +
+ # Clean out old path -- cannot use '-exec {} +' syntax here
+ find . -type f -exec rm -f "${ROOT}/usr/${TARGET}/usr/include/{}" \;
rmdir "${ROOT}/usr/${TARGET}/usr/include" >& /dev/null
rmdir "${ROOT}/usr/${TARGET}/usr" >& /dev/null
rmdir "${ROOT}/usr/${TARGET}" >& /dev/null
@@ -358,7 +358,7 @@ while [[ $# -gt 0 ]] ; do
;;
-V|--version)
unset Header
- cvsver="$Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/files/binutils-config-2,v 1.1 2009/12/20 19:56:57 vapier Exp $"
+ cvsver="$Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/files/binutils-config-2,v 1.2 2010/08/15 05:14:35 vapier Exp $"
cvsver=${cvsver##*binutils-config-}
bver=${cvsver%%,v *}
cvsver=${cvsver#* }