summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-10-27 19:07:09 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-10-27 19:07:09 +0000
commit46d160229649e32c0d8d60836983be25f97aa05e (patch)
tree0a3d6d465f901a568f297f5c604d49f15615dafe /sys-devel
parentUpdate protector patch to 3.3-5. (diff)
downloadgentoo-2-46d160229649e32c0d8d60836983be25f97aa05e.tar.gz
gentoo-2-46d160229649e32c0d8d60836983be25f97aa05e.tar.bz2
gentoo-2-46d160229649e32c0d8d60836983be25f97aa05e.zip
Update protector patch to 3.3-5.
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog7
-rw-r--r--sys-devel/gcc/Manifest4
-rw-r--r--sys-devel/gcc/files/digest-gcc-3.3.2-r25
-rw-r--r--sys-devel/gcc/gcc-3.3.2-r2.ebuild622
4 files changed, 635 insertions, 3 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index a421c249d126..211406e10a3c 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gcc
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.139 2003/10/26 15:43:27 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.140 2003/10/27 19:06:56 azarah Exp $
+
+*gcc-3.3.2-r2 (27 Oct 2003)
+
+ 27 Oct 2003; Martin Schlemmer <azarah@gentoo.org> gcc-3.3.2-r2.ebuild:
+ Update protector patch to 3.3-5.
*gcc-3.3.2-r1 (26 Oct 2003)
diff --git a/sys-devel/gcc/Manifest b/sys-devel/gcc/Manifest
index bb1edc3a2044..0179859d8d5f 100644
--- a/sys-devel/gcc/Manifest
+++ b/sys-devel/gcc/Manifest
@@ -1,8 +1,8 @@
MD5 d25ffc7e82003a26e025471ca8df299c gcc-3.2.1-r7.ebuild 14774
MD5 77dabd76c2610078ebdb9566f8b54503 gcc-3.2.2-r2.ebuild 15843
-MD5 4d20468233a8fe77879ae732c0e8c946 gcc-3.3.2-r2.ebuild 17951
+MD5 6349830efd51a7fa5d30727b362024f4 gcc-3.3.2-r2.ebuild 17951
MD5 6d0d6b9214ecb88e26a54b70901c50b4 gcc-2.95.3-r7.ebuild 5436
-MD5 4f05cb3e384da16a22aeba15ebfa97a7 ChangeLog 30780
+MD5 b4f4a9009fd3f73c2aa8b71752d3fe4b ChangeLog 30918
MD5 3f796d926d7c63b50910a657cb67a358 gcc-3.1.1-r1.ebuild 9595
MD5 aa01e0515884df05563094839c31d7d1 gcc-3.3.1-r1.ebuild 16131
MD5 10dc6dfc81f6d853c4cb5f54f89ccdbe gcc-3.3.1-r5.ebuild 17998
diff --git a/sys-devel/gcc/files/digest-gcc-3.3.2-r2 b/sys-devel/gcc/files/digest-gcc-3.3.2-r2
new file mode 100644
index 000000000000..97e44ed2bd42
--- /dev/null
+++ b/sys-devel/gcc/files/digest-gcc-3.3.2-r2
@@ -0,0 +1,5 @@
+MD5 65999f654102f5438ac8562d13a6eced gcc-3.3.2.tar.bz2 23585904
+MD5 4b757459fb3d0e69031a86de80320ad9 gcc-3.3.2-patches-1.0.tar.bz2 23675
+MD5 0a2f4bfe7858f064eead2663804db6bf gcc-3.3.2-branch-update-20031022.patch.bz2 152228
+MD5 55a77f8e961808836753c7280490b110 protector-3.3-5.tar.gz 24794
+MD5 cfaa61a61372f486160cdba32081fb3e gcc-3.3.2-manpages.tar.bz2 137196
diff --git a/sys-devel/gcc/gcc-3.3.2-r2.ebuild b/sys-devel/gcc/gcc-3.3.2-r2.ebuild
new file mode 100644
index 000000000000..5f530d580c6c
--- /dev/null
+++ b/sys-devel/gcc/gcc-3.3.2-r2.ebuild
@@ -0,0 +1,622 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.2-r2.ebuild,v 1.1 2003/10/27 19:06:57 azarah Exp $
+
+IUSE="static nls bootstrap java build X multilib"
+
+inherit eutils flag-o-matic libtool
+
+# Compile problems with these (bug #6641 among others)...
+#filter-flags "-fno-exceptions -fomit-frame-pointer -fforce-addr"
+
+# Recently there has been a lot of stability problem in Gentoo-land. Many
+# things can be the cause to this, but I believe that it is due to gcc3
+# still having issues with optimizations, or with it not filtering bad
+# combinations (protecting the user maybe from himeself) yet.
+#
+# This can clearly be seen in large builds like glibc, where too aggressive
+# CFLAGS cause the tests to fail miserbly.
+#
+# Quote from Nick Jones <carpaski@gentoo.org>, who in my opinion
+# knows what he is talking about:
+#
+# People really shouldn't force code-specific options on... It's a
+# bad idea. The -march options aren't just to look pretty. They enable
+# options that are sensible (and include sse,mmx,3dnow when apropriate).
+#
+# The next command strips CFLAGS and CXXFLAGS from nearly all flags. If
+# you do not like it, comment it, but do not bugreport if you run into
+# problems.
+#
+# <azarah@gentoo.org> (13 Oct 2002)
+strip-flags
+
+# Theoretical cross compiler support
+[ ! -n "${CCHOST}" ] && export CCHOST="${CHOST}"
+
+LOC="/usr"
+MY_PV="`echo ${PV} | awk -F. '{ gsub(/_pre.*|_alpha.*/, ""); print $1 "." $2 }'`"
+MY_PV_FULL="`echo ${PV} | awk '{ gsub(/_pre.*|_alpha.*/, ""); print $0 }'`"
+
+LIBPATH="${LOC}/lib/gcc-lib/${CCHOST}/${MY_PV_FULL}"
+BINPATH="${LOC}/${CCHOST}/gcc-bin/${MY_PV}"
+DATAPATH="${LOC}/share/gcc-data/${CCHOST}/${MY_PV}"
+# Dont install in /usr/include/g++-v3/, but in gcc internal directory.
+# We will handle /usr/include/g++-v3/ with gcc-config ...
+STDCXX_INCDIR="${LIBPATH}/include/g++-v${MY_PV/\.*/}"
+
+# ProPolice version
+PP_VER="3_3"
+PP_FVER="${PP_VER//_/.}-5"
+
+# Patch tarball support ...
+#PATCH_VER="1.0"
+PATCH_VER="1.0"
+
+# Snapshot support ...
+#SNAPSHOT="2002-08-12"
+SNAPSHOT=
+
+# Branch update support ...
+MAIN_BRANCH="${PV}" # Tarball, etc used ...
+
+#BRANCH_UPDATE="20021208"
+BRANCH_UPDATE="20031022"
+
+if [ -z "${SNAPSHOT}" ]
+then
+ S="${WORKDIR}/${PN}-${MAIN_BRANCH}"
+ SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/${P}/${PN}-${MAIN_BRANCH}.tar.bz2"
+
+ if [ -n "${PATCH_VER}" ]
+ then
+ SRC_URI="${SRC_URI}
+ mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2"
+ fi
+
+ if [ -n "${BRANCH_UPDATE}" ]
+ then
+ SRC_URI="${SRC_URI}
+ mirror://gentoo/${PN}-${MAIN_BRANCH}-branch-update-${BRANCH_UPDATE}.patch.bz2"
+ fi
+else
+ S="${WORKDIR}/gcc-${SNAPSHOT//-}"
+ SRC_URI="ftp://sources.redhat.com/pub/gcc/snapshots/${SNAPSHOT}/gcc-${SNAPSHOT//-}.tar.bz2"
+fi
+if [ -n "${PP_VER}" ]
+then
+ SRC_URI="${SRC_URI}
+ http://www.research.ibm.com/trl/projects/security/ssp/gcc${PP_VER}/protector-${PP_FVER}.tar.gz"
+fi
+SRC_URI="${SRC_URI}
+ mirror://gentoo/${P}-manpages.tar.bz2"
+
+DESCRIPTION="The GNU Compiler Collection. Includes C/C++ and java compilers"
+HOMEPAGE="http://www.gnu.org/software/gcc/gcc.html"
+
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="-* ~x86 ~mips ~sparc ~amd64"
+
+# Ok, this is a hairy one again, but lets assume that we
+# are not cross compiling, than we want SLOT to only contain
+# $PV, as people upgrading to new gcc layout will not have
+# their old gcc unmerged ...
+if [ "${CHOST}" == "${CCHOST}" ]
+then
+# GCC-3.3 is supposed to be binary compatible with 3.2..
+# SLOT="${MY_PV}"
+ SLOT="3.2"
+else
+# GCC-3.3 is supposed to be binary compatible with 3.2..
+# SLOT="${CCHOST}-${MY_PV}"
+ SLOT="${CCHOST}-3.2"
+fi
+
+# We need the later binutils for support of the new cleanup attribute.
+# 'make check' fails for about 10 tests (if I remember correctly) less
+# if we use later bison.
+DEPEND="virtual/glibc
+ >=sys-devel/binutils-2.14.90.0.6-r1
+ >=sys-devel/bison-1.875
+ >=sys-devel/gcc-config-1.3.1
+ amd64? ( multilib? ( >=app-emulation/emul-linux-x86-baselibs-1.0 ) )
+ !build? ( >=sys-libs/ncurses-5.2-r2
+ nls? ( sys-devel/gettext ) )"
+
+RDEPEND="virtual/glibc
+ >=sys-devel/gcc-config-1.3.1
+ >=sys-libs/zlib-1.1.4
+ >=sys-apps/texinfo-4.2-r4
+ !build? ( >=sys-libs/ncurses-5.2-r2 )"
+
+PDEPEND="sys-devel/gcc-config"
+
+
+chk_gcc_version() {
+ # This next bit is for updating libtool linker scripts ...
+ local OLD_GCC_VERSION="`gcc -dumpversion`"
+ local OLD_GCC_CHOST="$(gcc -v 2>&1 | egrep '^Reading specs' |\
+ sed -e 's:^.*/gcc-lib/\([^/]*\)/[0-9]\+.*$:\1:')"
+
+ if [ "${OLD_GCC_VERSION}" != "${MY_PV_FULL}" ]
+ then
+ echo "${OLD_GCC_VERSION}" > "${WORKDIR}/.oldgccversion"
+ fi
+
+ if [ -n "${OLD_GCC_CHOST}" ]
+ then
+ if [ "${CHOST}" = "${CCHOST}" -a "${OLD_GCC_CHOST}" != "${CHOST}" ]
+ then
+ echo "${OLD_GCC_CHOST}" > "${WORKDIR}/.oldgccchost"
+ fi
+ fi
+
+ # Did we check the version ?
+ touch "${WORKDIR}/.chkgccversion"
+}
+
+version_patch() {
+ [ ! -f "$1" ] && return 1
+ [ -z "$2" ] && return 1
+
+ sed -e "s:@GENTOO@:$2:g" ${1} > ${T}/${1##*/}
+ epatch ${T}/${1##*/}
+}
+
+src_unpack() {
+ if [ -z "${SNAPSHOT}" ]
+ then
+ unpack ${PN}-${MAIN_BRANCH}.tar.bz2
+
+ if [ -n "${PATCH_VER}" ]
+ then
+ unpack ${P}-patches-${PATCH_VER}.tar.bz2
+ fi
+ else
+ unpack gcc-${SNAPSHOT//-}.tar.bz2
+ fi
+
+ if [ -n "${PP_VER}" ]
+ then
+ unpack protector-${PP_FVER}.tar.gz
+ fi
+
+ cd ${S}
+ # Fixup libtool to correctly generate .la files with portage
+ elibtoolize --portage --shallow
+
+ echo
+
+ # Branch update ...
+ if [ -n "${BRANCH_UPDATE}" ]
+ then
+ epatch ${DISTDIR}/${PN}-${MAIN_BRANCH}-branch-update-${BRANCH_UPDATE}.patch.bz2
+ fi
+
+ # Do bulk patches included in ${P}-patches-${PATCH_VER}.tar.bz2
+ if [ -n "${PATCH_VER}" ]
+ then
+ mkdir -p ${WORKDIR}/patch/exclude
+ mv -f ${WORKDIR}/patch/{40,41}* ${WORKDIR}/patch/exclude/
+
+ if [ -n "`use multilib`" -a "${ARCH}" = "amd64" ]
+ then
+ mv -f ${WORKDIR}/patch/06* ${WORKDIR}/patch/exclude/
+ bzip2 -c ${FILESDIR}/gcc331_use_multilib.amd64.patch > \
+ ${WORKDIR}/patch/06_amd64_gcc331-use-multilib.patch.bz2
+ fi
+
+ epatch ${WORKDIR}/patch
+ fi
+
+ if [ -z "${PP_VER}" ]
+ then
+ # Make gcc's version info specific to Gentoo
+ version_patch ${FILESDIR}/3.3.2/gcc332-gentoo-branding.patch \
+ "${BRANCH_UPDATE} (Gentoo Linux ${PVR})" || die "Failed Branding"
+ fi
+
+ if [ -n "${PP_VER}" ] && [ "${ARCH}" != "hppa" ]
+ then
+ # ProPolice Stack Smashing protection
+ EPATCH_OPTS="${EPATCH_OPTS} ${WORKDIR}/protector.dif" \
+ epatch ${FILESDIR}/3.3.1/gcc331-pp-fixup.patch
+ epatch ${WORKDIR}/protector.dif
+ cp ${WORKDIR}/protector.c ${WORKDIR}/${P}/gcc/ || die "protector.c not found"
+ cp ${WORKDIR}/protector.h ${WORKDIR}/${P}/gcc/ || die "protector.h not found"
+ version_patch ${FILESDIR}/3.3.2/gcc332-gentoo-branding.patch \
+ "${BRANCH_UPDATE} (Gentoo Linux ${PVR}, propolice)" \
+ || die "Failed Branding"
+ fi
+
+ # Install our pre generated manpages if we do not have perl ...
+ if [ ! -x /usr/bin/perl ]
+ then
+ cd ${S}; unpack ${P}-manpages.tar.bz2
+ fi
+
+ # Misdesign in libstdc++ (Redhat)
+ cp -a ${S}/libstdc++-v3/config/cpu/i{4,3}86/atomicity.h
+
+ cd ${S}; ./contrib/gcc_update --touch &> /dev/null
+}
+
+src_compile() {
+
+ local myconf=
+ local gcc_lang=
+
+ if [ -z "`use build`" ]
+ then
+ myconf="${myconf} --enable-shared"
+ gcc_lang="c,c++,f77,objc"
+ else
+ gcc_lang="c"
+ fi
+ if [ -z "`use nls`" -o "`use build`" ]
+ then
+ myconf="${myconf} --disable-nls"
+ else
+ myconf="${myconf} --enable-nls --without-included-gettext"
+ fi
+ if [ -n "`use java`" -a -z "`use build`" ]
+ then
+ gcc_lang="${gcc_lang},java"
+ fi
+
+ # Enable building of the gcj Java AWT & Swing X11 backend
+ # if we have X as a use flag and are not in a build stage.
+ # X11 support is still very experimental but enabling it is
+ # quite innocuous... [No, gcc is *not* linked to X11...]
+ # <dragon@gentoo.org> (15 May 2003)
+ if [ -n "`use java`" -a -n "`use X`" -a -z "`use build`" -a \
+ -f /usr/X11R6/include/X11/Xlib.h ]
+ then
+ myconf="${myconf} --x-includes=/usr/X11R6/include --x-libraries=/usr/X11R6/lib"
+ myconf="${myconf} --enable-interpreter --enable-java-awt=xlib --with-x"
+ fi
+
+ # Multilib not yet supported
+ if [ -n "`use multilib`" -a "${ARCH}" = "amd64" ]
+ then
+ einfo "WARNING: Multilib support enabled. This is still experimental."
+ myconf="${myconf} --enable-multilib"
+ else
+ if [ "${ARCH}" = "amd64" ]
+ then
+ einfo "WARNING: Multilib not enabled. You will not be able to build 32bit binaries."
+ fi
+ myconf="${myconf} --disable-multilib"
+ fi
+
+ # In general gcc does not like optimization, and add -O2 where
+ # it is safe. This is especially true for gcc-3.3 ...
+ export CFLAGS="${CFLAGS/-O?/-O2}"
+ export CXXFLAGS="${CXXFLAGS/-O?/-O2}"
+ export GCJFLAGS="${CFLAGS/-O?/-O2}"
+
+ # Build in a separate build tree
+ mkdir -p ${WORKDIR}/build
+ cd ${WORKDIR}/build
+
+ einfo "Configuring GCC..."
+ addwrite "/dev/zero"
+ ${S}/configure --prefix=${LOC} \
+ --bindir=${BINPATH} \
+ --includedir=${LIBPATH}/include \
+ --datadir=${DATAPATH} \
+ --mandir=${DATAPATH}/man \
+ --infodir=${DATAPATH}/info \
+ --enable-shared \
+ --host=${CHOST} \
+ --target=${CCHOST} \
+ --with-system-zlib \
+ --enable-languages=${gcc_lang} \
+ --enable-threads=posix \
+ --enable-long-long \
+ --disable-checking \
+ --enable-cstdio=stdio \
+ --enable-clocale=generic \
+ --enable-__cxa_atexit \
+ --enable-version-specific-runtime-libs \
+ --with-gxx-include-dir=${STDCXX_INCDIR} \
+ --with-local-prefix=${LOC}/local \
+ ${myconf} || die
+
+ touch ${S}/gcc/c-gperf.h
+
+ # Do not make manpages if we do not have perl ...
+ if [ ! -x /usr/bin/perl ]
+ then
+ find ${S} -name '*.[17]' -exec touch {} \; || :
+ fi
+
+ # Setup -j in MAKEOPTS
+ get_number_of_jobs
+
+ einfo "Building GCC..."
+ # Only build it static if we are just building the C frontend, else
+ # a lot of things break because there are not libstdc++.so ....
+ if [ -n "`use static`" -a "${gcc_lang}" = "c" ]
+ then
+ # Fix for our libtool-portage.patch
+ S="${WORKDIR}/build" \
+ emake LDFLAGS="-static" bootstrap \
+ LIBPATH="${LIBPATH}" \
+ BOOT_CFLAGS="${CFLAGS}" STAGE1_CFLAGS="-O" || die
+ # Above FLAGS optimize and speedup build, thanks
+ # to Jeff Garzik <jgarzik@mandrakesoft.com>
+ else
+ # Fix for our libtool-portage.patch
+ S="${WORKDIR}/build" \
+ emake bootstrap-lean \
+ LIBPATH="${LIBPATH}" \
+ BOOT_CFLAGS="${CFLAGS}" STAGE1_CFLAGS="-O" || die
+
+ fi
+}
+
+src_install() {
+ # Do allow symlinks in ${LOC}/lib/gcc-lib/${CHOST}/${PV}/include as
+ # this can break the build.
+ for x in cd ${WORKDIR}/build/gcc/include/*
+ do
+ if [ -L ${x} ]
+ then
+ rm -f ${x}
+ fi
+ done
+
+ einfo "Installing GCC..."
+ # Do the 'make install' from the build directory
+ cd ${WORKDIR}/build
+ S="${WORKDIR}/build" \
+ make prefix=${LOC} \
+ bindir=${BINPATH} \
+ includedir=${LIBPATH}/include \
+ datadir=${DATAPATH} \
+ mandir=${DATAPATH}/man \
+ infodir=${DATAPATH}/info \
+ DESTDIR="${D}" \
+ LIBPATH="${LIBPATH}" \
+ install || die
+
+ [ -r ${D}${BINPATH}/gcc ] || die "gcc not found in ${D}"
+
+ dodir /lib /usr/bin
+ dodir /etc/env.d/gcc
+ echo "PATH=\"${BINPATH}\"" > ${D}/etc/env.d/gcc/${CCHOST}-${MY_PV_FULL}
+ echo "ROOTPATH=\"${BINPATH}\"" >> ${D}/etc/env.d/gcc/${CCHOST}-${MY_PV_FULL}
+ if [ -n "`use multilib`" -a "${ARCH}" = "amd64" ]
+ then
+ # amd64 is a bit unique because of multilib. Add some other paths
+ echo "LDPATH=\"${LIBPATH}:${LIBPATH}/32:${LIBPATH}/../lib64:${LIBPATH}/../lib32\"" >> ${D}/etc/env.d/gcc/${CCHOST}-${MY_PV_FULL}
+ else
+ echo "LDPATH=\"${LIBPATH}\"" >> ${D}/etc/env.d/gcc/${CCHOST}-${MY_PV_FULL}
+ fi
+ echo "MANPATH=\"${DATAPATH}/man\"" >> ${D}/etc/env.d/gcc/${CCHOST}-${MY_PV_FULL}
+ echo "INFOPATH=\"${DATAPATH}/info\"" >> ${D}/etc/env.d/gcc/${CCHOST}-${MY_PV_FULL}
+ echo "STDCXX_INCDIR=\"${STDCXX_INCDIR##*/}\"" >> ${D}/etc/env.d/gcc/${CCHOST}-${MY_PV_FULL}
+ # Also set CC and CXX
+ echo "CC=\"gcc\"" >> ${D}/etc/env.d/gcc/${CCHOST}-${MY_PV_FULL}
+ echo "CXX=\"g++\"" >> ${D}/etc/env.d/gcc/${CCHOST}-${MY_PV_FULL}
+
+ # Make sure we dont have stuff lying around that
+ # can nuke multiple versions of gcc
+ if [ -z "`use build`" ]
+ then
+ cd ${D}${LIBPATH}
+
+ # Tell libtool files where real libraries are
+ for x in ${D}${LOC}/lib/*.la ${D}${LIBPATH}/../*.la
+ do
+ if [ -f "${x}" ]
+ then
+ sed -i -e "s:/usr/lib:${LIBPATH}:" ${x}
+ mv ${x} ${D}${LIBPATH}
+ fi
+ done
+
+ # Move all the libraries to version specific libdir.
+ for x in ${D}${LOC}/lib/*.{so,a}* ${D}${LIBPATH}/../*.{so,a}*
+ do
+ [ -f "${x}" -o -L "${x}" ] && mv -f ${x} ${D}${LIBPATH}
+ done
+
+ # Move Java headers to compiler-specific dir
+ for x in ${D}${LOC}/include/gc*.h ${D}${LOC}/include/j*.h
+ do
+ [ -f "${x}" ] && mv -f ${x} ${D}${LIBPATH}/include/
+ done
+ for x in gcj gnu java javax org
+ do
+ if [ -d "${D}${LOC}/include/${x}" ]
+ then
+ dodir /${LIBPATH}/include/${x}
+ mv -f ${D}${LOC}/include/${x}/* ${D}${LIBPATH}/include/${x}/
+ rm -rf ${D}${LOC}/include/${x}
+ fi
+ done
+
+ if [ -d "${D}${LOC}/lib/security" ]
+ then
+ dodir /${LIBPATH}/security
+ mv -f ${D}${LOC}/lib/security/* ${D}${LIBPATH}/security
+ rm -rf ${D}${LOC}/lib/security
+ fi
+
+ # Move libgcj.spec to compiler-specific directories
+ [ -f "${D}${LOC}/lib/libgcj.spec" ] && \
+ mv -f ${D}${LOC}/lib/libgcj.spec ${D}${LIBPATH}/libgcj.spec
+
+ # Rename jar because it could clash with Kaffe's jar if this gcc is
+ # primary compiler (aka don't have the -<version> extension)
+ cd ${D}${LOC}/${CCHOST}/gcc-bin/${MY_PV}
+ [ -f jar ] && mv -f jar gcj-jar
+
+ # Move <cxxabi.h> to compiler-specific directories
+ [ -f "${D}${STDCXX_INCDIR}/cxxabi.h" ] && \
+ mv -f ${D}${STDCXX_INCDIR}/cxxabi.h ${D}${LIBPATH}/include/
+
+ # These should be symlinks
+ cd ${D}${BINPATH}
+ for x in gcc g++ c++ g77 gcj
+ do
+ rm -f ${CCHOST}-${x}
+ [ -f "${x}" ] && ln -sf ${x} ${CCHOST}-${x}
+
+ if [ -f "${CCHOST}-${x}-${PV}" ]
+ then
+ rm -f ${CCHOST}-${x}-${PV}
+ ln -sf ${x} ${CCHOST}-${x}-${PV}
+ fi
+ done
+ fi
+
+ # This one comes with binutils
+ if [ -f "${D}${LOC}/lib/libiberty.a" ]
+ then
+ rm -f ${D}${LOC}/lib/libiberty.a
+ fi
+
+ cd ${S}
+ if [ -z "`use build`" ]
+ then
+ cd ${S}
+ docinto /${CCHOST}
+ dodoc COPYING COPYING.LIB ChangeLog* FAQ MAINTAINERS README
+ docinto ${CCHOST}/html
+ dohtml *.html
+ cd ${S}/boehm-gc
+ docinto ${CCHOST}/boehm-gc
+ dodoc ChangeLog doc/{README*,barrett_diagram}
+ docinto ${CCHOST}/boehm-gc/html
+ dohtml doc/*.html
+ cd ${S}/gcc
+ docinto ${CCHOST}/gcc
+ dodoc ChangeLog* FSFChangeLog* LANGUAGES NEWS ONEWS README* SERVICE
+ cd ${S}/libf2c
+ docinto ${CCHOST}/libf2c
+ dodoc ChangeLog* README TODO *.netlib
+ cd ${S}/libffi
+ docinto ${CCHOST}/libffi
+ dodoc ChangeLog* LICENSE README
+ cd ${S}/libiberty
+ docinto ${CCHOST}/libiberty
+ dodoc ChangeLog* COPYING.LIB README
+ cd ${S}/libobjc
+ docinto ${CCHOST}/libobjc
+ dodoc ChangeLog* README* THREADS*
+ cd ${S}/libstdc++-v3
+ docinto ${CCHOST}/libstdc++-v3
+ dodoc ChangeLog* README
+ docinto ${CCHOST}/libstdc++-v3/html
+ dohtml -r -a css,diff,html,txt,xml docs/html/*
+ cp -f docs/html/17_intro/[A-Z]* \
+ ${D}/usr/share/doc/${PF}/${DOCDESTTREE}/17_intro/
+
+ if [ -n "`use java`" ]
+ then
+ cd ${S}/fastjar
+ docinto ${CCHOST}/fastjar
+ dodoc AUTHORS CHANGES COPYING ChangeLog* NEWS README
+ cd ${S}/libjava
+ docinto ${CCHOST}/libjava
+ dodoc ChangeLog* COPYING HACKING LIBGCJ_LICENSE NEWS README THANKS
+ fi
+
+ prepman ${DATAPATH}
+ prepinfo ${DATAPATH}
+ else
+ rm -rf ${D}/usr/share/{man,info}
+ rm -rf ${D}${DATAPATH}/{man,info}
+ fi
+
+ # Rather install the script, else portage with changing $FILESDIR
+ # between binary and source package borks things ....
+ insinto /lib/rcscripts/awk
+ doins ${FILESDIR}/awk/fixlafiles.awk
+ exeinto /sbin
+ doexe ${FILESDIR}/fix_libtool_files.sh
+
+ # Fix ncurses b0rking
+ find ${D}/ -name '*curses.h' -exec rm -f {} \;
+
+ if [ -n "`use multilib`" -a "${ARCH}" = "amd64" ]
+ then
+ # If using multilib, GCC has a bug, where it doesn't know where to find
+ # -lgcc_s when linking while compiling with g++ . ${LIBPATH} is in
+ # it's path though, so ln the 64bit and 32bit versions of -lgcc_s
+ # to that directory.
+ ln -sf ${LIBPATH}/../lib64/libgcc_s.so ${D}/${LIBPATH}/libgcc_s.so
+ ln -sf ${LIBPATH}/../lib32/libgcc_s_32.so ${D}/${LIBPATH}/libgcc_s_32.so
+ fi
+}
+
+pkg_preinst() {
+
+ if [ ! -f "${WORKDIR}/.chkgccversion" ]
+ then
+ chk_gcc_version
+ fi
+
+ # Make again sure that the linker "should" be able to locate
+ # libstdc++.so ...
+ if [ -n "`use multilib`" -a "${ARCH}" = "amd64" ]
+ then
+ # Can't always find libgcc_s.so.1, make it find it
+ export LD_LIBRARY_PATH="${LIBPATH}:${LIBPATH}/../lib64:${LIBPATH}/../lib32:${LD_LIBRARY_PATH}"
+ else
+ export LD_LIBRARY_PATH="${LIBPATH}:${LD_LIBRARY_PATH}"
+ fi
+ ${ROOT}/sbin/ldconfig
+}
+
+pkg_postinst() {
+
+ if [ -n "`use multilib`" -a "${ARCH}" = "amd64" ]
+ then
+ # Can't always find libgcc_s.so.1, make it find it
+ export LD_LIBRARY_PATH="${LIBPATH}:${LIBPATH}/../lib64:${LIBPATH}/../lib32:${LD_LIBRARY_PATH}"
+ else
+ export LD_LIBRARY_PATH="${LIBPATH}:${LD_LIBRARY_PATH}"
+ fi
+ if [ "${ROOT}" = "/" -a "${COMPILER}" = "gcc3" -a "${CHOST}" = "${CCHOST}" ]
+ then
+ gcc-config --use-portage-chost ${CCHOST}-${MY_PV_FULL}
+ fi
+
+ # Update libtool linker scripts to reference new gcc version ...
+ if [ "${ROOT}" = "/" ] && \
+ [ -f "${WORKDIR}/.oldgccversion" -o -f "${WORKDIR}/.oldgccchost" ]
+ then
+ local OLD_GCC_VERSION=
+ local OLD_GCC_CHOST=
+
+ if [ -f "${WORKDIR}/.oldgccversion" ] && \
+ [ -n "$(cat "${WORKDIR}/.oldgccversion")" ]
+ then
+ OLD_GCC_VERSION="$(cat "${WORKDIR}/.oldgccversion")"
+ else
+ OLD_GCC_VERSION="${MY_PV_FULL}"
+ fi
+
+ if [ -f "${WORKDIR}/.oldgccchost" ] && \
+ [ -n "$(cat "${WORKDIR}/.oldgccchost")" ]
+ then
+ OLD_GCC_CHOST="--oldarch $(cat "${WORKDIR}/.oldgccchost")"
+ fi
+
+ /sbin/fix_libtool_files.sh ${OLD_GCC_VERSION} ${OLD_GCC_CHOST}
+ fi
+
+ # Fix ncurses b0rking (if r5 isn't unmerged)
+ find ${ROOT}/usr/lib/gcc-lib -name '*curses.h' -exec rm -f {} \;
+
+ # http://dev.gentoo.org/~pappy/hardened-gcc/docs/etdyn-ssp.html
+ if has_version '>=sys-devel/hardened-gcc-1.2'
+ then
+ [ "${ROOT}" = "/" ] && hardened-gcc -A
+ fi
+}
+