summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-05-25 17:27:30 +0000
committerMike Frysinger <vapier@gentoo.org>2012-05-25 17:27:30 +0000
commit5a5f5b89343da34ffedbe526bc3992c8e3bd5269 (patch)
treef8dd28eb186de907fbd1cb84845507b3366f04e9 /sys-devel
parentInitial commit of this simple lib. Required for spatialite. (diff)
downloadgentoo-2-5a5f5b89343da34ffedbe526bc3992c8e3bd5269.tar.gz
gentoo-2-5a5f5b89343da34ffedbe526bc3992c8e3bd5269.tar.bz2
gentoo-2-5a5f5b89343da34ffedbe526bc3992c8e3bd5269.zip
Update x32 support.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog6
-rw-r--r--sys-devel/gcc/gcc-4.6.2.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.6.3.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.7.0.ebuild10
4 files changed, 14 insertions, 14 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 2ae1743b9d92..557402d22c3b 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.878 2012/05/22 05:07:54 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.879 2012/05/25 17:27:30 vapier Exp $
+
+ 25 May 2012; Mike Frysinger <vapier@gentoo.org> gcc-4.6.2.ebuild,
+ gcc-4.6.3.ebuild, gcc-4.7.0.ebuild:
+ Update x32 support.
22 May 2012; Ryan Hill <dirtyepic@gentoo.org> gcc-4.6.0.ebuild,
gcc-4.6.1-r1.ebuild, gcc-4.6.2.ebuild, gcc-4.6.3.ebuild:
diff --git a/sys-devel/gcc/gcc-4.6.2.ebuild b/sys-devel/gcc/gcc-4.6.2.ebuild
index 86a24191478e..d7341bfef39d 100644
--- a/sys-devel/gcc/gcc-4.6.2.ebuild
+++ b/sys-devel/gcc/gcc-4.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.6.2.ebuild,v 1.10 2012/05/22 05:07:54 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.6.2.ebuild,v 1.11 2012/05/25 17:27:30 vapier Exp $
PATCH_VER="1.4"
UCLIBC_VER="1.0"
@@ -42,9 +42,7 @@ src_unpack() {
fi
# drop the x32 stuff once 4.7 goes stable
- case ${CHOST} in
- x86_64*) has x32 $(get_all_abis) || EPATCH_EXCLUDE+=" 80_all_gcc-4.6-x32.patch" ;;
- esac
+ EPATCH_EXCLUDE+=" 80_all_gcc-4.6-x32.patch"
toolchain_src_unpack
diff --git a/sys-devel/gcc/gcc-4.6.3.ebuild b/sys-devel/gcc/gcc-4.6.3.ebuild
index 0a82f00a37c0..dc3e799868c5 100644
--- a/sys-devel/gcc/gcc-4.6.3.ebuild
+++ b/sys-devel/gcc/gcc-4.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.6.3.ebuild,v 1.4 2012/05/22 05:07:54 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.6.3.ebuild,v 1.5 2012/05/25 17:27:30 vapier Exp $
PATCH_VER="1.3"
UCLIBC_VER="1.0"
@@ -42,9 +42,7 @@ src_unpack() {
fi
# drop the x32 stuff once 4.7 goes stable
- case ${CHOST} in
- x86_64*) has x32 $(get_all_abis) || EPATCH_EXCLUDE+=" 80_all_gcc-4.6-x32.patch" ;;
- esac
+ EPATCH_EXCLUDE+=" 80_all_gcc-4.6-x32.patch"
toolchain_src_unpack
diff --git a/sys-devel/gcc/gcc-4.7.0.ebuild b/sys-devel/gcc/gcc-4.7.0.ebuild
index 1644bd5642c1..18a672cc39ca 100644
--- a/sys-devel/gcc/gcc-4.7.0.ebuild
+++ b/sys-devel/gcc/gcc-4.7.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.7.0.ebuild,v 1.1 2012/05/22 04:46:22 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.7.0.ebuild,v 1.2 2012/05/25 17:27:30 vapier Exp $
-PATCH_VER="1.0"
+PATCH_VER="1.1"
UCLIBC_VER="1.0"
# Hardened gcc 4 stuff
@@ -42,9 +42,9 @@ src_unpack() {
fi
# drop the x32 stuff once 4.7 goes stable
- case ${CHOST} in
- x86_64*) has x32 $(get_all_abis) || EPATCH_EXCLUDE+=" 80_all_gcc-4.6-x32.patch" ;;
- esac
+ if [[ ${CTARGET} != x86_64* ]] || ! has x32 $(get_all_abis) ; then
+ EPATCH_EXCLUDE+=" 90_all_gcc-4.7-x32.patch"
+ fi
toolchain_src_unpack