summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-07-03 18:57:51 +0000
committerMike Frysinger <vapier@gentoo.org>2006-07-03 18:57:51 +0000
commit6327030d7d469b6e2b266953e006b2074a33717b (patch)
treefe63f3be99430c017e43aaed4dbaea1f0440a05a /sys-devel
parentold (diff)
downloadgentoo-2-6327030d7d469b6e2b266953e006b2074a33717b.tar.gz
gentoo-2-6327030d7d469b6e2b266953e006b2074a33717b.tar.bz2
gentoo-2-6327030d7d469b6e2b266953e006b2074a33717b.zip
Push out accumulated fixes.
(Portage version: 2.1.1_pre2-r2)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc-config/ChangeLog8
-rw-r--r--sys-devel/gcc-config/files/digest-gcc-config-1.3.13-r31
-rwxr-xr-xsys-devel/gcc-config/files/gcc-config-1.3.1322
-rw-r--r--sys-devel/gcc-config/gcc-config-1.3.13-r3.ebuild51
4 files changed, 70 insertions, 12 deletions
diff --git a/sys-devel/gcc-config/ChangeLog b/sys-devel/gcc-config/ChangeLog
index 9321c28df08f..d3354a53055e 100644
--- a/sys-devel/gcc-config/ChangeLog
+++ b/sys-devel/gcc-config/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/gcc-config
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.129 2006/06/15 19:10:43 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.130 2006/07/03 18:57:51 vapier Exp $
+
+*gcc-config-1.3.13-r3 (03 Jul 2006)
+
+ 03 Jul 2006; Mike Frysinger <vapier@gentoo.org> files/gcc-config-1.3.13,
+ +gcc-config-1.3.13-r3.ebuild:
+ Push out accumulated fixes.
16 Jun 2006; Joshua Kinard <kumba@gentoo.org> gcc-config-2.0.0_rc1.ebuild:
De-keywording for now on mips. Will stay with gcc-config-1.3.x and see how
diff --git a/sys-devel/gcc-config/files/digest-gcc-config-1.3.13-r3 b/sys-devel/gcc-config/files/digest-gcc-config-1.3.13-r3
new file mode 100644
index 000000000000..8b137891791f
--- /dev/null
+++ b/sys-devel/gcc-config/files/digest-gcc-config-1.3.13-r3
@@ -0,0 +1 @@
+
diff --git a/sys-devel/gcc-config/files/gcc-config-1.3.13 b/sys-devel/gcc-config/files/gcc-config-1.3.13
index 3b56952da529..c014087f27ec 100755
--- a/sys-devel/gcc-config/files/gcc-config-1.3.13
+++ b/sys-devel/gcc-config/files/gcc-config-1.3.13
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.13,v 1.8 2006/06/19 20:10:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.13,v 1.9 2006/07/03 18:57:51 vapier Exp $
trap ":" INT QUIT TSTP
@@ -45,7 +45,7 @@ USAGE_END
find_path() {
[[ -z $1 ]] && return 0
- local fullpath="$(type -P $1)"
+ local fullpath=$(type -P $1)
if [[ -x ${fullpath} ]] ; then
echo "${fullpath}"
@@ -94,7 +94,7 @@ try_real_hard_to_find_CHOST() {
# newer portage supports spaces between the var and =
# CHOST = "this-is-retarded"
ret=$(eval $(
- ${SED} -n \
+ ${SED:-sed} -n \
-e 's:[[:space:]]::g' \
-e '/^CHOST=/p' \
"${conf}"
@@ -111,7 +111,7 @@ try_real_hard_to_find_CHOST() {
# Then we try /etc/env.d/gcc/config
#
if [[ -s ${ROOT}/etc/env.d/gcc/config ]] ; then
- ret=$(split_gcc_ver $(<"${ROOT}"/etc/env.d/gcc/config))
+ ret=$(split_gcc_ver $(eval $(<"${ROOT}"/etc/env.d/gcc/config) ; echo ${CURRENT}))
echo ${ret% *}
fi
}
@@ -174,7 +174,7 @@ switch_profile() {
# compilers for default CHOST will be used to compile stuff,
# and thus we want all their lib paths in /etc/ld.so.conf ...
get_real_chost
- GCC_PROFILES="$(${FIND} "${GCC_ENV_D}" -maxdepth 1 -name "${REAL_CHOST}-*" -a ! -name "${CC_COMP}")"
+ GCC_PROFILES=$(${FIND} "${GCC_ENV_D}" -maxdepth 1 -name "${REAL_CHOST}-*" -a ! -name "${CC_COMP}")
GCC_PROFILES="${GCC_ENV_D}/${CC_COMP} ${GCC_PROFILES}"
# Extract all LDPATH's for our CHOST
@@ -184,7 +184,7 @@ switch_profile() {
source "${x}"
# Handle LDPATH's that have multiple directories
- local old_IFS="${IFS}"
+ local old_IFS=${IFS}
export IFS=":"
local sub_ldpath=
for sub_ldpath in ${LDPATH} ; do
@@ -194,7 +194,7 @@ switch_profile() {
fi
fi
done
- export IFS="${old_IFS}"
+ export IFS=${old_IFS}
fi
done
MY_LDPATH="${MY_LDPATH:1}" # trim leading :
@@ -204,7 +204,7 @@ switch_profile() {
unset GCC_SPECS LDPATH
source "${GCC_ENV_D}/${CC_COMP}"
OLD_CC_COMP=$(get_current_profile)
- CTARGET="${CTARGET:-${REAL_CHOST}}"
+ CTARGET=${CTARGET:-${REAL_CHOST}}
# What kind of env.d entry are we going to generate ?
if is_cross_compiler ; then
@@ -242,7 +242,7 @@ switch_profile() {
fi
# Save PATH
- GCC_BIN_PATH="${PATH}"
+ GCC_BIN_PATH=${PATH}
# Fix environment
source /etc/profile
umask 022
@@ -418,7 +418,7 @@ list_profiles() {
}
print_environ() {
- local OLDPATH="${PATH}"
+ local OLDPATH=${PATH}
local ENV_CMD=
local SET_ELEMENT=
@@ -549,7 +549,7 @@ for x in "$@" ; do
# Only use specified compiler if one is not already selected.
-O|--use-old)
if get_current_profile &>/dev/null ; then
- CC_COMP="$(get_current_profile)"
+ CC_COMP=$(get_current_profile)
else
eerror "No profile selected, unable to utilize --use-old"
exit 1
diff --git a/sys-devel/gcc-config/gcc-config-1.3.13-r3.ebuild b/sys-devel/gcc-config/gcc-config-1.3.13-r3.ebuild
new file mode 100644
index 000000000000..dcfe872581c1
--- /dev/null
+++ b/sys-devel/gcc-config/gcc-config-1.3.13-r3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.13-r3.ebuild,v 1.1 2006/07/03 18:57:51 vapier Exp $
+
+inherit toolchain-funcs multilib
+
+# Version of .c wrapper to use
+W_VER="1.4.7"
+
+DESCRIPTION="Utility to change the gcc compiler being used"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}
+
+src_compile() {
+ $(tc-getCC) -O2 -Wall -o wrapper \
+ "${FILESDIR}"/wrapper-${W_VER}.c || die "compile wrapper"
+}
+
+src_install() {
+ newbin "${FILESDIR}"/${PN}-${PV} ${PN} || die "install gcc-config"
+ sed -i \
+ -e "s:PORTAGE-VERSION:${PVR}:g" \
+ -e "s:GENTOO_LIBDIR:$(get_libdir):g" \
+ "${D}"/usr/bin/${PN}
+
+ exeinto /usr/$(get_libdir)/misc
+ newexe wrapper gcc-config || die "install wrapper"
+}
+
+pkg_postinst() {
+ # Do we have a valid multi ver setup ?
+ if gcc-config --get-current-profile &>/dev/null ; then
+ # We not longer use the /usr/include/g++-v3 hacks, as
+ # it is not needed ...
+ [[ -L ${ROOT}/usr/include/g++ ]] && rm -f "${ROOT}"/usr/include/g++
+ [[ -L ${ROOT}/usr/include/g++-v3 ]] && rm -f "${ROOT}"/usr/include/g++-v3
+ [[ ${ROOT} = "/" ]] && gcc-config $(/usr/bin/gcc-config --get-current-profile)
+ fi
+
+ # Make sure old versions dont exist #79062
+ rm -f "${ROOT}"/usr/sbin/gcc-config
+}