summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-06-15 06:38:50 +0000
committerNed Ludd <solar@gentoo.org>2004-06-15 06:38:50 +0000
commit82a0175894da3df1af3e417df4262b39fba95e97 (patch)
tree732c4f2c0ed05740ce89abab44ea02beb545f155 /sys-devel
parentremove dep of bc when uclibc is used (Manifest recommit) (diff)
downloadgentoo-2-82a0175894da3df1af3e417df4262b39fba95e97.tar.gz
gentoo-2-82a0175894da3df1af3e417df4262b39fba95e97.tar.bz2
gentoo-2-82a0175894da3df1af3e417df4262b39fba95e97.zip
add uclibc to the list of things gnuconfig_update is run on
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/make/ChangeLog5
-rw-r--r--sys-devel/make/make-3.80.ebuild8
2 files changed, 8 insertions, 5 deletions
diff --git a/sys-devel/make/ChangeLog b/sys-devel/make/ChangeLog
index 36417c79afd5..a3137c0455a0 100644
--- a/sys-devel/make/ChangeLog
+++ b/sys-devel/make/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/make
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/make/ChangeLog,v 1.15 2004/04/10 07:12:49 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/make/ChangeLog,v 1.16 2004/06/15 06:38:50 solar Exp $
+
+ 15 Jun 2004; <solar@gentoo.org> make-3.80.ebuild:
+ add uclibc to the list of things gnuconfig_update is run on
10 Apr 2004; Joshua Kinard <kumba@gentoo.org> make-3.79.1-r5.ebuild:
Marked stable on mips, and added gnuconfig for mips64 hosts.
diff --git a/sys-devel/make/make-3.80.ebuild b/sys-devel/make/make-3.80.ebuild
index 08288276da54..9265175b8538 100644
--- a/sys-devel/make/make-3.80.ebuild
+++ b/sys-devel/make/make-3.80.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/make/make-3.80.ebuild,v 1.16 2004/04/28 05:17:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/make/make-3.80.ebuild,v 1.17 2004/06/15 06:38:50 solar Exp $
inherit gnuconfig
@@ -11,15 +11,15 @@ SRC_URI="ftp://ftp.gnu.org/gnu/make/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 ppc64 s390"
-IUSE="nls static build"
+IUSE="nls static build uclibc"
DEPEND="virtual/glibc
nls? ( sys-devel/gettext )"
RDEPEND="virtual/glibc"
src_compile() {
- # Detect mips systems properly
- use mips && gnuconfig_update
+ # Detect mips and uclibc systems properly
+ ( use mips || use uclibc ) && gnuconfig_update
local myconf=""
use nls || myconf="--disable-nls"