summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2012-06-22 13:36:45 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2012-06-22 13:36:45 +0000
commit84dadd8f8c6d39ba32dd2822a4ce753b22712595 (patch)
treeb65bd634116a2ed6324b3f980bb3d687c8e68ed4 /sys-devel
parentChange USE=ass to USE=libass to be consistent with other usages of it in the ... (diff)
downloadgentoo-2-84dadd8f8c6d39ba32dd2822a4ce753b22712595.tar.gz
gentoo-2-84dadd8f8c6d39ba32dd2822a4ce753b22712595.tar.bz2
gentoo-2-84dadd8f8c6d39ba32dd2822a4ce753b22712595.zip
Convert patch from DOS to Unix format, to prevent bugs like #422725
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang/ChangeLog6
-rw-r--r--sys-devel/clang/files/clang-3.1-increase-parser-recursion-limit.patch30
2 files changed, 20 insertions, 16 deletions
diff --git a/sys-devel/clang/ChangeLog b/sys-devel/clang/ChangeLog
index 3f330c33ba8c..e24fccbe161a 100644
--- a/sys-devel/clang/ChangeLog
+++ b/sys-devel/clang/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/clang
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.72 2012/06/12 17:49:22 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.73 2012/06/22 13:36:45 voyageur Exp $
+
+ 22 Jun 2012; Bernard Cafarelli <voyageur@gentoo.org>
+ files/clang-3.1-increase-parser-recursion-limit.patch:
+ Convert patch from DOS to Unix format, to prevent bugs like #422725
12 Jun 2012; Fabian Groffen <grobian@gentoo.org> clang-3.1-r4.ebuild:
Marked ~x64-macos
diff --git a/sys-devel/clang/files/clang-3.1-increase-parser-recursion-limit.patch b/sys-devel/clang/files/clang-3.1-increase-parser-recursion-limit.patch
index 91606d1ca724..79f4f9f07871 100644
--- a/sys-devel/clang/files/clang-3.1-increase-parser-recursion-limit.patch
+++ b/sys-devel/clang/files/clang-3.1-increase-parser-recursion-limit.patch
@@ -1,15 +1,15 @@
-Backported from r155737.
-
-diff --git a/llvm-3.1.src/tools/clang/include/clang/Parse/Parser.h b/llvm-3.1.src/tools/clang/include/clang/Parse/Parser.h
-index 0ae5dc8..2a7464f 100644
---- a/llvm-3.1.src/tools/clang/include/clang/Parse/Parser.h
-+++ b/llvm-3.1.src/tools/clang/include/clang/Parse/Parser.h
-@@ -451,7 +451,7 @@ private:
- }
- }
-
-- enum { MaxDepth = 256 };
-+ enum { MaxDepth = 512 };
-
- bool diagnoseOverflow();
- bool diagnoseMissingClose();
+Backported from r155737.
+
+diff --git a/llvm-3.1.src/tools/clang/include/clang/Parse/Parser.h b/llvm-3.1.src/tools/clang/include/clang/Parse/Parser.h
+index 0ae5dc8..2a7464f 100644
+--- a/llvm-3.1.src/tools/clang/include/clang/Parse/Parser.h
++++ b/llvm-3.1.src/tools/clang/include/clang/Parse/Parser.h
+@@ -451,7 +451,7 @@ private:
+ }
+ }
+
+- enum { MaxDepth = 256 };
++ enum { MaxDepth = 512 };
+
+ bool diagnoseOverflow();
+ bool diagnoseMissingClose();