summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-10 04:10:38 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-10 04:10:38 +0000
commit8886f52a7f2ced15e326eb81dcec5070732d1a28 (patch)
tree4695213f4d2640601fc1eefd47c157387f969b73 /sys-devel
parentAdd patch from upstream cvs to fix some hangs #98156 by Scott Jones. (diff)
downloadgentoo-2-8886f52a7f2ced15e326eb81dcec5070732d1a28.tar.gz
gentoo-2-8886f52a7f2ced15e326eb81dcec5070732d1a28.tar.bz2
gentoo-2-8886f52a7f2ced15e326eb81dcec5070732d1a28.zip
Dont apply spec-env patch to cross-compilers otherwise native hardened users can screw up their cross-compilers real quick #96162 by Kevin F. Quinn.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog9
-rw-r--r--sys-devel/gcc/gcc-3.3.5-r1.ebuild4
-rw-r--r--sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild4
-rw-r--r--sys-devel/gcc/gcc-3.3.5.20050130-r2.ebuild4
-rw-r--r--sys-devel/gcc/gcc-3.3.6.ebuild4
-rw-r--r--sys-devel/gcc/gcc-3.4.3-r1.ebuild4
-rw-r--r--sys-devel/gcc/gcc-3.4.3.20050110-r2.ebuild4
-rw-r--r--sys-devel/gcc/gcc-3.4.4.ebuild4
8 files changed, 22 insertions, 15 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index cb5f65a21827..6c888c71b020 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.433 2005/07/10 00:24:39 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.434 2005/07/10 04:10:38 vapier Exp $
+
+ 10 Jul 2005; Mike Frysinger <vapier@gentoo.org> gcc-3.3.5-r1.ebuild,
+ gcc-3.3.5.20050130-r1.ebuild, gcc-3.3.5.20050130-r2.ebuild,
+ gcc-3.3.6.ebuild, gcc-3.4.3-r1.ebuild, gcc-3.4.3.20050110-r2.ebuild,
+ gcc-3.4.4.ebuild:
+ Dont apply spec-env patch to cross-compilers otherwise native hardened users
+ can screw up their cross-compilers real quick #96162 by Kevin F. Quinn.
*gcc-4.1.0_beta20050709 (10 Jul 2005)
diff --git a/sys-devel/gcc/gcc-3.3.5-r1.ebuild b/sys-devel/gcc/gcc-3.3.5-r1.ebuild
index ef51d49fb8ec..b0e250aff9d4 100644
--- a/sys-devel/gcc/gcc-3.3.5-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.3.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.5-r1.ebuild,v 1.25 2005/06/10 01:29:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.5-r1.ebuild,v 1.26 2005/07/10 04:10:38 vapier Exp $
MAN_VER="3.3.5"
#BRANCH_UPDATE="20041025"
@@ -84,7 +84,7 @@ src_unpack() {
fi
# misc patches that havent made it into a patch tarball yet
- epatch ${FILESDIR}/gcc-spec-env.patch
+ [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
# fix an incorrect prototype of ffecom_gfrt_basictype() which causes
# 3.3.5 to not compile on some configurations.
diff --git a/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild b/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild
index b0c616fb2b54..5db8fe5a0a31 100644
--- a/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild,v 1.9 2005/06/10 01:29:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild,v 1.10 2005/07/10 04:10:38 vapier Exp $
MAN_VER="3.3.5"
PATCH_VER="1.4"
@@ -82,7 +82,7 @@ src_unpack() {
fi
# misc patches that havent made it into a patch tarball yet
- epatch ${FILESDIR}/gcc-spec-env.patch
+ [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
# Anything useful and objc will require libffi. Seriously. Lets just force
# libffi to install with USE="objc", even though it normally only installs
diff --git a/sys-devel/gcc/gcc-3.3.5.20050130-r2.ebuild b/sys-devel/gcc/gcc-3.3.5.20050130-r2.ebuild
index bd8a9577cf4a..bde405fc9520 100644
--- a/sys-devel/gcc/gcc-3.3.5.20050130-r2.ebuild
+++ b/sys-devel/gcc/gcc-3.3.5.20050130-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.5.20050130-r2.ebuild,v 1.4 2005/06/10 01:29:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.5.20050130-r2.ebuild,v 1.5 2005/07/10 04:10:38 vapier Exp $
MAN_VER="3.3.5"
PATCH_VER="1.5"
@@ -82,7 +82,7 @@ src_unpack() {
fi
# misc patches that havent made it into a patch tarball yet
- epatch ${FILESDIR}/gcc-spec-env.patch
+ [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
# Anything useful and objc will require libffi. Seriously. Lets just force
# libffi to install with USE="objc", even though it normally only installs
diff --git a/sys-devel/gcc/gcc-3.3.6.ebuild b/sys-devel/gcc/gcc-3.3.6.ebuild
index 79090858f070..72d90d12dd24 100644
--- a/sys-devel/gcc/gcc-3.3.6.ebuild
+++ b/sys-devel/gcc/gcc-3.3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.6.ebuild,v 1.10 2005/06/13 14:31:14 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.6.ebuild,v 1.11 2005/07/10 04:10:38 vapier Exp $
MAN_VER=""
PATCH_VER="1.2"
@@ -75,7 +75,7 @@ src_unpack() {
fi
# misc patches that havent made it into a patch tarball yet
- epatch "${FILESDIR}"/gcc-spec-env.patch
+ [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
# Anything useful and objc will require libffi. Seriously. Lets just force
# libffi to install with USE="objc", even though it normally only installs
diff --git a/sys-devel/gcc/gcc-3.4.3-r1.ebuild b/sys-devel/gcc/gcc-3.4.3-r1.ebuild
index 36fa5e703d87..516d7900ef76 100644
--- a/sys-devel/gcc/gcc-3.4.3-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.4.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.3-r1.ebuild,v 1.39 2005/06/24 01:16:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.3-r1.ebuild,v 1.40 2005/07/10 04:10:38 vapier Exp $
MAN_VER="3.4.3"
BRANCH_UPDATE="20041125"
@@ -84,8 +84,8 @@ src_unpack() {
sed -e 's/3\.4\.4/3.4.3/' -i ${S}/gcc/version.c
# misc patches that havent made it into a patch tarball yet
+ [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
epatch ${FILESDIR}/3.4.0/gcc34-reiser4-fix.patch
- epatch ${FILESDIR}/gcc-spec-env.patch
epatch ${FILESDIR}/3.4.2/810-arm-bigendian-uclibc.patch
# nothing in the tree provides libssp.so, so nothing will ever trigger this
diff --git a/sys-devel/gcc/gcc-3.4.3.20050110-r2.ebuild b/sys-devel/gcc/gcc-3.4.3.20050110-r2.ebuild
index a540bf771f09..0b62b139054a 100644
--- a/sys-devel/gcc/gcc-3.4.3.20050110-r2.ebuild
+++ b/sys-devel/gcc/gcc-3.4.3.20050110-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.3.20050110-r2.ebuild,v 1.7 2005/07/06 05:39:39 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.3.20050110-r2.ebuild,v 1.8 2005/07/10 04:10:38 vapier Exp $
MAN_VER="3.4.3"
PATCH_VER="1.3"
@@ -79,7 +79,7 @@ src_unpack() {
sed -e 's/3\.4\.4/3.4.3/' -i ${S}/gcc/version.c
# misc patches that havent made it into a patch tarball yet
- epatch ${FILESDIR}/gcc-spec-env.patch
+ [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
# nothing in the tree provides libssp.so, so nothing will ever trigger this
# logic, but having the patch in the tree makes life so much easier for me
diff --git a/sys-devel/gcc/gcc-3.4.4.ebuild b/sys-devel/gcc/gcc-3.4.4.ebuild
index 8a0281256c94..88672b87d98b 100644
--- a/sys-devel/gcc/gcc-3.4.4.ebuild
+++ b/sys-devel/gcc/gcc-3.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.4.ebuild,v 1.18 2005/07/10 01:36:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.4.ebuild,v 1.19 2005/07/10 04:10:38 vapier Exp $
MAN_VER=""
PATCH_VER="1.2"
@@ -76,7 +76,7 @@ src_unpack() {
gcc_src_unpack
# misc patches that havent made it into a patch tarball yet
- epatch "${FILESDIR}"/gcc-spec-env.patch
+ [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
# nothing in the tree provides libssp.so, so nothing will ever trigger this
# logic, but having the patch in the tree makes life so much easier for me