summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Coie <rac@gentoo.org>2004-09-22 18:00:12 +0000
committerRobert Coie <rac@gentoo.org>2004-09-22 18:00:12 +0000
commit8d227590a6cf3f44e17834424f9f77484f2bdf0b (patch)
tree0b2c7eee274cfc78964d1474fa0c7521a5c95348 /sys-devel
parentStable amd64, sparc. (Manifest recommit) (diff)
downloadgentoo-2-8d227590a6cf3f44e17834424f9f77484f2bdf0b.tar.gz
gentoo-2-8d227590a6cf3f44e17834424f9f77484f2bdf0b.tar.bz2
gentoo-2-8d227590a6cf3f44e17834424f9f77484f2bdf0b.zip
USE threads -> ithreads
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/libperl/ChangeLog7
-rw-r--r--sys-devel/libperl/libperl-5.8.2-r1.ebuild16
-rw-r--r--sys-devel/libperl/libperl-5.8.2.ebuild16
-rw-r--r--sys-devel/libperl/libperl-5.8.3.ebuild16
-rw-r--r--sys-devel/libperl/libperl-5.8.4-r1.ebuild16
-rw-r--r--sys-devel/libperl/libperl-5.8.4.ebuild16
-rw-r--r--sys-devel/libperl/libperl-5.8.5.ebuild16
7 files changed, 54 insertions, 49 deletions
diff --git a/sys-devel/libperl/ChangeLog b/sys-devel/libperl/ChangeLog
index e1f2223d0e79..9923f7fe4d45 100644
--- a/sys-devel/libperl/ChangeLog
+++ b/sys-devel/libperl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/libperl
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/ChangeLog,v 1.47 2004/09/22 17:40:02 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/ChangeLog,v 1.48 2004/09/22 18:00:12 rac Exp $
+
+ 22 Sep 2004; Robert Coie <rac@gentoo.org> libperl-5.8.2-r1.ebuild,
+ libperl-5.8.2.ebuild, libperl-5.8.3.ebuild, libperl-5.8.4-r1.ebuild,
+ libperl-5.8.4.ebuild, libperl-5.8.5.ebuild:
+ USE threads -> ithreads cleanup
*libperl-5.8.5-r1 (22 Sep 2004)
diff --git a/sys-devel/libperl/libperl-5.8.2-r1.ebuild b/sys-devel/libperl/libperl-5.8.2-r1.ebuild
index 4a2ecebb02b1..31c2d81f643b 100644
--- a/sys-devel/libperl/libperl-5.8.2-r1.ebuild
+++ b/sys-devel/libperl/libperl-5.8.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.2-r1.ebuild,v 1.6 2004/09/06 20:45:30 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.2-r1.ebuild,v 1.7 2004/09/22 18:00:12 rac Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -52,7 +52,7 @@
#
# Martin Schlemmer <azarah@gentoo.org> (28 Dec 2002).
-IUSE="berkdb gdbm threads uclibc"
+IUSE="berkdb gdbm ithreads uclibc"
inherit eutils flag-o-matic
@@ -96,13 +96,13 @@ RDEPEND="
PDEPEND=">=dev-lang/perl-${PV}"
pkg_setup() {
- # I think this should rather be displayed if you *have* 'threads'
+ # I think this should rather be displayed if you *have* 'ithreads'
# in USE if it could break things ...
- if use threads
+ if use ithreads
then
ewarn ""
ewarn "PLEASE NOTE: You are compiling perl-5.8 with"
- ewarn "threading enabled."
+ ewarn "interpreter-level threading enabled."
ewarn "Threading is not supported by all applications "
ewarn "that compile against perl. You use threading at "
ewarn "your own discretion. "
@@ -112,7 +112,7 @@ pkg_setup() {
ewarn ""
ewarn "PLEASE NOTE: If you want to compile perl-5.8 with"
ewarn "threading enabled , you must restart this emerge"
- ewarn "with USE=threads emerge...."
+ ewarn "with USE=ithreads emerge...."
ewarn "Threading is not supported by all applications "
ewarn "that compile against perl. You use threading at "
ewarn "your own discretion. "
@@ -145,9 +145,9 @@ src_compile() {
export LC_ALL="C"
local myconf=""
- if use threads
+ if use ithreads
then
- einfo "using threads"
+ einfo "using ithreads"
mythreading="-multi"
myconf="-Dusethreads ${myconf}"
myarch="${CHOST%%-*}-linux-thread"
diff --git a/sys-devel/libperl/libperl-5.8.2.ebuild b/sys-devel/libperl/libperl-5.8.2.ebuild
index c3616ebed75e..6babf1e53a13 100644
--- a/sys-devel/libperl/libperl-5.8.2.ebuild
+++ b/sys-devel/libperl/libperl-5.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.2.ebuild,v 1.17 2004/09/06 20:45:30 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.2.ebuild,v 1.18 2004/09/22 18:00:12 rac Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -52,7 +52,7 @@
#
# Martin Schlemmer <azarah@gentoo.org> (28 Dec 2002).
-IUSE="berkdb gdbm threads"
+IUSE="berkdb gdbm ithreads"
inherit eutils flag-o-matic
@@ -96,13 +96,13 @@ RDEPEND="
PDEPEND=">=dev-lang/perl-${PV}"
pkg_setup() {
- # I think this should rather be displayed if you *have* 'threads'
+ # I think this should rather be displayed if you *have* 'ithreads'
# in USE if it could break things ...
- if use threads
+ if use ithreads
then
ewarn ""
ewarn "PLEASE NOTE: You are compiling perl-5.8 with"
- ewarn "threading enabled."
+ ewarn "interpreter-level threading enabled."
ewarn "Threading is not supported by all applications "
ewarn "that compile against perl. You use threading at "
ewarn "your own discretion. "
@@ -112,7 +112,7 @@ pkg_setup() {
ewarn ""
ewarn "PLEASE NOTE: If you want to compile perl-5.8 with"
ewarn "threading enabled , you must restart this emerge"
- ewarn "with USE=threads emerge...."
+ ewarn "with USE=ithreads emerge...."
ewarn "Threading is not supported by all applications "
ewarn "that compile against perl. You use threading at "
ewarn "your own discretion. "
@@ -142,9 +142,9 @@ src_compile() {
export LC_ALL="C"
local myconf=""
- if use threads
+ if use ithreads
then
- einfo "using threads"
+ einfo "using ithreads"
mythreading="-multi"
myconf="-Dusethreads ${myconf}"
myarch="${CHOST%%-*}-linux-thread"
diff --git a/sys-devel/libperl/libperl-5.8.3.ebuild b/sys-devel/libperl/libperl-5.8.3.ebuild
index 52073954fe9d..98eed889d4dd 100644
--- a/sys-devel/libperl/libperl-5.8.3.ebuild
+++ b/sys-devel/libperl/libperl-5.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.3.ebuild,v 1.11 2004/09/06 20:45:30 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.3.ebuild,v 1.12 2004/09/22 18:00:12 rac Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -52,7 +52,7 @@
#
# Martin Schlemmer <azarah@gentoo.org> (28 Dec 2002).
-IUSE="berkdb gdbm threads"
+IUSE="berkdb gdbm ithreads"
inherit eutils flag-o-matic
@@ -96,13 +96,13 @@ RDEPEND="
PDEPEND=">=dev-lang/perl-${PV}"
pkg_setup() {
- # I think this should rather be displayed if you *have* 'threads'
+ # I think this should rather be displayed if you *have* 'ithreads'
# in USE if it could break things ...
- if use threads
+ if use ithreads
then
ewarn ""
ewarn "PLEASE NOTE: You are compiling perl-5.8 with"
- ewarn "threading enabled."
+ ewarn "interpreter-level threading enabled."
ewarn "Threading is not supported by all applications "
ewarn "that compile against perl. You use threading at "
ewarn "your own discretion. "
@@ -112,7 +112,7 @@ pkg_setup() {
ewarn ""
ewarn "PLEASE NOTE: If you want to compile perl-5.8 with"
ewarn "threading enabled , you must restart this emerge"
- ewarn "with USE=threads emerge...."
+ ewarn "with USE=ithreads emerge...."
ewarn "Threading is not supported by all applications "
ewarn "that compile against perl. You use threading at "
ewarn "your own discretion. "
@@ -142,9 +142,9 @@ src_compile() {
export LC_ALL="C"
local myconf=""
- if use threads
+ if use ithreads
then
- einfo "using threads"
+ einfo "using ithreads"
mythreading="-multi"
myconf="-Dusethreads ${myconf}"
myarch="${CHOST%%-*}-linux-thread"
diff --git a/sys-devel/libperl/libperl-5.8.4-r1.ebuild b/sys-devel/libperl/libperl-5.8.4-r1.ebuild
index b91fbae1b1c6..6fd4063c1f5e 100644
--- a/sys-devel/libperl/libperl-5.8.4-r1.ebuild
+++ b/sys-devel/libperl/libperl-5.8.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.4-r1.ebuild,v 1.11 2004/09/09 18:42:54 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.4-r1.ebuild,v 1.12 2004/09/22 18:00:12 rac Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -52,7 +52,7 @@
#
# Martin Schlemmer <azarah@gentoo.org> (28 Dec 2002).
-IUSE="berkdb gdbm threads uclibc"
+IUSE="berkdb gdbm ithreads uclibc"
inherit eutils flag-o-matic
@@ -97,13 +97,13 @@ PDEPEND=">=dev-lang/perl-${PV}"
pkg_setup() {
- # I think this should rather be displayed if you *have* 'threads'
+ # I think this should rather be displayed if you *have* 'ithreads'
# in USE if it could break things ...
- if use threads
+ if use ithreads
then
ewarn ""
ewarn "PLEASE NOTE: You are compiling perl-5.8 with"
- ewarn "threading enabled."
+ ewarn "interpreter-level threading enabled."
ewarn "Threading is not supported by all applications "
ewarn "that compile against perl. You use threading at "
ewarn "your own discretion. "
@@ -113,7 +113,7 @@ pkg_setup() {
ewarn ""
ewarn "PLEASE NOTE: If you want to compile perl-5.8 with"
ewarn "threading enabled , you must restart this emerge"
- ewarn "with USE=threads emerge...."
+ ewarn "with USE=ithreads emerge...."
ewarn "Threading is not supported by all applications "
ewarn "that compile against perl. You use threading at "
ewarn "your own discretion. "
@@ -153,9 +153,9 @@ src_compile() {
export LC_ALL="C"
local myconf=""
- if use threads
+ if use ithreads
then
- einfo "using threads"
+ einfo "using ithreads"
mythreading="-multi"
myconf="-Dusethreads ${myconf}"
myarch="${CHOST%%-*}-linux-thread"
diff --git a/sys-devel/libperl/libperl-5.8.4.ebuild b/sys-devel/libperl/libperl-5.8.4.ebuild
index dade2661a3c1..3b33bf3c3cef 100644
--- a/sys-devel/libperl/libperl-5.8.4.ebuild
+++ b/sys-devel/libperl/libperl-5.8.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.4.ebuild,v 1.14 2004/09/06 20:45:30 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.4.ebuild,v 1.15 2004/09/22 18:00:12 rac Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -53,7 +53,7 @@
# Martin Schlemmer <azarah@gentoo.org> (28 Dec 2002).
# fix manifest
-IUSE="berkdb gdbm threads"
+IUSE="berkdb gdbm ithreads"
inherit eutils flag-o-matic
@@ -97,13 +97,13 @@ RDEPEND="
PDEPEND=">=dev-lang/perl-${PV}"
pkg_setup() {
- # I think this should rather be displayed if you *have* 'threads'
+ # I think this should rather be displayed if you *have* 'ithreads'
# in USE if it could break things ...
- if use threads
+ if use ithreads
then
ewarn ""
ewarn "PLEASE NOTE: You are compiling perl-5.8 with"
- ewarn "threading enabled."
+ ewarn "intepreter-level threading enabled."
ewarn "Threading is not supported by all applications "
ewarn "that compile against perl. You use threading at "
ewarn "your own discretion. "
@@ -113,7 +113,7 @@ pkg_setup() {
ewarn ""
ewarn "PLEASE NOTE: If you want to compile perl-5.8 with"
ewarn "threading enabled , you must restart this emerge"
- ewarn "with USE=threads emerge...."
+ ewarn "with USE=ithreads emerge...."
ewarn "Threading is not supported by all applications "
ewarn "that compile against perl. You use threading at "
ewarn "your own discretion. "
@@ -149,9 +149,9 @@ src_compile() {
export LC_ALL="C"
local myconf=""
- if use threads
+ if use ithreads
then
- einfo "using threads"
+ einfo "using ithreads"
mythreading="-multi"
myconf="-Dusethreads ${myconf}"
myarch="${CHOST%%-*}-linux-thread"
diff --git a/sys-devel/libperl/libperl-5.8.5.ebuild b/sys-devel/libperl/libperl-5.8.5.ebuild
index ed2aa9b7e827..5786bb3b3894 100644
--- a/sys-devel/libperl/libperl-5.8.5.ebuild
+++ b/sys-devel/libperl/libperl-5.8.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.5.ebuild,v 1.3 2004/09/06 20:45:30 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.5.ebuild,v 1.4 2004/09/22 18:00:12 rac Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -52,7 +52,7 @@
#
# Martin Schlemmer <azarah@gentoo.org> (28 Dec 2002).
-IUSE="berkdb gdbm threads uclibc"
+IUSE="berkdb gdbm ithreads uclibc"
inherit eutils flag-o-matic
@@ -97,13 +97,13 @@ RDEPEND="
PDEPEND=">=dev-lang/perl-${PV}"
pkg_setup() {
- # I think this should rather be displayed if you *have* 'threads'
+ # I think this should rather be displayed if you *have* 'ithreads'
# in USE if it could break things ...
- if use threads
+ if use ithreads
then
ewarn ""
ewarn "PLEASE NOTE: You are compiling perl-5.8 with"
- ewarn "threading enabled."
+ ewarn "interpreter-level threading enabled."
ewarn "Threading is not supported by all applications "
ewarn "that compile against perl. You use threading at "
ewarn "your own discretion. "
@@ -113,7 +113,7 @@ pkg_setup() {
ewarn ""
ewarn "PLEASE NOTE: If you want to compile perl-5.8 with"
ewarn "threading enabled , you must restart this emerge"
- ewarn "with USE=threads emerge...."
+ ewarn "with USE=ithreads emerge...."
ewarn "Threading is not supported by all applications "
ewarn "that compile against perl. You use threading at "
ewarn "your own discretion. "
@@ -153,9 +153,9 @@ src_compile() {
export LC_ALL="C"
local myconf=""
- if use threads
+ if use ithreads
then
- einfo "using threads"
+ einfo "using ithreads"
mythreading="-multi"
myconf="-Dusethreads ${myconf}"
myarch="${CHOST%%-*}-linux-thread"