summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Coie <rac@gentoo.org>2004-06-09 20:20:34 +0000
committerRobert Coie <rac@gentoo.org>2004-06-09 20:20:34 +0000
commit905bac5777ed9acc4d31f229cbf1d6122740aeed (patch)
tree7f0a5c00f00f99e38dc0577ffd47345e44d6dd61 /sys-devel
parentadded metadata.xml (Manifest recommit) (diff)
downloadgentoo-2-905bac5777ed9acc4d31f229cbf1d6122740aeed.tar.gz
gentoo-2-905bac5777ed9acc4d31f229cbf1d6122740aeed.tar.bz2
gentoo-2-905bac5777ed9acc4d31f229cbf1d6122740aeed.zip
bug 42665
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/libperl/ChangeLog6
-rw-r--r--sys-devel/libperl/files/libperl-5.8.4-noksh.patch16
-rw-r--r--sys-devel/libperl/libperl-5.8.4.ebuild8
3 files changed, 28 insertions, 2 deletions
diff --git a/sys-devel/libperl/ChangeLog b/sys-devel/libperl/ChangeLog
index 77ea844d9dfa..beafdc7dda08 100644
--- a/sys-devel/libperl/ChangeLog
+++ b/sys-devel/libperl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/libperl
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/ChangeLog,v 1.29 2004/06/02 05:02:51 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/ChangeLog,v 1.30 2004/06/09 20:16:04 rac Exp $
+
+ 09 Jun 2004; Robert Coie <rac@gentoo.org> +files/libperl-5.8.4-noksh.patch,
+ libperl-5.8.4.ebuild:
+ Add noksh.patch, bug 42665
02 Jun 2004; Travis Tilley <lv@gentoo.org> libperl-5.8.4.ebuild:
stable on amd64
diff --git a/sys-devel/libperl/files/libperl-5.8.4-noksh.patch b/sys-devel/libperl/files/libperl-5.8.4-noksh.patch
new file mode 100644
index 000000000000..4c33b3e71b33
--- /dev/null
+++ b/sys-devel/libperl/files/libperl-5.8.4-noksh.patch
@@ -0,0 +1,16 @@
+diff -burN perl-5.8.4.orig/Configure perl-5.8.4/Configure
+--- perl-5.8.4.orig/Configure 2004-04-01 05:48:18.000000000 -0800
++++ perl-5.8.4/Configure 2004-06-09 12:02:54.694172368 -0700
+@@ -164,6 +164,12 @@
+ ;;
+ esac
+
++# 2004.06.09 rac
++# having $newsh persist as ksh here is bad news if ksh doesn't really
++# exist. this causes us to toss away a perfectly good working test in
++# bash in favour of more exotic external options. see bug 42665.
++test -x "${newsh}" || unset newsh
++
+ : if needed set CDPATH to a harmless value that is not chatty
+ : avoid bash 2.02 problems with empty CDPATH.
+ case "$CDPATH" in
diff --git a/sys-devel/libperl/libperl-5.8.4.ebuild b/sys-devel/libperl/libperl-5.8.4.ebuild
index c583aa77af53..300b78ab07a6 100644
--- a/sys-devel/libperl/libperl-5.8.4.ebuild
+++ b/sys-devel/libperl/libperl-5.8.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.4.ebuild,v 1.6 2004/06/07 16:50:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.4.ebuild,v 1.7 2004/06/09 20:16:04 rac Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -135,6 +135,12 @@ src_unpack() {
# LIBPERL=libperl.so.${SLOT}.`echo ${PV} | cut -d. -f1,2`
#
cd ${S}; epatch ${FILESDIR}/${P}-create-libperl-soname.patch
+
+ # Configure makes an unwarranted assumption that /bin/ksh is a
+ # good shell. This patch makes it revert to using /bin/sh unless
+ # /bin/ksh really is executable. Should fix bug 42665.
+ # rac 2004.06.09
+ cd ${S}; epatch ${FILESDIR}/${P}-noksh.patch
}
src_compile() {