summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-07-20 18:33:46 +0000
committerMike Frysinger <vapier@gentoo.org>2004-07-20 18:33:46 +0000
commit9bc3016ee77f0f0d41967152f725d45ffac85fdb (patch)
treeaf66d5ace6c44116ce88c512b9886ef21c7fcdcf /sys-devel
parentadd hardened to the list (diff)
downloadgentoo-2-9bc3016ee77f0f0d41967152f725d45ffac85fdb.tar.gz
gentoo-2-9bc3016ee77f0f0d41967152f725d45ffac85fdb.tar.bz2
gentoo-2-9bc3016ee77f0f0d41967152f725d45ffac85fdb.zip
clean up some ebuilds again (code out of global scope)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/gcc-2.95.3-r8.ebuild26
-rw-r--r--sys-devel/gcc/gcc-3.3.3-r3.ebuild49
-rw-r--r--sys-devel/gcc/gcc-3.3.3-r4.ebuild50
-rw-r--r--sys-devel/gcc/gcc-3.3.3-r5.ebuild49
-rw-r--r--sys-devel/gcc/gcc-3.3.3-r6.ebuild49
-rw-r--r--sys-devel/gcc/gcc-3.3.4-r1.ebuild49
-rw-r--r--sys-devel/gcc/gcc-3.3.4.ebuild49
7 files changed, 94 insertions, 227 deletions
diff --git a/sys-devel/gcc/gcc-2.95.3-r8.ebuild b/sys-devel/gcc/gcc-2.95.3-r8.ebuild
index 4443020e07c7..c7ac252c6af0 100644
--- a/sys-devel/gcc/gcc-2.95.3-r8.ebuild
+++ b/sys-devel/gcc/gcc-2.95.3-r8.ebuild
@@ -1,34 +1,16 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3-r8.ebuild,v 1.30 2004/07/02 09:32:02 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3-r8.ebuild,v 1.31 2004/07/20 18:33:46 vapier Exp $
inherit eutils flag-o-matic gcc
-# Recently there has been a lot of stability problem in Gentoo-land. Many
-# things can be the cause to this, but I believe that it is due to gcc3
-# still having issues with optimizations, or with it not filtering bad
-# combinations (protecting the user maybe from himeself) yet.
-#
-# This can clearly be seen in large builds like glibc, where too aggressive
-# CFLAGS cause the tests to fail miserbly.
-#
-# Quote from Nick Jones <carpaski@gentoo.org>, who in my opinion
-# knows what he is talking about:
-#
-# People really shouldn't force code-specific options on... It's a
-# bad idea. The -march options aren't just to look pretty. They enable
-# options that are sensible (and include sse,mmx,3dnow when apropriate).
-#
-# The next command strips CFLAGS and CXXFLAGS from nearly all flags. If
-# you do not like it, comment it, but do not bugreport if you run into
+# The next command strips most flags from CFLAGS/CXXFLAGS. If you do
+# not like it, comment it out, but do not file bugreports if you run into
# problems.
-#
-# <azarah@gentoo.org> (13 Oct 2002)
do_filter_flags() {
strip-flags
- # In general gcc does not like optimization, and add -O2 where
- # it is safe.
+ # In general gcc does not like optimization ... we'll add -O2 where safe
filter-flags -O?
# Compile problems with these (bug #6641 among others)...
diff --git a/sys-devel/gcc/gcc-3.3.3-r3.ebuild b/sys-devel/gcc/gcc-3.3.3-r3.ebuild
index da7af7a9a623..956ff6c21a37 100644
--- a/sys-devel/gcc/gcc-3.3.3-r3.ebuild
+++ b/sys-devel/gcc/gcc-3.3.3-r3.ebuild
@@ -1,35 +1,21 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.3-r3.ebuild,v 1.10 2004/07/02 09:32:03 eradicator Exp $
-
-IUSE="static nls bootstrap java build X multilib gcj f77 objc hardened uclibc"
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.3-r3.ebuild,v 1.11 2004/07/20 18:33:46 vapier Exp $
inherit eutils flag-o-matic libtool
-# Compile problems with these (bug #6641 among others)...
-#filter-flags "-fno-exceptions -fomit-frame-pointer -fforce-addr"
-
-# Recently there has been a lot of stability problem in Gentoo-land. Many
-# things can be the cause to this, but I believe that it is due to gcc3
-# still having issues with optimizations, or with it not filtering bad
-# combinations (protecting the user maybe from himeself) yet.
-#
-# This can clearly be seen in large builds like glibc, where too aggressive
-# CFLAGS cause the tests to fail miserbly.
-#
-# Quote from Nick Jones <carpaski@gentoo.org>, who in my opinion
-# knows what he is talking about:
-#
-# People really shouldn't force code-specific options on... It's a
-# bad idea. The -march options aren't just to look pretty. They enable
-# options that are sensible (and include sse,mmx,3dnow when apropriate).
-#
-# The next command strips CFLAGS and CXXFLAGS from nearly all flags. If
-# you do not like it, comment it, but do not bugreport if you run into
+# The next command strips most flags from CFLAGS/CXXFLAGS. If you do
+# not like it, comment it out, but do not file bugreports if you run into
# problems.
-#
-# <azarah@gentoo.org> (13 Oct 2002)
-strip-flags
+do_filter_flags() {
+ strip-flags
+
+ # In general gcc does not like optimization ... we'll add -O2 where safe
+ filter-flags -O?
+
+ # Compile problems with these (bug #6641 among others)...
+ #filter-flags -fno-exceptions -fomit-frame-pointer -fforce-addr
+}
# gcc produce unstable binaries if compiled with a different CHOST.
[ "${ARCH}" = "hppa" ] && export CHOST="hppa-unknown-linux-gnu"
@@ -110,6 +96,7 @@ HOMEPAGE="http://www.gnu.org/software/gcc/gcc.html"
LICENSE="GPL-2 LGPL-2.1"
KEYWORDS="~x86 ~sparc ~mips ~alpha arm -hppa ~amd64 ~ia64 ~ppc64 s390"
+IUSE="static nls bootstrap java build X multilib gcj f77 objc hardened uclibc"
# Ok, this is a hairy one again, but lets assume that we
# are not cross compiling, than we want SLOT to only contain
@@ -399,7 +386,6 @@ src_unpack() {
}
src_compile() {
-
local myconf=
local gcc_lang=
@@ -466,13 +452,8 @@ src_compile() {
myconf="${myconf} --disable-__cxa_atexit --enable-target-optspace --with-gnu-ld --enable-sjlj-exceptions"
fi
- # In general gcc does not like optimization, and add -O2 where
- export CFLAGS="$(echo "${CFLAGS}" | sed -e 's|-O[0-9s]\?|-O2|g')"
- einfo "CFLAGS=\"${CFLAGS}\""
- export CXXFLAGS="$(echo "${CXXFLAGS}" | sed -e 's|-O[0-9s]\?|-O2|g')"
- einfo "CXXFLAGS=\"${CXXFLAGS}\""
- export GCJFLAGS="$(echo "${GCJFLAGS}" | sed -e 's|-O[0-9s]\?|-O2|g')"
- einfo "GCJFLAGS=\"${GCJFLAGS}\""
+ # Make sure we have sane CFLAGS
+ do_filter_flags
# Build in a separate build tree
mkdir -p ${WORKDIR}/build
diff --git a/sys-devel/gcc/gcc-3.3.3-r4.ebuild b/sys-devel/gcc/gcc-3.3.3-r4.ebuild
index 9f8bdc904aca..69dc5fc1f39a 100644
--- a/sys-devel/gcc/gcc-3.3.3-r4.ebuild
+++ b/sys-devel/gcc/gcc-3.3.3-r4.ebuild
@@ -1,35 +1,21 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.3-r4.ebuild,v 1.11 2004/07/02 09:32:03 eradicator Exp $
-
-IUSE="static nls bootstrap java build X multilib gcj f77 objc hardened uclibc debug"
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.3-r4.ebuild,v 1.12 2004/07/20 18:33:46 vapier Exp $
inherit eutils flag-o-matic libtool
-# Compile problems with these (bug #6641 among others)...
-#filter-flags "-fno-exceptions -fomit-frame-pointer -fforce-addr"
-
-# Recently there has been a lot of stability problem in Gentoo-land. Many
-# things can be the cause to this, but I believe that it is due to gcc3
-# still having issues with optimizations, or with it not filtering bad
-# combinations (protecting the user maybe from himeself) yet.
-#
-# This can clearly be seen in large builds like glibc, where too aggressive
-# CFLAGS cause the tests to fail miserbly.
-#
-# Quote from Nick Jones <carpaski@gentoo.org>, who in my opinion
-# knows what he is talking about:
-#
-# People really shouldn't force code-specific options on... It's a
-# bad idea. The -march options aren't just to look pretty. They enable
-# options that are sensible (and include sse,mmx,3dnow when apropriate).
-#
-# The next command strips CFLAGS and CXXFLAGS from nearly all flags. If
-# you do not like it, comment it, but do not bugreport if you run into
+# The next command strips most flags from CFLAGS/CXXFLAGS. If you do
+# not like it, comment it out, but do not file bugreports if you run into
# problems.
-#
-# <azarah@gentoo.org> (13 Oct 2002)
-strip-flags
+do_filter_flags() {
+ strip-flags
+
+ # In general gcc does not like optimization ... we'll add -O2 where safe
+ filter-flags -O?
+
+ # Compile problems with these (bug #6641 among others)...
+ #filter-flags -fno-exceptions -fomit-frame-pointer -fforce-addr
+}
# gcc produce unstable binaries if compiled with a different CHOST.
[ "${ARCH}" = "hppa" ] && export CHOST="hppa-unknown-linux-gnu"
@@ -107,9 +93,9 @@ DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie a
HOMEPAGE="http://www.gnu.org/software/gcc/gcc.html"
LICENSE="GPL-2 LGPL-2.1"
-
#KEYWORDS="~x86 ~mips ~sparc ~amd64 -hppa ~alpha ~ia64 ~ppc64 ~s390"
KEYWORDS="-* arm"
+IUSE="static nls bootstrap java build X multilib gcj f77 objc hardened uclibc debug"
# Ok, this is a hairy one again, but lets assume that we
# are not cross compiling, than we want SLOT to only contain
@@ -422,7 +408,6 @@ src_unpack() {
}
src_compile() {
-
local myconf=
local gcc_lang=
@@ -489,13 +474,8 @@ src_compile() {
myconf="${myconf} --disable-__cxa_atexit --enable-target-optspace --with-gnu-ld --enable-sjlj-exceptions"
fi
- # In general gcc does not like optimization, and add -O2 where
- export CFLAGS="$(echo "${CFLAGS}" | sed -e 's|-O[0-9s]\?|-O2|g')"
- einfo "CFLAGS=\"${CFLAGS}\""
- export CXXFLAGS="$(echo "${CXXFLAGS}" | sed -e 's|-O[0-9s]\?|-O2|g')"
- einfo "CXXFLAGS=\"${CXXFLAGS}\""
- export GCJFLAGS="$(echo "${GCJFLAGS}" | sed -e 's|-O[0-9s]\?|-O2|g')"
- einfo "GCJFLAGS=\"${GCJFLAGS}\""
+ # Make sure we have sane CFLAGS
+ do_filter_flags
# Build in a separate build tree
mkdir -p ${WORKDIR}/build
diff --git a/sys-devel/gcc/gcc-3.3.3-r5.ebuild b/sys-devel/gcc/gcc-3.3.3-r5.ebuild
index 626f0d364834..504e447af747 100644
--- a/sys-devel/gcc/gcc-3.3.3-r5.ebuild
+++ b/sys-devel/gcc/gcc-3.3.3-r5.ebuild
@@ -1,35 +1,21 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.3-r5.ebuild,v 1.6 2004/07/02 09:32:03 eradicator Exp $
-
-IUSE="static nls bootstrap java build X multilib gcj f77 objc hardened uclibc debug"
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.3-r5.ebuild,v 1.7 2004/07/20 18:33:46 vapier Exp $
inherit eutils flag-o-matic libtool
-# Compile problems with these (bug #6641 among others)...
-#filter-flags "-fno-exceptions -fomit-frame-pointer -fforce-addr"
-
-# Recently there has been a lot of stability problem in Gentoo-land. Many
-# things can be the cause to this, but I believe that it is due to gcc3
-# still having issues with optimizations, or with it not filtering bad
-# combinations (protecting the user maybe from himeself) yet.
-#
-# This can clearly be seen in large builds like glibc, where too aggressive
-# CFLAGS cause the tests to fail miserbly.
-#
-# Quote from Nick Jones <carpaski@gentoo.org>, who in my opinion
-# knows what he is talking about:
-#
-# People really shouldn't force code-specific options on... It's a
-# bad idea. The -march options aren't just to look pretty. They enable
-# options that are sensible (and include sse,mmx,3dnow when apropriate).
-#
-# The next command strips CFLAGS and CXXFLAGS from nearly all flags. If
-# you do not like it, comment it, but do not bugreport if you run into
+# The next command strips most flags from CFLAGS/CXXFLAGS. If you do
+# not like it, comment it out, but do not file bugreports if you run into
# problems.
-#
-# <azarah@gentoo.org> (13 Oct 2002)
-strip-flags
+do_filter_flags() {
+ strip-flags
+
+ # In general gcc does not like optimization ... we'll add -O2 where safe
+ filter-flags -O?
+
+ # Compile problems with these (bug #6641 among others)...
+ #filter-flags -fno-exceptions -fomit-frame-pointer -fforce-addr
+}
# gcc produce unstable binaries if compiled with a different CHOST.
[ "${ARCH}" = "hppa" ] && export CHOST="hppa-unknown-linux-gnu"
@@ -109,6 +95,7 @@ HOMEPAGE="http://www.gnu.org/software/gcc/gcc.html"
LICENSE="GPL-2 LGPL-2.1"
# SpanKY says hppa is a no go with any 3.3.x
KEYWORDS="-* -hppa arm ~x86 ~sparc ~amd64"
+IUSE="static nls bootstrap java build X multilib gcj f77 objc hardened uclibc debug"
# Ok, this is a hairy one again, but lets assume that we
# are not cross compiling, than we want SLOT to only contain
@@ -417,7 +404,6 @@ src_unpack() {
}
src_compile() {
-
local myconf=
local gcc_lang=
@@ -484,13 +470,8 @@ src_compile() {
myconf="${myconf} --disable-__cxa_atexit --enable-target-optspace --with-gnu-ld --enable-sjlj-exceptions"
fi
- # In general gcc does not like optimization, and add -O2 where
- export CFLAGS="$(echo "${CFLAGS}" | sed -e 's|-O[0-9s]\?|-O2|g')"
- einfo "CFLAGS=\"${CFLAGS}\""
- export CXXFLAGS="$(echo "${CXXFLAGS}" | sed -e 's|-O[0-9s]\?|-O2|g')"
- einfo "CXXFLAGS=\"${CXXFLAGS}\""
- export GCJFLAGS="$(echo "${GCJFLAGS}" | sed -e 's|-O[0-9s]\?|-O2|g')"
- einfo "GCJFLAGS=\"${GCJFLAGS}\""
+ # Make sure we have sane CFLAGS
+ do_filter_flags
# Build in a separate build tree
mkdir -p ${WORKDIR}/build
diff --git a/sys-devel/gcc/gcc-3.3.3-r6.ebuild b/sys-devel/gcc/gcc-3.3.3-r6.ebuild
index 879eadfdf7e4..4910a1291105 100644
--- a/sys-devel/gcc/gcc-3.3.3-r6.ebuild
+++ b/sys-devel/gcc/gcc-3.3.3-r6.ebuild
@@ -1,35 +1,21 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.3-r6.ebuild,v 1.14 2004/07/20 15:23:31 pappy Exp $
-
-IUSE="static nls bootstrap java build X multilib gcj f77 objc pic hardened uclibc debug"
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.3-r6.ebuild,v 1.15 2004/07/20 18:33:46 vapier Exp $
inherit eutils flag-o-matic libtool gnuconfig
-# Compile problems with these (bug #6641 among others)...
-#filter-flags "-fno-exceptions -fomit-frame-pointer -fforce-addr"
-
-# Recently there has been a lot of stability problem in Gentoo-land. Many
-# things can be the cause to this, but I believe that it is due to gcc3
-# still having issues with optimizations, or with it not filtering bad
-# combinations (protecting the user maybe from himeself) yet.
-#
-# This can clearly be seen in large builds like glibc, where too aggressive
-# CFLAGS cause the tests to fail miserbly.
-#
-# Quote from Nick Jones <carpaski@gentoo.org>, who in my opinion
-# knows what he is talking about:
-#
-# People really shouldn't force code-specific options on... It's a
-# bad idea. The -march options aren't just to look pretty. They enable
-# options that are sensible (and include sse,mmx,3dnow when apropriate).
-#
-# The next command strips CFLAGS and CXXFLAGS from nearly all flags. If
-# you do not like it, comment it, but do not bugreport if you run into
+# The next command strips most flags from CFLAGS/CXXFLAGS. If you do
+# not like it, comment it out, but do not file bugreports if you run into
# problems.
-#
-# <azarah@gentoo.org> (13 Oct 2002)
-strip-flags
+do_filter_flags() {
+ strip-flags
+
+ # In general gcc does not like optimization ... we'll add -O2 where safe
+ filter-flags -O?
+
+ # Compile problems with these (bug #6641 among others)...
+ #filter-flags -fno-exceptions -fomit-frame-pointer -fforce-addr
+}
# gcc produce unstable binaries if compiled with a different CHOST.
[ "${ARCH}" = "hppa" ] && export CHOST="hppa-unknown-linux-gnu"
@@ -110,6 +96,7 @@ LICENSE="GPL-2 LGPL-2.1"
## desired KEYWORDS="~sparc ~x86"
## KEYWORDS="-* -hppa arm ~x86 ~sparc ~amd64"
KEYWORDS="x86 amd64 mips"
+IUSE="static nls bootstrap java build X multilib gcj f77 objc pic hardened uclibc debug"
# Ok, this is a hairy one again, but lets assume that we
# are not cross compiling, than we want SLOT to only contain
@@ -429,7 +416,6 @@ src_unpack() {
}
src_compile() {
-
local myconf=
local gcc_lang=
@@ -494,13 +480,8 @@ src_compile() {
myconf="${myconf} --disable-__cxa_atexit --enable-target-optspace --with-gnu-ld --enable-sjlj-exceptions"
fi
- # In general gcc does not like optimization, and add -O2 where
- export CFLAGS="$(echo "${CFLAGS}" | sed -e 's|-O[0-9s]\?|-O2|g')"
- einfo "CFLAGS=\"${CFLAGS}\""
- export CXXFLAGS="$(echo "${CXXFLAGS}" | sed -e 's|-O[0-9s]\?|-O2|g')"
- einfo "CXXFLAGS=\"${CXXFLAGS}\""
- export GCJFLAGS="$(echo "${GCJFLAGS}" | sed -e 's|-O[0-9s]\?|-O2|g')"
- einfo "GCJFLAGS=\"${GCJFLAGS}\""
+ # Make sure we have sane CFLAGS
+ do_filter_flags
# Build in a separate build tree
mkdir -p ${WORKDIR}/build
diff --git a/sys-devel/gcc/gcc-3.3.4-r1.ebuild b/sys-devel/gcc/gcc-3.3.4-r1.ebuild
index c53931757f86..4f813714ab4f 100644
--- a/sys-devel/gcc/gcc-3.3.4-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.3.4-r1.ebuild
@@ -1,35 +1,21 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.4-r1.ebuild,v 1.3 2004/07/14 23:28:59 lv Exp $
-
-IUSE="static nls bootstrap build X multilib gcj f77 objc pic hardened uclibc debug"
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.4-r1.ebuild,v 1.4 2004/07/20 18:33:46 vapier Exp $
inherit eutils flag-o-matic libtool gnuconfig
-# Compile problems with these (bug #6641 among others)...
-#filter-flags "-fno-exceptions -fomit-frame-pointer -fforce-addr"
-
-# Recently there has been a lot of stability problem in Gentoo-land. Many
-# things can be the cause to this, but I believe that it is due to gcc3
-# still having issues with optimizations, or with it not filtering bad
-# combinations (protecting the user maybe from himeself) yet.
-#
-# This can clearly be seen in large builds like glibc, where too aggressive
-# CFLAGS cause the tests to fail miserbly.
-#
-# Quote from Nick Jones <carpaski@gentoo.org>, who in my opinion
-# knows what he is talking about:
-#
-# People really shouldn't force code-specific options on... It's a
-# bad idea. The -march options aren't just to look pretty. They enable
-# options that are sensible (and include sse,mmx,3dnow when apropriate).
-#
-# The next command strips CFLAGS and CXXFLAGS from nearly all flags. If
-# you do not like it, comment it, but do not bugreport if you run into
+# The next command strips most flags from CFLAGS/CXXFLAGS. If you do
+# not like it, comment it out, but do not file bugreports if you run into
# problems.
-#
-# <azarah@gentoo.org> (13 Oct 2002)
-strip-flags
+do_filter_flags() {
+ strip-flags
+
+ # In general gcc does not like optimization ... we'll add -O2 where safe
+ filter-flags -O?
+
+ # Compile problems with these (bug #6641 among others)...
+ #filter-flags -fno-exceptions -fomit-frame-pointer -fforce-addr
+}
# gcc produce unstable binaries if compiled with a different CHOST.
[ "${ARCH}" = "hppa" ] && export CHOST="hppa-unknown-linux-gnu"
@@ -110,6 +96,7 @@ LICENSE="GPL-2 LGPL-2.1"
## SpanKY says hppa is a no go with any 3.3.x
# desire ~sparc
KEYWORDS="-hppa ~x86 ~amd64 ~mips ~arm"
+IUSE="static nls bootstrap build X multilib gcj f77 objc pic hardened uclibc debug"
# Ok, this is a hairy one again, but lets assume that we
# are not cross compiling, than we want SLOT to only contain
@@ -432,7 +419,6 @@ src_unpack() {
}
src_compile() {
-
local myconf=
local gcc_lang=
@@ -497,13 +483,8 @@ src_compile() {
myconf="${myconf} --disable-__cxa_atexit --enable-target-optspace --with-gnu-ld --enable-sjlj-exceptions"
fi
- # In general gcc does not like optimization, and add -O2 where
- export CFLAGS="$(echo "${CFLAGS}" | sed -e 's|-O[0-9s]\?|-O2|g')"
- einfo "CFLAGS=\"${CFLAGS}\""
- export CXXFLAGS="$(echo "${CXXFLAGS}" | sed -e 's|-O[0-9s]\?|-O2|g')"
- einfo "CXXFLAGS=\"${CXXFLAGS}\""
- export GCJFLAGS="$(echo "${GCJFLAGS}" | sed -e 's|-O[0-9s]\?|-O2|g')"
- einfo "GCJFLAGS=\"${GCJFLAGS}\""
+ # Make sure we have sane CFLAGS
+ do_filter_flags
# Build in a separate build tree
mkdir -p ${WORKDIR}/build
diff --git a/sys-devel/gcc/gcc-3.3.4.ebuild b/sys-devel/gcc/gcc-3.3.4.ebuild
index 12452b3f8092..258baef9d7c6 100644
--- a/sys-devel/gcc/gcc-3.3.4.ebuild
+++ b/sys-devel/gcc/gcc-3.3.4.ebuild
@@ -1,35 +1,21 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.4.ebuild,v 1.7 2004/07/14 23:28:59 lv Exp $
-
-IUSE="static nls bootstrap build X multilib gcj f77 objc pic hardened uclibc debug"
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.4.ebuild,v 1.8 2004/07/20 18:33:46 vapier Exp $
inherit eutils flag-o-matic libtool gnuconfig
-# Compile problems with these (bug #6641 among others)...
-#filter-flags "-fno-exceptions -fomit-frame-pointer -fforce-addr"
-
-# Recently there has been a lot of stability problem in Gentoo-land. Many
-# things can be the cause to this, but I believe that it is due to gcc3
-# still having issues with optimizations, or with it not filtering bad
-# combinations (protecting the user maybe from himeself) yet.
-#
-# This can clearly be seen in large builds like glibc, where too aggressive
-# CFLAGS cause the tests to fail miserbly.
-#
-# Quote from Nick Jones <carpaski@gentoo.org>, who in my opinion
-# knows what he is talking about:
-#
-# People really shouldn't force code-specific options on... It's a
-# bad idea. The -march options aren't just to look pretty. They enable
-# options that are sensible (and include sse,mmx,3dnow when apropriate).
-#
-# The next command strips CFLAGS and CXXFLAGS from nearly all flags. If
-# you do not like it, comment it, but do not bugreport if you run into
+# The next command strips most flags from CFLAGS/CXXFLAGS. If you do
+# not like it, comment it out, but do not file bugreports if you run into
# problems.
-#
-# <azarah@gentoo.org> (13 Oct 2002)
-strip-flags
+do_filter_flags() {
+ strip-flags
+
+ # In general gcc does not like optimization ... we'll add -O2 where safe
+ filter-flags -O?
+
+ # Compile problems with these (bug #6641 among others)...
+ #filter-flags -fno-exceptions -fomit-frame-pointer -fforce-addr
+}
# gcc produce unstable binaries if compiled with a different CHOST.
[ "${ARCH}" = "hppa" ] && export CHOST="hppa-unknown-linux-gnu"
@@ -110,6 +96,7 @@ LICENSE="GPL-2 LGPL-2.1"
## desired KEYWORDS="~sparc ~x86"
## KEYWORDS="-* -hppa arm ~x86 ~sparc ~amd64"
KEYWORDS="-*"
+IUSE="static nls bootstrap build X multilib gcj f77 objc pic hardened uclibc debug"
# Ok, this is a hairy one again, but lets assume that we
# are not cross compiling, than we want SLOT to only contain
@@ -431,7 +418,6 @@ src_unpack() {
}
src_compile() {
-
local myconf=
local gcc_lang=
@@ -496,13 +482,8 @@ src_compile() {
myconf="${myconf} --disable-__cxa_atexit --enable-target-optspace --with-gnu-ld --enable-sjlj-exceptions"
fi
- # In general gcc does not like optimization, and add -O2 where
- export CFLAGS="$(echo "${CFLAGS}" | sed -e 's|-O[0-9s]\?|-O2|g')"
- einfo "CFLAGS=\"${CFLAGS}\""
- export CXXFLAGS="$(echo "${CXXFLAGS}" | sed -e 's|-O[0-9s]\?|-O2|g')"
- einfo "CXXFLAGS=\"${CXXFLAGS}\""
- export GCJFLAGS="$(echo "${GCJFLAGS}" | sed -e 's|-O[0-9s]\?|-O2|g')"
- einfo "GCJFLAGS=\"${GCJFLAGS}\""
+ # Make sure we have sane CFLAGS
+ do_filter_flags
# Build in a separate build tree
mkdir -p ${WORKDIR}/build