summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-09-08 18:14:27 +0000
committerMike Frysinger <vapier@gentoo.org>2004-09-08 18:14:27 +0000
commit9e18dff9a767d257f1aa901e9470198e1d1e300e (patch)
tree79ea649a90d3451dab82a5a7c18e1e9545c97591 /sys-devel
parentVersion bumped. Thanks to Adam Piatyszek <ediap@et.put.poznan.pl>, closing bu... (diff)
downloadgentoo-2-9e18dff9a767d257f1aa901e9470198e1d1e300e.tar.gz
gentoo-2-9e18dff9a767d257f1aa901e9470198e1d1e300e.tar.bz2
gentoo-2-9e18dff9a767d257f1aa901e9470198e1d1e300e.zip
merge -r2 back into -r1
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils/ChangeLog6
-rw-r--r--sys-devel/binutils/binutils-2.14.90.0.8-r1.ebuild23
-rw-r--r--sys-devel/binutils/binutils-2.14.90.0.8-r2.ebuild185
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.14.90.0.8-r12
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.14.90.0.8-r22
5 files changed, 24 insertions, 194 deletions
diff --git a/sys-devel/binutils/ChangeLog b/sys-devel/binutils/ChangeLog
index d0e3ba7a53d3..04a1f7e4d6f8 100644
--- a/sys-devel/binutils/ChangeLog
+++ b/sys-devel/binutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/binutils
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/ChangeLog,v 1.154 2004/09/07 00:37:05 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/ChangeLog,v 1.155 2004/09/08 18:14:27 vapier Exp $
+
+ 08 Sep 2004; Mike Frysinger <vapier@gentoo.org>
+ binutils-2.14.90.0.8-r1.ebuild, -binutils-2.14.90.0.8-r2.ebuild:
+ Merge the changes from -r2 back into -r1 since it was just uclibc specific.
06 Sep 2004; <solar@gentoo.org>
+files/2.15/binutils-2.15-elf32-arm-textrel.patch,
diff --git a/sys-devel/binutils/binutils-2.14.90.0.8-r1.ebuild b/sys-devel/binutils/binutils-2.14.90.0.8-r1.ebuild
index 86746904a2c6..d0d198698827 100644
--- a/sys-devel/binutils/binutils-2.14.90.0.8-r1.ebuild
+++ b/sys-devel/binutils/binutils-2.14.90.0.8-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.14.90.0.8-r1.ebuild,v 1.21 2004/09/02 17:28:09 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.14.90.0.8-r1.ebuild,v 1.22 2004/09/08 18:14:27 vapier Exp $
-inherit eutils libtool flag-o-matic
+inherit eutils libtool flag-o-matic gnuconfig
-PATCHVER="1.2"
+PATCHVER="1.3"
DESCRIPTION="Tools necessary to build programs"
HOMEPAGE="http://sources.redhat.com/binutils/"
SRC_URI="mirror://kernel/linux/devel/binutils/${P}.tar.bz2
@@ -14,7 +14,7 @@ SRC_URI="mirror://kernel/linux/devel/binutils/${P}.tar.bz2
LICENSE="GPL-2 | LGPL-2"
SLOT="0"
KEYWORDS="x86 ~ppc sparc mips alpha ~hppa amd64 ~ia64 ~ppc64 s390"
-IUSE="nls bootstrap build multitarget"
+IUSE="nls bootstrap build multitarget uclibc"
DEPEND="virtual/libc
nls? ( sys-devel/gettext )
@@ -29,6 +29,12 @@ src_unpack() {
mkdir ${WORKDIR}/patch/skip
mv ${WORKDIR}/patch/05* ${WORKDIR}/patch/skip/
+ # one of 38/39 has to be moved out of the way, both are backports of different relro versions
+ # 39 is more current, but not fully backported
+ mv ${WORKDIR}/patch/39_* ${WORKDIR}/patch/skip/
+
+ use uclibc && mv ${WORKDIR}/patch/*relro* ${WORKDIR}/patch/*sparc1* ${WORKDIR}/patch/skip/
+
epatch ${WORKDIR}/patch
# Libtool is broken (Redhat).
@@ -44,11 +50,13 @@ src_unpack() {
}' ${x}.orig > ${x}
rm -rf ${x}.orig
done
+
+ gnuconfig_update
}
src_compile() {
# Generate borked binaries. Bug #6730
- filter-flags -fomit-frame-pointer -fssa
+ filter-flags -fomit-frame-pointer -fssa -freduce-all-givs
local myconf=
[ ! -z "${CBUILD}" ] && myconf="--build=${CBUILD}"
@@ -168,4 +176,9 @@ src_install() {
else
rm -rf ${D}/usr/share/man
fi
+
+ use uclibc && rm -rf ${D}/usr/lib/ldscripts
+
+ # remove shared libs' links (.so) to build all apps against the static versions
+ use uclibc && rm -f ${D}/usr/lib/lib{bfd,opcodes}.so ${D}/usr/lib/lib*.la
}
diff --git a/sys-devel/binutils/binutils-2.14.90.0.8-r2.ebuild b/sys-devel/binutils/binutils-2.14.90.0.8-r2.ebuild
deleted file mode 100644
index f416ea84bee3..000000000000
--- a/sys-devel/binutils/binutils-2.14.90.0.8-r2.ebuild
+++ /dev/null
@@ -1,185 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.14.90.0.8-r2.ebuild,v 1.12 2004/09/02 17:28:09 vapier Exp $
-
-inherit eutils libtool flag-o-matic gnuconfig
-
-PATCHVER="1.3"
-DESCRIPTION="Tools necessary to build programs"
-HOMEPAGE="http://sources.redhat.com/binutils/"
-SRC_URI="mirror://kernel/linux/devel/binutils/${P}.tar.bz2
- mirror://kernel/linux/devel/binutils/test/${P}.tar.bz2
- mirror://gentoo/${P}-patches-${PATCHVER}.tar.bz2"
-
-LICENSE="GPL-2 | LGPL-2"
-SLOT="0"
-#KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~hppa ~amd64 ~ia64 ~ppc64 ~s390"
-KEYWORDS="-*"
-IUSE="nls bootstrap build multitarget uclibc"
-
-DEPEND="virtual/libc
- nls? ( sys-devel/gettext )
- !build? ( !bootstrap? ( dev-lang/perl ) )"
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
-
- # The prescott patch is not ready yet.
- mkdir ${WORKDIR}/patch/skip
- mv ${WORKDIR}/patch/05* ${WORKDIR}/patch/skip/
-
- # one of 38/39 has to be moved out of the way, both are backports of different relro versions
- # 39 is more current, but not fully backported
- mv ${WORKDIR}/patch/39_* ${WORKDIR}/patch/skip/
-
- use uclibc && mv ${WORKDIR}/patch/*relro* ${WORKDIR}/patch/*sparc1* ${WORKDIR}/patch/skip/
-
- epatch ${WORKDIR}/patch
-
- # Libtool is broken (Redhat).
- for x in ${S}/opcodes/Makefile.{am,in}
- do
- cp ${x} ${x}.orig
- gawk '
- {
- if ($0 ~ /LIBADD/)
- gsub("../bfd/libbfd.la", "-L../bfd/.libs ../bfd/libbfd.la")
-
- print
- }' ${x}.orig > ${x}
- rm -rf ${x}.orig
- done
-
- gnuconfig_update
-}
-
-src_compile() {
- # Generate borked binaries. Bug #6730
- filter-flags -fomit-frame-pointer -fssa -freduce-all-givs
-
- local myconf=
- [ ! -z "${CBUILD}" ] && myconf="--build=${CBUILD}"
- use nls && \
- myconf="${myconf} --without-included-gettext" || \
- myconf="${myconf} --disable-nls"
- use multitarget && myconf="${myconf} --enable-targets=all"
-
- # Filter CFLAGS=".. -O2 .." on arm
- use arm && replace-flags -O? -O
- # GCC 3.4 miscompiles binutils unless CFLAGS are conservative #47581
- has_version "=sys-devel/gcc-3.4*" && strip-flags && replace-flags -O3 -O2
-
- # Fix /usr/lib/libbfd.la
- elibtoolize --portage
-
- ./configure --enable-shared \
- --enable-64-bit-bfd \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --host=${CHOST} \
- ${myconf} || die
-
- make configure-bfd || die
- make headers -C bfd || die
- emake tooldir="${ROOT}/usr/bin" \
- all || die
-
- if ! use build
- then
- if ! use bootstrap
- then
- # Nuke the manpages to recreate them (only use this if we have perl)
- find . -name '*.1' -exec rm -f {} \; || :
- fi
- # Make the info pages (makeinfo included with gcc is used)
- make info || die
- fi
-}
-
-src_install() {
-
- make prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install || die
-
- insinto /usr/include
- doins include/libiberty.h
-
- # c++filt is included with gcc -- what are these GNU people thinking?
- # but not the manpage, so leave that!
-# We install it now, as gcc-3.3 do not have it any longer ...
-# rm -f ${D}/usr/bin/c++filt #${D}/usr/share/man/man1/c++filt*
-
- # By default strip has a symlink going from /usr/${CHOST}/bin/strip to
- # /usr/bin/strip we should reverse it:
-
- rm ${D}/usr/${CHOST}/bin/strip; mv ${D}/usr/bin/strip ${D}/usr/${CHOST}/bin/strip
- # The strip symlink gets created in the loop below
-
- # By default ar, as, ld, nm, ranlib and strip are in two places; create
- # symlinks. This will reduce the size of the tbz2 significantly. We also
- # move all the stuff in /usr/bin to /usr/${CHOST}/bin and create the
- # appropriate symlinks. Things are cleaner that way.
- cd ${D}/usr/bin
- local x=
- for x in * strip
- do
- if [ ! -e ../${CHOST}/bin/${x} ]
- then
- mv ${x} ../${CHOST}/bin/${x}
- else
- rm -f ${x}
- fi
- ln -s ../${CHOST}/bin/${x} ${x}
- done
-
- if [ -n "${PROFILE_ARCH}" ] && \
- [ "${PROFILE_ARCH/64}" != "${PROFILE_ARCH}" ]
- then
- dosym ${CHOST} /usr/${CHOST/-/64-}
-
- for x in `ls ${D}/usr/${CHOST}/bin/`
- do
- [ ! -e "${D}/usr/bin/${CHOST}-${x}" ] && \
- dosym ../${CHOST}/bin/${x} /usr/bin/${CHOST}-${x}
- dosym ../${CHOST}/bin/${x} /usr/bin/${CHOST/-/64-}-${x}
- done
- fi
-
- cd ${S}
- if ! use build
- then
- make prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install-info || die
-
- dodoc COPYING* README
- docinto bfd
- dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
- docinto binutils
- dodoc binutils/ChangeLog binutils/NEWS binutils/README
- docinto gas
- dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING gas/NEWS gas/README*
- docinto gprof
- dodoc gprof/ChangeLog* gprof/TEST gprof/TODO gprof/bbconv.pl
- docinto ld
- dodoc ld/ChangeLog* ld/README ld/NEWS ld/TODO
- docinto libiberty
- dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
- docinto opcodes
- dodoc opcodes/ChangeLog*
- # Install pre-generated manpages .. currently we do not ...
- else
- rm -rf ${D}/usr/share/man
- fi
-
- use uclibc && rm -rf ${D}/usr/lib/ldscripts
-
- # remove shared libs' links (.so) to build all apps against the static versions
- use uclibc && rm -f ${D}/usr/lib/lib{bfd,opcodes}.so ${D}/usr/lib/lib*.la
-}
diff --git a/sys-devel/binutils/files/digest-binutils-2.14.90.0.8-r1 b/sys-devel/binutils/files/digest-binutils-2.14.90.0.8-r1
index 8a6a246359be..4d797f26e732 100644
--- a/sys-devel/binutils/files/digest-binutils-2.14.90.0.8-r1
+++ b/sys-devel/binutils/files/digest-binutils-2.14.90.0.8-r1
@@ -1,2 +1,2 @@
MD5 3e28792a585e14b57838cd24130a24dd binutils-2.14.90.0.8.tar.bz2 11015696
-MD5 05e6d5ab389e85300179d833f700c258 binutils-2.14.90.0.8-patches-1.2.tar.bz2 20117
+MD5 f03ab83098e3fa1d5cfdc2012655617f binutils-2.14.90.0.8-patches-1.3.tar.bz2 121243
diff --git a/sys-devel/binutils/files/digest-binutils-2.14.90.0.8-r2 b/sys-devel/binutils/files/digest-binutils-2.14.90.0.8-r2
deleted file mode 100644
index 4d797f26e732..000000000000
--- a/sys-devel/binutils/files/digest-binutils-2.14.90.0.8-r2
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 3e28792a585e14b57838cd24130a24dd binutils-2.14.90.0.8.tar.bz2 11015696
-MD5 f03ab83098e3fa1d5cfdc2012655617f binutils-2.14.90.0.8-patches-1.3.tar.bz2 121243